Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 112427 - ati-drivers don't create a useful /usr/lib/libGL.la
Summary: ati-drivers don't create a useful /usr/lib/libGL.la
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Highest major (vote)
Assignee: X11 External Driver Maintainers
URL:
Whiteboard:
Keywords:
: 115790 115939 116849 116917 117147 117309 118238 118785 119824 120330 123133 124547 124644 125129 131722 288873 (view as bug list)
Depends on: 115816
Blocks:
  Show dependency tree
 
Reported: 2005-11-13 09:09 UTC by Thomas Schlesinger
Modified: 2009-10-13 16:46 UTC (History)
24 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch for ati-drivers-8.20.8.ebuild (ati-drivers-8.20.8.patch,1005 bytes, patch)
2005-12-18 11:52 UTC, Joël
Details | Diff
sets $X11_IMPLM to xorg-x11 for <x11-base/xorg-x11-6.99 (ati-drivers-8.21.7-r1.ebuild.patch,234 bytes, patch)
2006-01-27 14:21 UTC, Yang Zhao
Details | Diff
xorg-x11-6.8.0 compatability (ati-drivers-8.21.7-r1.ebuild.patch,733 bytes, patch)
2006-02-02 21:33 UTC, Yang Zhao
Details | Diff
xorg-x11-6.8.0 compatability patch (ati-drivers-8.21.7-r1.patch,658 bytes, patch)
2006-02-02 21:38 UTC, Yang Zhao
Details | Diff
xorg-x11-6.8.0 compatability patch (ati-drivers-8.21.7-r1.patch,658 bytes, patch)
2006-02-02 21:44 UTC, Yang Zhao
Details | Diff
xorg-x11-6.8.* compatability patch for 8.22.5 (ati-drivers-8.22.5-r1.patch,441 bytes, patch)
2006-02-13 01:00 UTC, Yang Zhao
Details | Diff
79661: xorg-x11-6.8.* compatability patch for 8.22.5 (ati-drivers-8.22.5-r1.patch,441 bytes, patch)
2006-02-13 13:04 UTC, Yang Zhao
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Schlesinger 2005-11-13 09:09:25 UTC
The /usr/lib/libGL.la, built by ati-drivers-8.19.10, has a size of 0 byte.   
Ebuilds, who use the file for linking, like kopete, are stopping with an error   
message.  
  
My quick & dirty workaround is to switch opengl to the xorg-ati-driver before 
emerging and switching back after. 

Reproducible: Always
Steps to Reproduce:
emerge ati-drivers 
emerge a package that uses this file 
 
Actual Results:  
see details 

Expected Results:  
A useful /usr/lib/libGL.la should be built 

Portage 2.0.53_rc7 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r3, 
2.6.14-gentoo i686) 
================================================================= 
System uname: 2.6.14-gentoo i686 Intel(R) Pentium(R) M processor 1.73GHz 
Gentoo Base System version 1.12.0_pre10 
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) 
[disabled] 
dev-lang/python:     2.3.5, 2.4.2 
sys-apps/sandbox:    1.2.13 
sys-devel/autoconf:  2.13, 2.59-r7 
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1 
sys-devel/binutils:  2.16.1 
sys-devel/libtool:   1.5.20-r1 
virtual/os-headers:  2.6.11-r2 
ACCEPT_KEYWORDS="x86 ~x86" 
AUTOCLEAN="yes" 
CBUILD="i686-pc-linux-gnu" 
CFLAGS="-O3 -march=pentium-m -pipe -fomit-frame-pointer" 
CHOST="i686-pc-linux-gnu" 
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/texmf/web2c /etc/env.d" 
CXXFLAGS="-O3 -march=pentium-m -pipe -fomit-frame-pointer" 
DISTDIR="/usr/portage/distfiles" 
FEATURES="autoconfig distlocks sandbox sfperms strict" 
GENTOO_MIRRORS="http://distfiles.gentoo.org 
http://distro.ibiblio.org/pub/linux/distributions/gentoo" 
LANG="de_DE" 
LC_ALL="en_US" 
LINGUAS="de" 
MAKEOPTS="-j2" 
PKGDIR="/usr/portage/packages" 
PORTAGE_TMPDIR="/var/tmp" 
PORTDIR="/usr/portage" 
PORTDIR_OVERLAY="/usr/local/portage" 
SYNC="rsync://rsync.gentoo.org/gentoo-portage" 
USE="x86 X a52 acl acpi alsa apm arts audiofile avi berkdb bitmap-fonts bzip2 
cdr crypt cups curl divx4linux dri dts dv dvb dvd dvdread eds emboss encode 
esd exif expat fam fame ffmpeg flac foomaticdb fortran gdbm gif glut gmp gpm 
gstreamer gtk2 guile idn imagemagick imlib ipv6 irmc java jpeg junit kde 
kdepim kdexdeltas lcms libg++ libwww mad matroska mikmod mmx mmxext mng motif 
mp3 mpeg ncurses nls ogg oggvorbis opengl oss pam pcre pda pdflib perl png 
python qt quicktime readline recode samba scanner sdl speex spell sqlite sse 
ssl subtitles svg svga tcltk tcpd tetex tiff truetype truetype-fonts 
type1-fonts udev usb uselocales visualization vorbis xine xml2 xmms xv xvid 
zeroconf zlib linguas_de userland_GNU kernel_linux elibc_glibc" 
Unset:  ASFLAGS, CTARGET, LDFLAGS
Comment 1 Luca Barbato gentoo-dev 2005-11-13 10:45:47 UTC
the file should be a symlink pointing to the x11 implemented libGL.la, I'll
provide one soon.
Comment 2 Luca Barbato gentoo-dev 2005-11-14 15:05:06 UTC
could you please paste a readlink /usr/lib/opengl/ati/lib/libGL.la
Comment 3 Luca Barbato gentoo-dev 2005-11-14 16:52:48 UTC
looks like you don't have mesa installed. I'll check if it could be avoided but
I think not.
Comment 4 Thomas Schlesinger 2005-11-15 07:48:19 UTC
Luca,   
   
I've installed media-libs/mesa 6.4 on my notebook.   
   
This is the readlink and ls on libGL.la:  
SchlesisNB thomas # readlink /usr/lib/opengl/ati/lib/libGL.la 
SchlesisNB thomas # ls -al /usr/lib/opengl/ati/lib/libGL.la 
-rw-r--r--  1 root root 0 2005-11-14 18:27 /usr/lib/opengl/ati/lib/libGL.la 
   
Comment 5 Luca Barbato gentoo-dev 2005-11-15 08:10:31 UTC
the libGL.la is generated by a sed line. If you emerge again it you'll get the
correct libtool file.
Comment 6 Thomas Schlesinger 2005-11-15 08:23:13 UTC
I have re-emerged ati-drivers, but same result:  
SchlesisNB thomas # ls -al /usr/lib/libGL.la  
-rw-r--r--  1 root root 0 2005-11-15 17:25 /usr/lib/libGL.la  
SchlesisNB thomas # ls -al /usr/lib/opengl/ati/lib/libGL.la  
-rw-r--r--  1 root root 0 2005-11-15 17:23 /usr/lib/opengl/ati/lib/libGL.la  
  
BTW: if it helps, you can reach me via Chat: aim:schlesix/icq:167371362. 
Comment 7 Sonny Lander 2005-12-15 21:37:19 UTC
I have the same problem, Tho i thought it was caused by a problem i have with
virtual/x11 the ebuild things it needs 
/var/tmp/portage/ati-drivers-8.20.8/work/x8200/lib/modules/fglrx/build_mod/libfglrx_ip.a.GCC4
which does not exist, and i have no idea why i thinks my X11 version is 820, i
have to edit the ebuild to get passed that part and then i come up with the
empty libGL.la well thats all i can give, willing to help track this down anyway
i can.
Comment 8 Joël 2005-12-18 08:00:22 UTC
At a first glance, it seems the ${X11_IMPLEM} variable contains "x11" instead of "xorg-x11", which gives a non-existing filename as input for sed.

Please try the following patch:

--- ati-drivers-8.20.8.ebuild.orig      2005-12-11 04:55:47.000000000 +0100
+++ ati-drivers-8.20.8.ebuild   2005-12-18 16:51:19.000000000 +0100
@@ -46,6 +46,7 @@
                   [ "$(get_version_component_range 3 ${X11_IMPLEM_V})" = 99 ]
                then
                        BASE_NAME="${BASE_NAME}90"
+                       xlibdir="xorg"
                else
                        BASE_NAME="${BASE_NAME}$(get_version_component_range 2 ${X11_IMPLEM_V})0"
                fi
@@ -238,7 +239,7 @@
        #Workaround
        if use opengl ; then
        sed -e "s:libdir=.*:libdir=${ATI_ROOT}/lib:" \
-               /usr/$(get_libdir)/opengl/${X11_IMPLEM}/lib/libGL.la \
+               /usr/$(get_libdir)/opengl/xorg-x11/lib/libGL.la \
                > $D/${ATI_ROOT}/lib/libGL.la
        dosym ../${X11_IMPLEM}/include ${ATI_ROOT}/include
        fi


Note 1: the patch also contains a hack I made, so the fglrx DRI modules are put in the proper directory, and no "module_path" directive is needed in xorg.conf anymore :-)

Note 2: there are other uses of ${X11_IMPLEM} as a path element (you can see one of them at the bottom of the diff). I haven't verified if they are correct.
Comment 9 Joshua Baergen (RETIRED) gentoo-dev 2005-12-18 10:21:52 UTC
*** Bug 115939 has been marked as a duplicate of this bug. ***
Comment 10 Joël 2005-12-18 11:52:36 UTC
Created attachment 75035 [details, diff]
Patch for ati-drivers-8.20.8.ebuild

Better patch for the ati-drivers-8.20.8 ebuild. There's probably a better way to fix it -- so please advise :-)
Comment 11 Jory A. Pratt 2005-12-18 15:33:36 UTC
I am pointing you all to the update ebuild for modular X that has been shown to fix all but one small symlink which I will work out tomorrow, unless lu_zero gets to it before me.
Comment 12 Jory A. Pratt 2005-12-18 17:19:49 UTC
Fixed in CVS.
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2005-12-27 02:59:38 UTC
*** Bug 116849 has been marked as a duplicate of this bug. ***
Comment 14 Jakub Moc (RETIRED) gentoo-dev 2005-12-27 13:14:44 UTC
*** Bug 116917 has been marked as a duplicate of this bug. ***
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2005-12-30 01:42:11 UTC
*** Bug 117147 has been marked as a duplicate of this bug. ***
Comment 16 Jakub Moc (RETIRED) gentoo-dev 2005-12-30 01:43:07 UTC
People keep filing duplicates even with 8.20.8, this does not look like fixed.

Reopen.
Comment 17 Jakub Moc (RETIRED) gentoo-dev 2006-01-01 02:30:01 UTC
*** Bug 117309 has been marked as a duplicate of this bug. ***
Comment 18 Tobias Sager 2006-01-05 01:56:37 UTC
Just hit this problem while compiling xine-lib.
I am running ati-drivers 8.20.8. What's the workaround or solution for this?
Comment 19 Joël 2006-01-05 02:31:29 UTC
Just a random guess: maybe it got fixed for modular X users only ?
Comment 20 Jakub Moc (RETIRED) gentoo-dev 2006-01-07 17:33:26 UTC
*** Bug 118238 has been marked as a duplicate of this bug. ***
Comment 21 Jakub Moc (RETIRED) gentoo-dev 2006-01-07 17:35:09 UTC
*** Bug 115790 has been marked as a duplicate of this bug. ***
Comment 22 Sergey Shkoliarenko 2006-01-08 14:33:50 UTC
Workaround:
# cp -f /usr/lib/opengl/xorg-x11/lib/libGL.la /usr/lib/libGL.la
It worked for me. Try and enjoy :)
Comment 23 david cooper 2006-01-10 05:46:19 UTC
(In reply to comment #22)
> Workaround:
> # cp -f /usr/lib/opengl/xorg-x11/lib/libGL.la /usr/lib/libGL.la
> It worked for me. Try and enjoy :)

This enables compilation of software, but if you don't switch back to the ATI file, you will get DRI failure and no hardware features. Check your Xorg.0.log. Instead of cp -f you can use 'eselect opengl set xorg-x11' to accomplish the same thing.
Comment 24 Jakub Moc (RETIRED) gentoo-dev 2006-01-12 08:57:42 UTC
*** Bug 118785 has been marked as a duplicate of this bug. ***
Comment 25 Scott Stoddard (RETIRED) gentoo-dev 2006-01-20 15:55:13 UTC
still a problem in 8.20.8...
Comment 26 Jakub Moc (RETIRED) gentoo-dev 2006-01-21 08:03:59 UTC
*** Bug 119824 has been marked as a duplicate of this bug. ***
Comment 27 CHH 2006-01-22 05:07:57 UTC
(In reply to comment #23)
> (In reply to comment #22)
> > Workaround:
> > # cp -f /usr/lib/opengl/xorg-x11/lib/libGL.la /usr/lib/libGL.la
> > It worked for me. Try and enjoy :)
> 
> This enables compilation of software, but if you don't switch back to the ATI
> file, you will get DRI failure and no hardware features. Check your Xorg.0.log.
> Instead of cp -f you can use 'eselect opengl set xorg-x11' to accomplish the
> same thing.
> 

The workaround i used was to do the cp -f and change the last line of /usr/lib/libGL.la from:

    libdir='/usr/lib/opengl/xorg-x11/lib'
to

    libdir='/usr/lib/opengl/ati/lib'

Don't know about impacts other than to do this whenever ati-drivers is emerge'd again...
Comment 28 Jakub Moc (RETIRED) gentoo-dev 2006-01-25 12:14:51 UTC
*** Bug 120330 has been marked as a duplicate of this bug. ***
Comment 29 Jakub Moc (RETIRED) gentoo-dev 2006-01-25 12:17:32 UTC
OK, is someone looking into this, please? It's breaking a lot of packages and it's really annoying.
Comment 30 Jory A. Pratt 2006-01-25 12:29:27 UTC
Wed Jan 25 02:20 PM 
[ anarchy - ~ ] ls -al /usr/lib64/libGL.la 
-rw-r--r--  1 root root 758 Jan 23 11:36 /usr/lib64/libGL.la
Wed Jan 25 02:21 PM 
[ anarchy - ~ ] ls -al /usr/lib64/opengl/ati/lib/libGL.la 
-rw-r--r--  1 root root 758 Jan 23 11:35 /usr/lib64/opengl/ati/lib/libGL.la

Once again I am unable to replicate the problem even with my stable setup. Also is anyone that is having problems using anything other then x86?
Comment 31 Jakub Moc (RETIRED) gentoo-dev 2006-01-25 12:39:17 UTC
(In reply to comment #30)
> Also is anyone that is having problems using anything other then x86?

The last dupe is amd64.

Comment 32 Yang Zhao 2006-01-26 19:30:11 UTC
confirmed for 8.21.7 on x86
Comment 33 Ian Gowen 2006-01-26 20:00:10 UTC
(In reply to comment #32)
> confirmed for 8.21.7 on x86

Ditto. Why hasn't this been addressed yet?
Comment 34 Jory A. Pratt 2006-01-27 06:07:03 UTC
cause it is not the package that is busted. It is opengl-update or eselect that is causing you all problems.
Comment 35 Tobias Sager 2006-01-27 07:18:55 UTC
Yes, it's the package.

Just had a look at it. The problem on my machine is the detection of X11_IMPLEM is going wrong in the ebuild.
It detects virtual/x11-6.8 as best_version and then seds that down to x11 which is wrong. Correct would be xorg-x11. I don't know how to get that though. (How do you resolve virtuals to providers?)

Now, because the X11_IMPLEM is wrong, the sed on libGL.la of opengl (in xorg-x11) fails (as do the symlinks to extensions and include) and libGL.la is created as empty file.


Another question: shouldn't the symlink to extensions be created for `use opengl` only? (As the symlink for directory include.)

And finally, one more thing:
<snip>
--- ati-drivers-8.21.7.ebuild.org       2006-01-27 15:37:36.000000000 +0100
+++ ati-drivers-8.21.7.ebuild   2006-01-27 16:06:27.000000000 +0100
@@ -287,7 +287,7 @@
                doexe ${BASE_DIR}/usr/X11R6/${pkglibdir}/modules/linux/libfglrxdrm.so
        fi
 
-       cp -pPR ${ARCH_DIR}/usr/X11R6/${pkglibdir}/lib{fglrx_*,aticonfig} \
+       cp -pPR ${ARCH_DIR}/usr/X11R6/${pkglibdir}/lib{fglrx_*,aticonfig.a} \
                        ${D}/usr/$(get_libdir)
        #Not the best place
        insinto ${X11_DIR}/include/X11/extensions
</snip>
Comment 36 Caleb Cushing 2006-01-27 08:38:04 UTC
(In reply to comment #34)
> cause it is not the package that is busted. It is opengl-update or eselect that
> is causing you all problems.
> 

forgive me if I'm wrong but don't open-gl and eselect come with packages? if it's not ati-driver's that's broken. then fix the package that's causing the problem and make it a dependancy.
Comment 37 Yang Zhao 2006-01-27 14:21:20 UTC
Created attachment 78302 [details, diff]
sets $X11_IMPLM to xorg-x11 for <x11-base/xorg-x11-6.99

Please check validity for >=x11-base/xorg-x11-6.99

Should work for <6.99
Comment 38 Yang Zhao 2006-02-02 21:33:07 UTC
Created attachment 78785 [details, diff]
xorg-x11-6.8.0 compatability
Comment 39 Yang Zhao 2006-02-02 21:38:16 UTC
Created attachment 78786 [details, diff]
xorg-x11-6.8.0 compatability patch

Updated patch -- forgot to delete a few useless einfo lines I was using during debug
Comment 40 Yang Zhao 2006-02-02 21:44:36 UTC
Created attachment 78787 [details, diff]
xorg-x11-6.8.0 compatability patch

gah! My brain just isn't working properly tonight...

diffed the last one in the wrong order: this new one should actually be valid.
Comment 41 Iain Buchanan 2006-02-12 16:46:45 UTC
I'm seeing the issue with ati-drivers-8.22.5, xorg-x11-6.8.2-r6, and eselect-1.0 (all from ~x86).
Comment 42 Yang Zhao 2006-02-13 01:00:06 UTC
Created attachment 79661 [details, diff]
xorg-x11-6.8.* compatability patch for 8.22.5

Same fix as my previous patches, this time for 8.22.5 ebuild
Comment 43 Jabari R. Roberts 2006-02-13 12:52:36 UTC
(In reply to comment #42)
The diff in your patch got buggered -- it's going back to the original ebuild. ^_^
I reversed the order and the arrows; all but the second hunk (the comment after 'fi') applied.  I just made that change manually.
Now I'm able to get the directory listing that is in comment #30 and I can compile kde-base/kcontrol (which has an opengl dep).
Thank you very much!

FWIW, I have the same setup as comment #41, but I'm on ~amd64.


Comment 44 Yang Zhao 2006-02-13 13:04:58 UTC
Created attachment 79719 [details, diff]
79661: xorg-x11-6.8.* compatability patch for 8.22.5

Fixed patch. I keep getting the order wrong :p
Comment 45 Jakub Moc (RETIRED) gentoo-dev 2006-02-17 03:18:54 UTC
*** Bug 123133 has been marked as a duplicate of this bug. ***
Comment 46 Marco Calviani 2006-02-20 02:20:13 UTC
Same behaviour also on 8.22.5 in i386
Comment 47 Frederico 2006-02-21 09:39:00 UTC
I use the stable x86 ati-drivers-8.14.13-r3. Itried different versions of ati-drivers, and I got the same problem.
The file /usr/lib/opengl/ati/lib/libGL.la is an empty file, so, after runnig eselect opengl set ati, it copies that openGL.la into /usr/lib/libGL.la

My solution was:

1. emerge ati-drivers in another healthy linux machine,
2. copy /usr/lib/opengl/ati/lib/libGL.la from that machine to mine
3. run 'eselect opengl set ati'

everything works fine with DRI acceleration, but if I emerge ati-drivers again, it will go back to the libGL.la problem.

I think that the problem could be that the different between both machines is that the healthy one didn't have any LDFLAGS set, but the machine with the problem, when I installed gentoo I used 
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -Wl,--strip-all"
maybe this caused the libraries to not work properly
Comment 48 Tobias Sager 2006-02-22 02:36:08 UTC
Maintainers, could you please clarify what exactly is keeping this bug from getting fixed? There is a working patch for the ebuild attached.
Comment 49 Jakub Moc (RETIRED) gentoo-dev 2006-03-01 11:50:15 UTC
*** Bug 124547 has been marked as a duplicate of this bug. ***
Comment 50 Jakub Moc (RETIRED) gentoo-dev 2006-03-02 07:41:36 UTC
*** Bug 124644 has been marked as a duplicate of this bug. ***
Comment 51 Steve Arnold gentoo-dev 2006-03-02 17:55:26 UTC
Any action yet?  I just hit this bug on a new modular X install with no ati or extra drivers at all (this box has only a cheesy savage card).
Comment 52 Steve Arnold gentoo-dev 2006-03-02 19:19:44 UTC
After a little poking around, this is what I have so far; the failure occurs on Machine B:

Machine A: mostly x86 (with a large package.keywords), radeon card but no ati driver package (only x11 internal drivers) and no mesa.  This machine appears to have a correct set of libGL files, belonging to xorg-x11:

equery belongs /usr/lib/opengl/xorg-x11/lib/libGL.la
[ Searching for file(s) /usr/lib/opengl/xorg-x11/lib/libGL.la in *... ]
x11-base/xorg-x11-6.8.2-r6 (/usr/lib/opengl/xorg-x11/lib/libGL.la

(same for libGL.a)

Machine B: even more x86 (but with large package.keywords for modular X) with a savage card and fresh modular X and Gnome install (from no previous X at all).  It has mesa-6.4.2-r1 and xorg-x11-7.0-r1 and eselect fails completely:

eselect opengl set xorg-x11
Switching to xorg-x11 OpenGL interface.../usr/share/eselect//libs/core.bash: line 115: /usr/bin/sed: No such file or directory
!!! Error: Failed to create /usr/lib/libGL.la
exiting.

On machine B /usr/lib/libGL.la is a 0-byte file (instead of a symlink) and there is no libGL.a at all.  The libGL.so files belong to mesa:

equery belongs /usr/lib/opengl/xorg-x11/lib/libGL.la
[ Searching for file(s) /usr/lib/opengl/xorg-x11/lib/libGL.la in *... ]
media-libs/mesa-6.4.2-r1 (/usr/lib/opengl/xorg-x11/lib/libGL.la)

which should be correct for the modular X install right?  Anyway, I' made the broken one look like machine A (except for the missing libGL.a file) and continued the original build successfully (the failure happened on xine-lib).

Seems like an eselect bug to me...
Comment 53 Yang Zhao 2006-03-02 21:38:37 UTC
(In reply to comment #52)
> eselect opengl set xorg-x11
> Switching to xorg-x11 OpenGL interface.../usr/share/eselect//libs/core.bash:
> line 115: /usr/bin/sed: No such file or directory
> !!! Error: Failed to create /usr/lib/libGL.la
> exiting.

See bug #120180


> which should be correct for the modular X install right?...

The problem is that this bug occurs with NON-modular X. That is, xorg-x11-6.8.0 stable.

The real problem, as previously been outlined at least twice, is in the way virtual/x11 provider is identified. The current ebuild identifies it as x11, which is not correct. The fix is trivial, which is to check for xorg-x11 manually, hence the really short patch.

Comment 54 Yang Zhao 2006-03-02 21:40:54 UTC
(In reply to comment #53)
> (In reply to comment #52)
> > eselect opengl set xorg-x11
> > Switching to xorg-x11 OpenGL interface.../usr/share/eselect//libs/core.bash:
> > line 115: /usr/bin/sed: No such file or directory
> > !!! Error: Failed to create /usr/lib/libGL.la
> > exiting.
> 
> See bug #120180

Sorry. That should be bug #122260, which actually has a solution.
Comment 55 Carsten Lohrke (RETIRED) gentoo-dev 2006-03-06 15:29:30 UTC
*** Bug 125129 has been marked as a duplicate of this bug. ***
Comment 56 Yang Zhao 2006-03-13 10:10:21 UTC
Confirm fixed in 8.23.7
Comment 57 Jakub Moc (RETIRED) gentoo-dev 2006-04-29 15:07:57 UTC
*** Bug 131722 has been marked as a duplicate of this bug. ***
Comment 58 galion 2006-05-18 14:21:34 UTC
I have the exact same problem with the nvidia driver.
the error messege after compiling is:
!!! Error: Failed to create //usr/lib/libGL.la
I know it doesn't help much but I don't know what else to put in.

emerge --info:
Portage 2.1_pre10-r5 (default-linux/x86/2005.1, gcc-3.4.5, glibc-2.3.6-r2, 2.6.15-gentoo-r1 i686)
=================================================================
System uname: 2.6.15-gentoo-r1 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.12.0_pre15
dev-lang/python:     2.3.5, 2.4.2-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer -march=pentium4"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer -march=pentium4"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://mirror.hamakor.org.il/pub/mirrors/gentoo/ http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X aim alsa apm arts avi berkdb bidi bitmap-fonts bzip2 cdr cli crypt cups debug dri dvd dvdr eds emboss encode foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 imlib ipod ipv6 isdnlog jpeg kde libg++ libwww lm_sensors mad mikmod motif mozilla mp3 mpeg ncurses nls ogg oggvorbis openal opengl oss pam pcre pdf pdflib perl png pppd python qt quicktime readline reflection samba sdl session spell spl ssl tcpd truetype truetype-fonts type1-fonts unicode vorbis win32codecs xml2 xmms xorg xv xvid yahoo zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_i810 video_cards_nvidia video_cards_tga video_cards_v4l video_cards_vesa video_cards_vga video_cards_nv"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

some versions of packages that might have something to do with the problem:
nvidia-glx: 1.0.8756  nvidia-kernel: 1.0.8756  mesa: 6.4.2-r2  eselect: 1.0_rc2 
opengl-update: 3.0.0  xorg-x11: 6.8.2-r6
Comment 59 Jory A. Pratt 2006-05-18 14:51:46 UTC
(In reply to comment #58)
> I have the exact same problem with the nvidia driver.
> the error messege after compiling is:
> !!! Error: Failed to create //usr/lib/libGL.la
> I know it doesn't help much but I don't know what else to put in.
> 
> emerge --info:
> Portage 2.1_pre10-r5 (default-linux/x86/2005.1, gcc-3.4.5, glibc-2.3.6-r2,
> 2.6.15-gentoo-r1 i686)
> =================================================================
> System uname: 2.6.15-gentoo-r1 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
> Gentoo Base System version 1.12.0_pre15
> dev-lang/python:     2.3.5, 2.4.2-r1
> dev-python/pycrypto: 2.0.1-r5
> dev-util/ccache:     [Not Present]
> dev-util/confcache:  [Not Present]
> sys-apps/sandbox:    1.2.17
> sys-devel/autoconf:  2.13, 2.59-r7
> sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
> sys-devel/binutils:  2.16.1-r2
> sys-devel/libtool:   1.5.22
> virtual/os-headers:  2.6.11-r3
> ACCEPT_KEYWORDS="x86 ~x86"
> AUTOCLEAN="yes"
> CBUILD="i686-pc-linux-gnu"
> CFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer -march=pentium4"
> CHOST="i686-pc-linux-gnu"
> CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env
> /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config
> /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/X11/xkb
> /usr/share/config /var/qmail/control"
> CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/terminfo /etc/env.d"
> CXXFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer -march=pentium4"
> DISTDIR="/usr/portage/distfiles"
> FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
> GENTOO_MIRRORS="http://mirror.hamakor.org.il/pub/mirrors/gentoo/
> http://distfiles.gentoo.org
> http://www.ibiblio.org/pub/Linux/distributions/gentoo"
> PKGDIR="/usr/portage/packages"
> PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress
> --force --whole-file --delete --delete-after --stats --timeout=180
> --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
> PORTAGE_TMPDIR="/var/tmp"
> PORTDIR="/usr/portage"
> SYNC="rsync://rsync.gentoo.org/gentoo-portage"
> USE="x86 X aim alsa apm arts avi berkdb bidi bitmap-fonts bzip2 cdr cli crypt
> cups debug dri dvd dvdr eds emboss encode foomaticdb fortran gdbm gif gnome gpm
> gstreamer gtk gtk2 imlib ipod ipv6 isdnlog jpeg kde libg++ libwww lm_sensors
> mad mikmod motif mozilla mp3 mpeg ncurses nls ogg oggvorbis openal opengl oss
> pam pcre pdf pdflib perl png pppd python qt quicktime readline reflection samba
> sdl session spell spl ssl tcpd truetype truetype-fonts type1-fonts unicode
> vorbis win32codecs xml2 xmms xorg xv xvid yahoo zlib elibc_glibc
> input_devices_keyboard input_devices_mouse kernel_linux userland_GNU
> video_cards_i810 video_cards_nvidia video_cards_tga video_cards_v4l
> video_cards_vesa video_cards_vga video_cards_nv"
> Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL,
> LDFLAGS, LINGUAS, MAKEOPTS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
> 
> some versions of packages that might have something to do with the problem:
> nvidia-glx: 1.0.8756  nvidia-kernel: 1.0.8756  mesa: 6.4.2-r2  eselect: 1.0_rc2 
> opengl-update: 3.0.0  xorg-x11: 6.8.2-r6
> 

Open a new bug for nvidia package not an ati-drivers issue and myself nor lu_zero will work toward fixing it
Comment 60 Jakub Moc (RETIRED) gentoo-dev 2006-11-10 16:39:59 UTC
No reports of this for 6 months. Plus, monolithic Xorg no longer supported -> this bug is no longer relevant. 

FIXED, closing.
Comment 61 Daniel Beecham 2009-10-13 13:19:40 UTC
*** Bug 288873 has been marked as a duplicate of this bug. ***