Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 109482 - `emerge --config` should be advised instead of `ebuild ... config`
Summary: `emerge --config` should be advised instead of `ebuild ... config`
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Jason Stubbs (RETIRED)
URL:
Whiteboard:
Keywords:
: 109987 140371 (view as bug list)
Depends on: 111130
Blocks:
  Show dependency tree
 
Reported: 2005-10-16 09:23 UTC by Jason Stubbs (RETIRED)
Modified: 2007-01-13 00:11 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Stubbs (RETIRED) gentoo-dev 2005-10-16 09:23:49 UTC
(Assigning to QA as I don't know where else to assign it to) 
 
These packages all instruct the user to run `ebuild /var/db/.../${PV}.ebuild 
config`. Instead they should instruct to run `emerge --config =${PV}`. 
 
app-emacs/auctex 
app-emulation/win4lin 
app-portage/porthole 
app-text/man2html 
dev-db/firebird 
dev-db/mysql 
dev-db/pgcluster 
dev-db/postgresql 
dev-lang/ccc 
dev-lang/cxx 
dev-php/mod_php 
dev-python/mod_python 
dev-ruby/mod_ruby 
games-fps/ut2003 
games-fps/ut2003-bonuspack-epic 
games-fps/ut2004 
games-strategy/freecraft 
mail-filter/dspam 
mail-mta/nullmailer 
mail-mta/qmail 
mail-mta/qmail-ldap 
mail-mta/qmail-mysql 
media-sound/digitaldj 
media-sound/fobbit 
media-tv/nuvexport 
net-analyzer/aimsniff 
net-dialup/fcdsl 
net-dns/bind 
net-fs/coda 
net-ftp/glftpd 
net-irc/ircd-hybrid 
net-mail/bincimap 
net-mail/cyrus-imapd 
net-mail/mailfront 
net-mail/mailman 
net-misc/dhcp 
net-p2p/phpgnucacheii 
net-www/gentoo-webroot-default 
net-www/mod_auth_ldap 
net-www/mod_auth_pgsql 
net-www/mod_bandwidth 
net-www/mod_contribs 
net-www/mod_dav 
net-www/mod_encoding 
net-www/mod_fastcgi 
net-www/mod_gzip 
net-www/mod_layout 
net-www/mod_ldap_userdir 
net-www/mod_mp3 
net-www/mod_pcgi2 
net-www/mod_scgi 
net-www/mod_ssl 
net-www/mod_throttle 
net-zope/zopex3 
sys-apps/baselayout 
sys-apps/baselayout-vserver 
sys-apps/sal-client 
sys-block/partimage 
sys-cluster/csync2 
sys-cluster/xmlsysd 
www-apache/mod_chroot 
www-apache/mod_perl 
www-apps/Apache-Gallery 
www-apps/drupal 
www-apps/dspam-web 
www-apps/joomla 
www-apps/mambo 
www-apps/open-xchange 
www-apps/tikiwiki 
www-client/kazehakase 
www-client/kazehakase-cvs 
www-servers/aolserver 
x11-libs/kylixlibs3-borqt
Comment 1 Andrej Kacian (RETIRED) gentoo-dev 2005-10-16 09:55:39 UTC
Um, shouldn't that be ${PF} ?
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-10-16 12:44:31 UTC
Can someone add the maintainers/herds for the packages, pretty please? :) 
Comment 3 Petteri Räty (RETIRED) gentoo-dev 2005-10-16 13:00:08 UTC
betelgeuse@pena /mnt/checkouts/gentoo-x86/dev-java/japitools $ emerge --help |
grep config
   emerge --help [ system | config | sync ]
betelgeuse@pena /mnt/checkouts/gentoo-x86/dev-java/japitools $

Maybe this feature should be documented... I added bug 109496. Also
linux-wlan-ng-firmware was not on the list. It uses the following text: ebuild
<ebuild> config. Originally I did not want to hardcode the location of the
ebuild, but nice to know emerge --config exists. Any way the point is that the
script used to find the packages should be adjusted to match anything ebuild
<word> config.
Comment 4 Chris Gianelloni (RETIRED) gentoo-dev 2005-10-16 14:57:24 UTC
(In reply to comment #0)
> (Assigning to QA as I don't know where else to assign it to)

You would assign it to yourself, actually.

> games-fps/ut2003 
> games-fps/ut2003-bonuspack-epic 
> games-fps/ut2004

Completed.

> games-strategy/freecraft

This ebuild doesn't fall under this bug.  Not sure why it was included.
Comment 5 Francesco R. (RETIRED) gentoo-dev 2005-10-17 06:55:03 UTC
dev-db/mysql should be ok
Comment 6 Alin Năstac (RETIRED) gentoo-dev 2005-10-17 09:17:55 UTC
(In reply to comment #0)
> net-dialup/fcdsl 

fixed for net-dialup packages
Comment 7 Christian Heim (RETIRED) gentoo-dev 2005-10-17 11:28:58 UTC
(In reply to comment #0)
> (Assigning to QA as I don't know where else to assign it to) 
>  
> These packages all instruct the user to run `ebuild /var/db/.../${PV}.ebuild 
> config`. Instead they should instruct to run `emerge --config =${PV}`. 
>  
> sys-apps/baselayout 
> sys-apps/baselayout-vserver 

I've no idea why the to baselayout's are in there ... they don't even use any
reference to `ebuild /var/db/.../${PV}.ebuild config`.
Comment 8 Maurice van der Pot (RETIRED) gentoo-dev 2005-10-17 12:26:47 UTC
Fixed net-fs/coda
Comment 9 Michael Hanselmann (hansmi) (RETIRED) gentoo-dev 2005-10-17 13:46:24 UTC
qmail ebuilds fixed.
Comment 10 Tuan Van (RETIRED) gentoo-dev 2005-10-17 14:31:06 UTC
net-mail/cyrus-imapd is N/A

CC'ing mholzer to take care of mailman.
Comment 11 Radoslaw Stachowiak (RETIRED) gentoo-dev 2005-10-17 15:11:09 UTC
fixed net-zope/zopex3
Comment 12 Caleb Tennis (RETIRED) gentoo-dev 2005-10-20 11:32:02 UTC
mod_ruby fixed 
Comment 13 Eric Pretorious 2005-10-22 14:08:43 UTC
net-analyzer/aimsniff-0.9-r1 refuses the double-dash format but works correctly
without any dashes. i.e.,
ebuild /usr/portage/aimsniff-0.9-r1/aimsniff-0.9-r1.ebuild --config={PF} <==NO WORK
ebuild /usr/portage/aimsniff-0.9-r1/aimsniff-0.9-r1.ebuild config={PF}   <==WORKS
Comment 14 Petteri Räty (RETIRED) gentoo-dev 2005-10-22 14:13:47 UTC
(In reply to comment #13)
> net-analyzer/aimsniff-0.9-r1 refuses the double-dash format but works correctly
> without any dashes. i.e.,
> ebuild /usr/portage/aimsniff-0.9-r1/aimsniff-0.9-r1.ebuild --config={PF} <==NO
WORK
> ebuild /usr/portage/aimsniff-0.9-r1/aimsniff-0.9-r1.ebuild config={PF}   <==WORKS

We are talking about using emerge not ebuild.
Comment 15 Jason Stubbs (RETIRED) gentoo-dev 2005-10-22 18:40:51 UTC
Regenerated the list:   
    
app-emulation/win4lin    
app-text/man2html    
app-text/tetex    
dev-db/firebird    
dev-db/myodbc    
dev-db/pgcluster    
dev-lang/ccc    
dev-lang/cxx    
dev-php/mod_php    
dev-python/mod_python    
dev-util/subversion    
mail-filter/dspam    
mail-mta/nullmailer    
mail-mta/qmail    
mail-mta/qmail-ldap    
mail-mta/qmail-mysql    
media-sound/digitaldj    
media-sound/fobbit    
net-analyzer/aimsniff    
net-dialup/ppp    
net-dns/bind    
net-fs/coda    
net-ftp/glftpd    
net-irc/cyclone    
net-irc/ircd-hybrid    
net-mail/bincimap    
net-mail/mailfront    
net-mail/mailman    
net-misc/asterisk    
net-misc/asterisk-addons    
net-misc/dhcp    
net-p2p/freenet    
net-p2p/phpgnucacheii    
net-proxy/middleman    
net-www/gentoo-webroot-default    
net-www/mod_auth_ldap    
net-www/mod_auth_pgsql    
net-www/mod_bandwidth    
net-www/mod_contribs    
net-www/mod_dav    
net-www/mod_encoding    
net-www/mod_fastcgi    
net-www/mod_gzip    
net-www/mod_layout    
net-www/mod_ldap_userdir    
net-www/mod_mp3    
net-www/mod_pcgi2    
net-www/mod_scgi    
net-www/mod_ssl    
net-www/mod_throttle    
net-www/mod_watch    
net-www/webapp-config    
net-zope/zopex3    
sys-apps/busybox    
sys-apps/sal-client    
sys-block/partimage    
sys-cluster/csync2    
sys-cluster/xmlsysd    
www-apache/mod_chroot    
www-apache/mod_perl    
www-apps/Apache-Gallery    
www-apps/drupal    
www-apps/dspam-web    
www-apps/joomla    
www-apps/mambo    
www-apps/open-xchange    
www-apps/tikiwiki    
www-client/elinks    
www-servers/aolserver    
x11-libs/kylixlibs3-borqt    
x11-misc/3ddesktop    
    
   
Yes on the s/PV/PF/g. With ebuilds being on the list that shouldn't be, I  
tried a couple of methods to generate the list - I must have accidentally used  
the result of one of the failed ones. 
Comment 16 Renat Lumpau (RETIRED) gentoo-dev 2005-10-23 08:10:32 UTC
www-apps/Apache-Gallery
www-apps/joomla
www-apps/mambo
www-apps/tikiwiki

are done

net-www/webapp-config shouldn't be on the list
Comment 17 Doug Goldstein gentoo-dev 2005-10-23 10:23:23 UTC
uh. nuvexport doesn't say anything about using config. Removing myself from this
bug as a result.
Comment 18 Christian Zoffoli (RETIRED) gentoo-dev 2005-10-23 15:38:01 UTC
sys-block/partimage fixed
sys-cluster/csync2 fixed
Comment 19 Masatomo Nakano (RETIRED) gentoo-dev 2005-10-23 20:56:21 UTC
fixed
  dev-db/pgcluster 
  dev-db/postgresql 

no config command in
  www-client/kazehakase 
  www-client/kazehakase-cvs 
Comment 20 Carsten Lohrke (RETIRED) gentoo-dev 2005-10-24 16:46:09 UTC
(In reply to comment #0)
> config`. Instead they should instruct to run `emerge --config =${PV}`. 

Shouldn't that be  emerge --config =${PF}  to have the exact ebuild revision?
Comment 21 Harald van Dijk (RETIRED) gentoo-dev 2005-10-24 23:18:50 UTC
(In reply to comment #20)
> Shouldn't that be  emerge --config =${PF}  to have the exact ebuild revision?

Yes. See comment #1 and comment #15.

Removing tools-portage@ as porthole isn't affected and isn't in the regenerated
list.
Comment 22 Christian Heim (RETIRED) gentoo-dev 2005-10-25 00:34:03 UTC
Removing vserver-devs@ as baselayout-vserver isn't affected and isn't in the
regenerated list.
Comment 23 Carsten Lohrke (RETIRED) gentoo-dev 2005-10-25 01:33:42 UTC
(In reply to comment #21)
> Yes. See comment #1 and comment #15.

Aww! (:)
Comment 24 Luca Longinotti (RETIRED) gentoo-dev 2005-10-29 15:44:45 UTC
dev-php/mod_php fixed.
Best regards, CHTEKK.
Comment 25 Konstantin Arkhipov (RETIRED) gentoo-dev 2005-10-29 18:36:16 UTC
net-dns/bind done.
Comment 26 Marco Morales 2005-10-31 18:29:03 UTC
*** Bug 109987 has been marked as a duplicate of this bug. ***
Comment 27 Marco Morales 2005-10-31 19:13:30 UTC
net-analyzer/aimsniff fixed
Comment 28 Marco Morales 2005-10-31 19:23:55 UTC
www-apps/drupal fixed
Comment 29 Leonardo Boshell (RETIRED) gentoo-dev 2005-11-01 03:56:12 UTC
app-text/tetex is not affected.
Comment 30 Sven Wegener gentoo-dev 2005-11-02 23:32:50 UTC
net-irc done
Comment 31 Marco Morales 2005-11-03 06:47:03 UTC
netmon done
Comment 32 Ziga Boehm 2005-11-10 14:06:30 UTC
for net-www/gentoo-webroot-default update please see bug 111920 ... 
Comment 33 Michael Cummings (RETIRED) gentoo-dev 2005-11-12 08:25:07 UTC
Old mod_perl's fixed, removing perl
Comment 34 Roy Marples (RETIRED) gentoo-dev 2005-12-21 06:20:49 UTC
nt-misc/dhcp fixed
Comment 35 Daniel Black (RETIRED) gentoo-dev 2005-12-29 00:48:59 UTC
Mike Frysinger: http://www.gentoo.org/doc/en/qmail-howto.xml
Comment 36 SpanKY gentoo-dev 2005-12-29 00:50:39 UTC
ive already fixed it locally, i'm in the middle of other aspects of the qmail guide
Comment 37 Carsten Lohrke (RETIRED) gentoo-dev 2005-12-30 16:19:31 UTC
Fixed dev-db/firebird and did 

find . -iname "*\.ebuild" -exec grep -H "ebuild /var" {} \;


False positives (newer ebuils are correct or don't need the config step):

www-apache/mod_chroot
x11-libs/kylixlibs3-borqt
app-text/man2html

and a lot other ones...


Still unfixed:

mail-mta/nullmailer
net-ftp/glftpd
net-p2p/phpgnucacheii
net-www/gentoo-webroot-default
mail-filter/dspam
www-servers/aolserver
sys-apps/sal-client
sys-cluster/xmlsysd
net-mail/bincimap
net-mail/mailfront
dev-lang/ccc
dev-lang/cxx
media-sound/digitaldj
media-sound/fobbit
www-apps/dspam-web
www-apps/open-xchange


Other noticable issues:

net-dns/bind - doesn't print any information regarding emerge --config at all (Which brings me to the idea to ask, why Portage doesn't do this automatically for all ebuilds, when pkg_config() exists!?).

net-www/mod_* - I did not check all of them, since newer ebuilds seem generally not to have a pkg_config function, so they can be considered fine.
Comment 38 Renat Lumpau (RETIRED) gentoo-dev 2006-01-08 09:52:06 UTC
Fixed
net-p2p/phpgnucacheii
mail-filter/dspam
www-apps/dspam-web

web-apps done now
Comment 39 Jean-François Gagnon Laporte 2006-01-23 12:11:19 UTC
(In reply to comment #37)
> Fixed dev-db/firebird and did 
> 

@Carlo : Unfortunatly you changed both dev-db/firebird ebuild to \"emerge --config =${PV}\"" instead of using \"emerge --config =${PF}\"" resulting in a false output asking for :

 * 1. If haven't done so already, please run:
 * 
 *    "emerge --config =1.5.1"
 * 
 *    to create lockfiles, set permissions and more

Adding your e-mail to cc to re-fix the ebuilds. See comment #15 and comment #21 for reference.

<snip>
Comment 40 Carsten Lohrke (RETIRED) gentoo-dev 2006-01-31 15:39:16 UTC
(In reply to comment #39)
> Adding your e-mail to cc to re-fix the ebuilds.

Thanks. Silly error of mine. :(
Comment 41 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2006-02-11 02:33:55 UTC
nullmailer fixed now
Comment 42 Michael Stewart (vericgar) (RETIRED) gentoo-dev 2006-06-04 21:02:40 UTC
Old-style apache ebuilds and modules have been removed from the tree, all new-style ebuilds use the correct form. Removing apache-bugs.
Comment 43 Stuart Longland (RETIRED) gentoo-dev 2006-09-25 07:28:13 UTC
Maybe I'm going blind, but I don't see any Mozilla packages mentioned in the updated list (comment #15), the one Mozilla package being fixed by Masatomo Nakano in comment #19. :-)

Thus, I'm removing mozilla from the list.  Add us back if there's still problems.
Comment 44 Patrick Lauer gentoo-dev 2006-10-04 11:37:54 UTC
(In reply to comment #37)
> Fixed dev-db/firebird and did 

> mail-mta/nullmailer
> net-ftp/glftpd
> net-p2p/phpgnucacheii
> net-www/gentoo-webroot-default
> mail-filter/dspam
> www-servers/aolserver
> sys-apps/sal-client
^^ these look fixed

===
> sys-cluster/xmlsysd
> net-mail/bincimap
> net-mail/mailfront
> dev-lang/ccc
> dev-lang/cxx
> media-sound/digitaldj
> media-sound/fobbit
==
these still do it

> www-apps/dspam-web
> www-apps/open-xchange
those two seem to be fixed


www-apps/drupal-4.6.2.ebuild is a new candidate :-(
> 
> Other noticable issues:
> 
> net-dns/bind - doesn't print any information regarding emerge --config at all
> (Which brings me to the idea to ask, why Portage doesn't do this automatically
> for all ebuilds, when pkg_config() exists!?).
> 
> net-www/mod_* - I did not check all of them, since newer ebuilds seem generally
> not to have a pkg_config function, so they can be considered fine.
> 

Comment 45 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-10-04 12:53:33 UTC
digitaldj fixed.
Comment 46 Jakub Moc (RETIRED) gentoo-dev 2006-10-05 00:45:12 UTC
*** Bug 140371 has been marked as a duplicate of this bug. ***
Comment 47 Jakub Moc (RETIRED) gentoo-dev 2006-11-28 06:24:36 UTC
/usr/portage/x11-misc/ifpgui/ifpgui-0.10.8.ebuild:      ewarn "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"

*ifpgui-0.10.8 (12 Nov 2006)

  12 Nov 2006; Przemys&#322;aw Maci&#261;g <troll@gentoo.org> +files/ifpgui.desktop,
  +files/ifpgui.png, +files/ifpgui-doxyfile_fixes.patch,
  +files/ifpgui-translation_files_directory.patch,
  +files/ifpgui-use_system_libifp.patch, +ifpgui-0.10.8.ebuild:
  Initial import (closing #118115)
Comment 48 Jakub Moc (RETIRED) gentoo-dev 2006-11-28 06:28:52 UTC
All the rest fixed, removing CCs.
Comment 49 Przemyslaw Maciag (RETIRED) gentoo-dev 2006-11-28 14:03:40 UTC
(In reply to comment #47)
> /usr/portage/x11-misc/ifpgui/ifpgui-0.10.8.ebuild:      ewarn "ebuild
> /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"

ifpgui done
Comment 50 Jakub Moc (RETIRED) gentoo-dev 2007-01-12 23:05:11 UTC
(In reply to comment #49)
> ifpgui done

Not really...
 
<snip>
ewarn "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
ewarn "emerge --config =${PF}"
</snip>

Replace the above with "emerge --config =${CATEGORY}/${PF}" please.
Comment 51 Krzysztof Pawlik (RETIRED) gentoo-dev 2007-01-12 23:49:02 UTC
(In reply to comment #50)
> (In reply to comment #49)
> > ifpgui done
> 
> Not really...
> 
> <snip>
> ewarn "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
> ewarn "emerge --config =${PF}"
> </snip>
> 
> Replace the above with "emerge --config =${CATEGORY}/${PF}" please.

Fixed.
Comment 52 Jakub Moc (RETIRED) gentoo-dev 2007-01-13 00:11:57 UTC
(In reply to comment #51)
> Fixed.

And closing, all done. Yay! :P