Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 98253 - Replace xsupplicant init script by an rcscript network module
Summary: Replace xsupplicant init script by an rcscript network module
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: No maintainer - Look at if you want to take care of it
Depends on:
Reported: 2005-07-07 11:14 UTC by Sebastian Roeder
Modified: 2007-03-08 23:26 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Roeder 2005-07-07 11:14:55 UTC
I have two problems with the init script provided in the xsupplicant-1.0.1  
1. "/etc/init.d/xsupplicant stop" doesn't work as expected - it always gives  
me the zwo red !! and I have to delete /var/run/xsupplicant manually. Maybe 
this is an upstream problem since the kill command doesn't work either. 
2. Then I do not change the init script the xsupplicant is in background 
modus. This is bad for me cause xsupplicant aep-md5 (wired) authetification 
has to be finished becore I can start net.eth0. Therefore I removed the 
background option from the init script but now xsupplicant is always verbose 
on boot (showing my user + passwort!) and I can't make it be silent. 
3. Offtopic: Is there any chance to use variables from the xsupplicant conf 
script within non-xsupplicant init scripts (like net.eth0)? Sorry for OT - I 
you don't like it please ignore the last question. 
Of cause I will help to fix the init script if I can. 

Reproducible: Always
Steps to Reproduce:
Comment 1 Henrik Brix Andersen 2005-07-08 08:02:21 UTC
You should take a look at baselayout-1.11.x and wpa_supplicant:
Comment 2 Sebastian Roeder 2005-08-18 14:12:40 UTC
After surching the web a long time I managed to get the aep-md5 authetification 
over WIRED LAN working with wpa_supplicant. Therefor the ~x86 wpa_supplicant 
0.4.x is needed. 
This is my wpa_supplicant.conf.wired: 
Now I can start it in the console with: 
wpa_supplicant -ieth0 -Dwired -c/etc/wpa_supplicant.conf.wired 
Finaly starting dhcpcd and everithing is fine. But I can not integrate this 
into /etc/conf.d/net. I tried it like this: 
# Network config for the new Gentoo baselayout > 0.11.11 on Dell Inspiron 6000 
# For reference see /etc/conf.d/net.example 
# Enable wpa_supplicant for all net.* devices 
modules=( "wpa_supplicant" ) 
# Configure wired LAN (eth0) 
# ************************* 
# Bring eth0 "UP" and prepare it for authentification 
ifconfig_eth0="up allmulti promisc" 
# Tell wpa_supplicant to use the "wired" driver for eth0 
# And to use config /etc/wpa_supplicant.conf.wired 
wpa_supplicant_eth0="-Dwired -c/etc/wpa_supplicant.conf.wired" 
config_eth0=( "dhcp" ) 
#dhcpcd_eth0="-t 30" 
But it doesn't work. Seems like wpa_supplicant is not even started cause 
wpa_cli status doesn't work either (wpa_ctrl_open can not be found). 
Is support for wired interfaces and wpa_supplicant not yet supported by 
baselayout-1.11.13? Can I fix this manually in the meantime? 
Thanks in advance for the help! I guess once this is working wpa_supplicant is 
a good replacement for xsupplicant and the integration within baselayout is a 
good approach.  
Comment 3 Henrik Brix Andersen 2005-10-25 05:33:16 UTC
The init script should be replaced by a rcscript network module.
Comment 4 Roy Marples (RETIRED) gentoo-dev 2005-10-25 06:33:23 UTC
baselayout-1.12.0_pre10 will support wpa_supplicant over wired interfaces.
You can find instructions and patches for enabling this in
baselayout-1.12.0_pre9-r1 at the below link

And yes, the xsupplicant init script should be replaces with a rcscripts net module.
Comment 5 Sebastian Roeder 2005-10-25 13:06:52 UTC
(In reply to comment #4) 
Yes, I know cause it was me who started the thread =) It works great! 
Would it be an option to replace xsupplicant completely with wpa_supplicant 
(removing it from portage, as it looks like it is not maintained in Gentoo)? Or 
is there something that xsupplicant can do but wpa_supplicant can't? 
Comment 6 Sebastian Roeder 2006-04-29 02:28:03 UTC
OK I mark this closed with the hint to use wpa_supplicant instead.
Comment 7 Henrik Brix Andersen 2006-04-29 02:37:41 UTC
(In reply to comment #6)
> OK I mark this closed with the hint to use wpa_supplicant instead.

Please leave this up to the developers - the problem with xsupplicant is not solved.
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2007-03-08 23:26:48 UTC
# Stefan Cornelius <> (7 Mar 2007)
# Masking net-misc/xsupplicant due to security bug 154995

Use something else, like net-wireless/wpa_supplicant