Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 919309 - app-containers/distrobuilder-3.0: add missing dependencies and patch old command
Summary: app-containers/distrobuilder-3.0: add missing dependencies and patch old command
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: William Hubbs
Keywords: EBUILD
Depends on:
Reported: 2023-12-05 21:21 UTC by rick
Modified: 2024-02-13 06:28 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

patch and updated ebuild file (distrobuilder.tar.gz,10.00 KB, text/plain)
2023-12-05 21:23 UTC, rick

Note You need to log in before you can comment on or make changes to this bug.
Description rick 2023-12-05 21:21:08 UTC

I've tried to build an ISO to make a Windows 10 VM and I found some problems.

I submit this patch for distrobuilder which contains 3 dependencies and a patch to use mkisofs instead of genisoimage. genisoimage was in a deleted package ( I've also add a kernel configuration check because repack-windows needs some specific flags.

I've also found that app-emulation/qemu needs the flag virtfs to run a Windows 10 VM. I hesitate to add a flag just for it, we don't really need these dependancies and flags and patch if we don't want to make a W10 VM.

Reproducible: Always
Comment 1 rick 2023-12-05 21:23:13 UTC
Created attachment 877654 [details]
patch and updated ebuild file
Comment 2 Joonas Niilola gentoo-dev 2023-12-13 13:27:21 UTC
First of all I didn't even know you could _build_ Windows VMs with distrobuilder. Then, I wonder if it's possible to write some all-around code logic that it's gonna try to use genisoimage and if that can't be found, fallback to mkisofs? If these tools are compatible at leat. That solution could be upstreamed potentially. 

If you run VMs through lxd (which utilizes qemu to do so), there's a message saying what you need to enable on qemu to have working VM support:
  optfeature "virtual machine support" app-emulation/qemu[spice,usbredir,virtfs]
Comment 3 rick 2023-12-14 23:25:20 UTC
I think it's possible. I'll try to make a patch for that and write a PR to the main project. I'll let write a comment when it's good, to remove the patch for a future version.

And my bad, I've not seen the message when I run LXD, I'll try to read my terminal better next time.
Comment 4 Larry the Git Cow gentoo-dev 2024-02-13 06:28:08 UTC
The bug has been referenced in the following commit(s):

commit e8ba118e6a27680c108d7fa5e559877217717733
Author:     Joonas Niilola <>
AuthorDate: 2024-02-13 06:26:34 +0000
Commit:     Joonas Niilola <>
CommitDate: 2024-02-13 06:26:34 +0000

    app-containers/distrobuilder: depend on cdrtools for 'mkisofs' bin
    Signed-off-by: Joonas Niilola <>

 .../{distrobuilder-3.0.ebuild => distrobuilder-3.0-r1.ebuild}        | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)