Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 914740 - media-gfx/blender-3.3.6-r1 intern/cycles/util/thread.cpp:50:34: error: expected unqualified-id before ‘&’ token
Summary: media-gfx/blender-3.3.6-r1 intern/cycles/util/thread.cpp:50:34: error: expect...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 1 vote (vote)
Assignee: Adrian
URL:
Whiteboard:
Keywords:
: 912338 (view as bug list)
Depends on:
Blocks: gcc-13
  Show dependency tree
 
Reported: 2023-09-26 12:00 UTC by zhaleks
Modified: 2024-01-16 01:02 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (20230926.EMERGE.BUILD.log,720.98 KB, text/x-log)
2023-09-26 12:01 UTC, zhaleks
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zhaleks 2023-09-26 12:00:15 UTC
Can't build with GCC13. Can't build with +osl too.

Reproducible: Always

Steps to Reproduce:
1.emerge blender
2.
3.
Actual Results:  
ERROR: media-gfx/blender-3.3.6-r1::gentoo failed (compile phase)

Expected Results:  
Successful build. 

Portage 3.0.49 (python 3.11.5-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-13, glibc-2.37-r3, 6.1.53-gentoo-r1 x86_64)
=================================================================
System uname: Linux-6.1.53-gentoo-r1-x86_64-Intel-R-_Core-TM-_i5-8500_CPU_@_3.00GHz-with-glibc2.37
KiB Mem:     7925844 total,   6282908 free
KiB Swap:   16777212 total,  16777212 free
Timestamp of repository gentoo: Tue, 26 Sep 2023 10:15:01 +0000
Head commit of repository gentoo: c05fedbbc9a038058a634815b88fcf19df7ad396
sh bash 5.1_p16-r6
ld GNU ld (Gentoo 2.40 p5) 2.40.0
app-misc/pax-utils:        1.3.5::gentoo
app-shells/bash:           5.1_p16-r6::gentoo
dev-lang/perl:             5.38.0-r1::gentoo
dev-lang/python:           3.11.5::gentoo
dev-lang/rust:             1.71.1::gentoo
dev-util/cmake:            3.26.5-r2::gentoo
dev-util/meson:            1.2.1-r1::gentoo
sys-apps/baselayout:       2.14::gentoo
sys-apps/openrc:           0.48::gentoo
sys-apps/sandbox:          2.37::gentoo
sys-devel/autoconf:        2.71-r6::gentoo
sys-devel/automake:        1.16.5-r1::gentoo
sys-devel/binutils:        2.40-r5::gentoo
sys-devel/binutils-config: 5.5::gentoo
sys-devel/clang:           15.0.7-r3::gentoo
sys-devel/gcc:             13.2.1_p20230826::gentoo
sys-devel/gcc-config:      2.11::gentoo
sys-devel/libtool:         2.4.7-r1::gentoo
sys-devel/llvm:            15.0.7-r3::gentoo
sys-devel/make:            4.4.1-r1::gentoo
sys-kernel/linux-headers:  6.1::gentoo (virtual/os-headers)
sys-libs/glibc:            2.37-r3::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.ru.gentoo.org/gentoo-portage
    priority: -1000
    volatile: False
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts: 
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=x86-64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=x86-64 -O2 -pipe"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GDK_PIXBUF_MODULE_FILE GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR XDG_STATE_HOME"
FCFLAGS="-march=x86-64 -O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs binpkg-multi-instance buildpkg buildpkg-live config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=x86-64 -O2 -pipe"
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles http://distfiles.gentoo.org"
LANG="ru_RU.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LEX="flex"
MAKEOPTS="-j2"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
SHELL="/bin/bash"
USE="7zip X a52 aac acl acpi activities alsa amd64 bittorrent bluetooth branding brotli btrfs bzip2 cairo cdda cdr cli client crypt cups dbus declarative dri dts dvd dvdr elogind encode exif firmware flac fortran gdbm geoclue gif git gles2 gpm gui harfbuzz iconv icu ipv6 jpeg kde kerberos kwallet lapack lcms libass libtirpc logrotate mad mng mp3 mp4 mpeg multilib ncurses networkmanager nls nptl ntp ogg opengl openh264 openmp opus oscar otr pam pango pcre pcsc-lite pdf pipewire plasma png policykit ppds pulseaudio qml qt5 rar readline samba scanner screencast sddm sdl seccomp semantic-desktop sip smartcard sna sound sound-server spell spice split-usr sqlite ssl startup-notification svg synaptics test-rust theora tiff touchpad truetype tty-helpers udev udisks unicode upnp upower usb utils v4l vaapi virtualbox vorbis vpx vulkan wayland widgets x264 xattr xcb xft xml xv xvid zip zlib" ABI_X86="64" ADA_TARGET="gnat_2021" ALSA_CARDS="usb-audio hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt rdrand sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput synaptics wacom" KERNEL="linux" L10N="en ru" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php8-1" POSTGRES_TARGETS="postgres15" PYTHON_SINGLE_TARGET="python3_11" PYTHON_TARGETS="python3_11" RUBY_TARGETS="ruby31" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  ADDR2LINE, AR, ARFLAGS, AS, ASFLAGS, CC, CCLD, CONFIG_SHELL, CPP, CPPFLAGS, CTARGET, CXX, CXXFILT, ELFEDIT, EMERGE_DEFAULT_OPTS, EXTRA_ECONF, F77FLAGS, FC, GCOV, GPROF, INSTALL_MASK, LC_ALL, LD, LFLAGS, LIBTOOL, LINGUAS, MAKE, MAKEFLAGS, NM, OBJCOPY, OBJDUMP, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RANLIB, READELF, RUSTFLAGS, SIZE, STRINGS, STRIP, YACC, YFLAGS
Comment 1 zhaleks 2023-09-26 12:01:50 UTC
Created attachment 871479 [details]
Build log
Comment 2 zhaleks 2023-09-26 13:23:22 UTC
Can't build any of Blenders in the Portage.
Comment 3 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2023-10-03 16:18:39 UTC
Filed https://gcc.gnu.org/bugzilla/show_bug.cgi?id=111681 for the GCC error improvement.
Comment 4 Larry the Git Cow gentoo-dev 2023-10-03 16:23:00 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=580ee060c186678d960994df4f6d21133ac4b393

commit 580ee060c186678d960994df4f6d21133ac4b393
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2023-10-03 16:22:20 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2023-10-03 16:22:20 +0000

    media-gfx/blender: fix build w/ gcc 13
    
    Closes: https://bugs.gentoo.org/914740
    Signed-off-by: Sam James <sam@gentoo.org>

 media-gfx/blender/blender-3.3.6-r1.ebuild                |  1 +
 media-gfx/blender/blender-3.3.8.ebuild                   |  1 +
 media-gfx/blender/blender-3.4.1-r3.ebuild                |  1 +
 media-gfx/blender/files/blender-3.3.6-cycles-gcc13.patch | 12 ++++++++++++
 4 files changed, 15 insertions(+)
Comment 5 zhaleks 2023-10-03 16:32:20 UTC
Hello.
Cool.
Thanks.
Comment 6 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2024-01-16 01:02:50 UTC
*** Bug 912338 has been marked as a duplicate of this bug. ***