Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 904468 - xfce-base/xfdesktop-4.19.1 shows empty desktop after upgrade, was showing file icons before
Summary: xfce-base/xfdesktop-4.19.1 shows empty desktop after upgrade, was showing fil...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 3 votes (vote)
Assignee: XFCE Team
URL: https://gitlab.xfce.org/xfce/xfdeskto...
Whiteboard:
Keywords:
Depends on: 930736
Blocks:
  Show dependency tree
 
Reported: 2023-04-17 13:00 UTC by Sebastian Pipping
Modified: 2024-05-12 14:07 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info,18.37 KB, text/plain)
2024-05-11 16:37 UTC, antonello
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Pipping gentoo-dev 2023-04-17 13:00:59 UTC
I installed xfce-base/xfdesktop-4.19.1 yesterday and found my desktop with no icons today after reboot.  What helped is to go to the settings and switch "Icon Type" to "None" and back to "File/launcher icons".  So there is apparently some problem in the upgrade path and/or a mismatch of settings dialog and reality. What do you think?
Comment 1 Andreas 2023-04-17 16:28:36 UTC
Same happened to me also.
I reverted to 4-19-0 and all ok.
Comment 2 Sebastian Pipping gentoo-dev 2023-04-18 14:12:32 UTC
I'm also noticing now after another reboot that the file icons no longer cover the full screen height but only the upper ~70 percent or so.  @xfce my vote for hard-masking 4.19.1, this is not ready for end-users.
Comment 3 Sebastian Pipping gentoo-dev 2023-04-18 14:23:56 UTC
Reported upstream now
Comment 4 Sebastian Pipping gentoo-dev 2023-04-18 15:11:29 UTC
(In reply to Sebastian Pipping from comment #2)
> I'm also noticing now after another reboot that the file icons no longer
> cover the full screen height but only the upper ~70 percent or so.

PS: That is https://gitlab.xfce.org/xfce/xfdesktop/-/issues/243 upstream now, if anyone's interested.
Comment 5 Sylvain 2023-11-02 17:29:58 UTC
With xfdesktop-4.19.1 installed, the workaround from comment #1 does not work.
since 4.19.0 is no longer available I had to revert to xfdesktop-4.18.1 to get the icons back
Comment 6 Larry the Git Cow gentoo-dev 2023-11-25 11:02:26 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=690179b9fa7b5906c8f850317388943cb214b3a5

commit 690179b9fa7b5906c8f850317388943cb214b3a5
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2023-11-25 11:01:28 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2023-11-25 11:01:28 +0000

    profiles: mask =xfce-base/xfdesktop-4.19.1
    
    Broken icon rendering on the desktop.
    
    Bug: https://bugs.gentoo.org/904468
    Signed-off-by: Sam James <sam@gentoo.org>

 profiles/package.mask | 5 +++++
 1 file changed, 5 insertions(+)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=07940937b7888149c00fc9ca5b13ac87aac9aabb

commit 07940937b7888149c00fc9ca5b13ac87aac9aabb
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2023-11-25 10:59:51 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2023-11-25 10:59:51 +0000

    xfce-base/xfdesktop: Revert "Remove old"
    
    This reverts commit 7f87d51a3e7cafec3cc2c5adc9a6183eea6fbbb9.
    
    Restore 4.19.0 given reported issues w/ icons in bug #904468.
    
    Bug: https://bugs.gentoo.org/904468
    Signed-off-by: Sam James <sam@gentoo.org>

 xfce-base/xfdesktop/Manifest                |  1 +
 xfce-base/xfdesktop/xfdesktop-4.19.0.ebuild | 64 +++++++++++++++++++++++++++++
 2 files changed, 65 insertions(+)
Comment 7 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2023-11-25 11:02:48 UTC
Masked after pinging mgorny on IRC. Thanks!
Comment 8 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2024-03-17 13:07:18 UTC
Could you try 4.19.2?  There's some icon-related fix in the changelog, so maybe it's better now.
Comment 9 Jan Psota 2024-03-18 06:28:49 UTC
(In reply to Michał Górny from comment #8)
> Could you try 4.19.2?  There's some icon-related fix in the changelog, so
> maybe it's better now.

Hi! Still no icons. Switching back to 4.19.0-r2 solves the problem.
And xfdesktop-4.19.0-r2 needs lower xfce-base/libxfce4windowing-4.19.1
to compile, on 4.19.3 merge breaks on linking (the problem is not in mold).
Comment 10 Larry the Git Cow gentoo-dev 2024-03-18 13:06:05 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b78a746e21efa6b804e00800a0c424e950394eec

commit b78a746e21efa6b804e00800a0c424e950394eec
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: 2024-03-18 13:04:06 +0000
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: 2024-03-18 13:06:02 +0000

    package.mask: Mask =xfdesktop-4.19.2 as well
    
    Bug: https://bugs.gentoo.org/904468
    Signed-off-by: Michał Górny <mgorny@gentoo.org>

 profiles/package.mask | 1 +
 1 file changed, 1 insertion(+)
Comment 11 Andreas 2024-03-18 15:54:35 UTC
Same happens with 
=xfce-base/xfdesktop-4.19.2
Comment 12 Harald Judt 2024-03-20 08:53:07 UTC
I am usually not using desktop icons, but I have tried with the latest version in Gentoo and everything works fine so far. Are you sure this is not a simple config problem? Have you already tried deleting the xfdesktop-specific settings ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-desktop.xml or start with a clean (xfce) profile?

Also, there are files that store the icon positions in terms of row and cols in ~/.config/xfce4/desktop.
Comment 13 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2024-03-20 08:58:04 UTC
Note that the bad versions are masked again.
Comment 14 Harald Judt 2024-03-20 09:06:03 UTC
I tried with xfdesktop-0.19.2:

LC_ALL=C xfdesktop -V
This is xfdesktop version 4.19.2, running on Xfce 4.18.
Built with GTK+ 3.24.41, linked with GTK+ 3.24.41.
Build options:
    Desktop Menu:        enabled
    Desktop Icons:       enabled
    Desktop File Icons:  enabled
Comment 15 Larry the Git Cow gentoo-dev 2024-04-26 13:16:50 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3e21439d4aabcc18687e5ee0a04ae29be8e59423

commit 3e21439d4aabcc18687e5ee0a04ae29be8e59423
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: 2024-04-26 13:14:59 +0000
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: 2024-04-26 13:16:45 +0000

    xfce-base/xfdesktop: Backport the settings problem patch
    
    Closes: https://bugs.gentoo.org/904468
    Signed-off-by: Michał Górny <mgorny@gentoo.org>

 .../files/xfdesktop-4.19.2-settings.patch          | 25 ++++++++++++++++++++++
 ...op-4.19.2.ebuild => xfdesktop-4.19.2-r1.ebuild} |  5 +++++
 2 files changed, 30 insertions(+)
Comment 16 gt_amd64 2024-04-26 14:47:27 UTC
This bug is *NOT* fixed, so why is it closed?

Still no icons on desktop with xfdesktop-4.19.2-r1.ebuild
I had to revert to xfdesktop-4.18.1 to get the icons back
Comment 17 Sebastian Pipping gentoo-dev 2024-04-26 23:07:03 UTC
xfdesktop-4.19.2-r1 segfaults during startup — new bug #930736 —, re-opening and adding bug #930736 as a blocker here.
Comment 18 Sebastian Pipping gentoo-dev 2024-04-26 23:11:49 UTC
(In reply to Sebastian Pipping from comment #17)
> xfdesktop-4.19.2-r1 segfaults during startup — new bug #930736 —, re-opening
> and adding bug #930736 as a blocker here.

Seemed like a good move a minute ago, no longer as sure.  Sam, if you want to revert back to "see also + closed" please feel free to, I'm good either way.
Comment 19 Larry the Git Cow gentoo-dev 2024-04-27 03:46:57 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=968649d789dfc35e8e53a9df688bc76b07dc9562

commit 968649d789dfc35e8e53a9df688bc76b07dc9562
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: 2024-04-27 03:46:18 +0000
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: 2024-04-27 03:46:18 +0000

    xfce-base/xfdesktop: Fix segv with a followup backport
    
    I am very sorry for messing this up and not including the other upstream
    fix.
    
    Closes: https://bugs.gentoo.org/904468
    Closes: https://bugs.gentoo.org/930736
    Signed-off-by: Michał Górny <mgorny@gentoo.org>

 .../files/xfdesktop-4.19.2-settings.patch          | 80 ++++++++++++++++++----
 ...4.19.2-r1.ebuild => xfdesktop-4.19.2-r2.ebuild} |  0
 2 files changed, 67 insertions(+), 13 deletions(-)
Comment 20 Sebastian Pipping gentoo-dev 2024-04-27 14:55:08 UTC
Seems to work and not crash with 4.19.2-r2 now — thanks!
Comment 21 safiire 2024-04-30 23:43:56 UTC
I just did an update and got 4.19.2-r2, and it is broken in the exact same way again.

Icons cannot be moved, wrong background color on textareas on icons

This isn't fixed, I cannot use my desktop like this, what am I missing here?
Comment 22 antonello 2024-05-11 16:04:57 UTC
Upgraded today to version 4.19.2-r2, after reboot the desktop wallpaper looks strange, the right mouse button does not work on the desktop.
Don't know with icons, as I don't use icons on the desktop.

Downgrade to version 4.18.1, everything goes back to normal.
Comment 23 antonello 2024-05-11 16:37:25 UTC
Created attachment 892744 [details]
emerge --info
Comment 24 antonello 2024-05-11 16:38:43 UTC
# xfdesktop
segmentation error
Comment 25 Sebastian Pipping gentoo-dev 2024-05-12 11:24:23 UTC
(In reply to antonello from comment #24)
> # xfdesktop
> segmentation error

With backtrace please (GDB) and potentially as new dedicated issue.  It doesn't segfault for everyone, so reproducing will need your help.  Thank you.
Comment 26 antonello 2024-05-12 13:24:44 UTC
(In reply to Sebastian Pipping from comment #25)
> (In reply to antonello from comment #24)
> > # xfdesktop
> > segmentation error
> 
> With backtrace please (GDB) and potentially as new dedicated issue.  It
> doesn't segfault for everyone, so reproducing will need your help.  Thank
> you.

Hi, I don't know what you mean by 'backtrace'...

anyway:

https://bugs.gentoo.org/931819
Comment 27 Sebastian Pipping gentoo-dev 2024-05-12 14:07:11 UTC
(In reply to antonello from comment #26)
> Hi, I don't know what you mean by 'backtrace'...

I meant a stack trace (https://en.wikipedia.org/wiki/Stack_trace) or traceback (Python lingo, https://docs.python.org/3/library/traceback.html).  To be contrete, something like the output of:

  # xfdesktop --quit
  # gdb --batch -ex run -ex bt --args xfdesktop --enabled-debug


> anyway:
> 
> https://bugs.gentoo.org/931819

Thanks, please add a stack trace using GDB there.