Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 90041 - TinyXML (new ebuild)
Summary: TinyXML (new ebuild)
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://www.grinninglizard.com/tinyxml/
Whiteboard: sunrise suggested
Keywords: EBUILD
Depends on:
Blocks: 217299 252920 252922 263965
  Show dependency tree
 
Reported: 2005-04-22 09:01 UTC by Zbigniew Braniecki
Modified: 2009-08-13 02:27 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
tinyxml-2.5.2.ebuild (tinyxml-2.5.2.ebuild,938 bytes, text/plain)
2007-01-11 00:39 UTC, Wojciech Myrda
Details
tinyxml-9999.ebuild (tinyxml-9999.ebuild,1.20 KB, text/plain)
2007-03-03 12:08 UTC, patrick
Details
tinyxml-9999.ebuild (tinyxml-9999.ebuild,1.18 KB, text/plain)
2007-03-03 13:54 UTC, patrick
Details
tinyxml-9999.ebuild (tinyxml-9999.ebuild,1.14 KB, text/plain)
2007-03-04 18:43 UTC, patrick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zbigniew Braniecki 2005-04-22 09:01:23 UTC
TinyXML is a nice lib used by many game engines.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Mr. Bones. (RETIRED) gentoo-dev 2005-04-23 05:26:49 UTC
but not a game...
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2005-04-27 02:06:05 UTC
*** Bug 90587 has been marked as a duplicate of this bug. ***
Comment 3 Alex Howells (RETIRED) gentoo-dev 2005-05-02 15:56:03 UTC
Resolving invalid, if you wish to submit an accompanying ebuild then reopen.

To Jakub:  that's an invalid duplicate, it's not related.
Comment 4 Wojciech Myrda 2007-01-11 00:39:59 UTC
Created attachment 106464 [details]
tinyxml-2.5.2.ebuild

I created this ebuild. I placed it in dev-util/tinyxml

# comment 1
     why that makes it irrelevant?
# comment 3
     What makes this request invalid? This days we have maintainer-wanted@gentoo.org to which bug reports can be assigned.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-01-11 00:46:20 UTC
Reopen...
Comment 6 patrick 2007-03-03 12:08:36 UTC
Created attachment 111903 [details]
tinyxml-9999.ebuild

This is a CVS ebuild for tinyxml. It installs tinyxml as a shared library.
Shared libraries are supported only in CVS for now, 2.5.2 only supports building an example application, which makes the 2.5.2 ebuild rather senseless.
Comment 7 patrick 2007-03-03 13:54:16 UTC
Created attachment 111912 [details]
tinyxml-9999.ebuild

make use of dolib
Comment 8 patrick 2007-03-04 18:43:31 UTC
Created attachment 112102 [details]
tinyxml-9999.ebuild

get rid of src_unpack as it is not needed at all.
Comment 9 patrick 2007-03-06 20:34:54 UTC
This is now in the sunrise overlay. You can find it at:
http://www.gentoo-sunrise.org/sunrise/browser/sunrise/dev-util/tinyxml
Comment 10 Marcin Kowalski 2007-03-31 17:36:31 UTC
is STL support enabled by default? 

documentation states that you can enable [or disable] STL usage (this relates mostly to the String class) during build time. 

maybe this should go into a separate USE flag.
Comment 11 Daniel Santos 2008-10-28 03:49:02 UTC
dev-util/tinyxml-2.5.3 dies with USE="doc".  I would include emerge --info, but it doesn't look like it has anything to do with my setup, rather it looks like there's no Doxyfile in the tarball and instead, it contains pre-generated docs.  Can somebody else please check it out?  Thanks.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-util/tinyxml-2.5.3  USE="doc* examples" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/portage/local/layman/sunrise


>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-util/tinyxml-2.5.3
 * tinyxml_2_5_3.tar.gz RMD160 SHA1 SHA256 size ;-) ...                  [ ok ]
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
>>> Unpacking source...
>>> Unpacking tinyxml_2_5_3.tar.gz to /tmp/portage/dev-util/tinyxml-2.5.3/work
>>> Source unpacked.
>>> Compiling source in /tmp/portage/dev-util/tinyxml-2.5.3/work/tinyxml ...
Error: configuration file dox not found!
Doxygen version 1.5.6
Copyright Dimitri van Heesch 1997-2008

You can use doxygen in a number of ways:

1) Use doxygen to generate a template configuration file:
    doxygen [-s] -g [configName]

    If - is used for configName doxygen will write to standard output.

2) Use doxygen to update an old configuration file:
    doxygen [-s] -u [configName]

3) Use doxygen to generate documentation using an existing configuration file:
    doxygen [configName]

    If - is used for configName doxygen will read from standard input.

4) Use doxygen to generate a template style sheet file for RTF, HTML or Latex.
    RTF:   doxygen -w rtf styleSheetFile
    HTML:  doxygen -w html headerFile footerFile styleSheetFile [configFile]
    LaTeX: doxygen -w latex headerFile styleSheetFile [configFile]

5) Use doxygen to generate an rtf extensions file
    RTF:   doxygen -e rtf extensionsFile

If -s is specified the comments in the config file will be omitted.
If configName is omitted `Doxyfile' will be used as a default.

 *
 * ERROR: dev-util/tinyxml-2.5.3 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_compile
 * environment, line  750:  Called die
 * The specific snippet of code:
 * doxygen dox || die "doxygen failed";
 * The die message:
 * doxygen failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/dev-util:tinyxml-2.5.3:20081028-034346.log'.
 * The ebuild environment file is located at '/tmp/portage/dev-util/tinyxml-2.5.3/temp/environment'.
 *

Comment 12 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-01-20 16:30:56 UTC
(this is an automated message based on filtering criteria that matched this bug)
'EBUILD' is in the KEYWORDS which should mean that there is a ebuild attached 
to this bug.
This bug is assigned to maintainer-wanted which means that it is not in the 
main tree.

Hello, The Gentoo Team would like to firstly thank you for your ebuild 
submission. We also apologize for not being able to accommodate you in a timely
manner. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The 
sunrise overlay[1] is a overlay for Gentoo which we allow trusted users to 
commit to and all users can have ebuilds reviewed by Gentoo devs for entry 
into the overlay. So, the sunrise team is suggesting that you look into this 
and submit your ebuild to the overlay where even *you* can commit to. =)

Because this is a mass message, we are also asking you to be patient with us. 
We anticipate a large number of requests in a short time. 

Thanks,
On behalf of the Gentoo Sunrise Team,
Jeremy.

[1]: http://www.gentoo.org/proj/en/sunrise/
[2]: http://overlays.gentoo.org/proj/sunrise/wiki/SunriseFaq
Comment 13 Samuli Suominen gentoo-dev 2009-08-13 02:26:53 UTC
0.5.3_p20090813 in portage...