Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 89823 - app-pda/pilot-link-0.12.1 version bump
Summary: app-pda/pilot-link-0.12.1 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Lowest enhancement (vote)
Assignee: Gentoo PDA Herd
URL:
Whiteboard:
Keywords: EBUILD
: 127233 160451 (view as bug list)
Depends on:
Blocks: 163853
  Show dependency tree
 
Reported: 2005-04-20 08:27 UTC by Assaf Berg
Modified: 2007-09-17 21:30 UTC (History)
22 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
pilot-link-0.12.0-pre4 Ebuild (pilot-link-0.12.0_pre4.ebuild,1.87 KB, application/octet-stream)
2005-07-04 02:36 UTC, Christian Schmitt
Details
pilot-link-0.12.0_pre4.ebuild (pilot-link-0.12.0_pre4.ebuild,1.96 KB, text/plain)
2006-01-12 17:00 UTC, Christian Schmitt
Details
0.12.1 ebuild (pilot-link-0.12.1.ebuild,2.17 KB, text/plain)
2006-09-21 00:48 UTC, Jukka Palko
Details
updated 0.12.1 ebuild w/ python/java/tcltk/USB/userland support (pilot-link-0.12.1.ebuild,2.58 KB, text/plain)
2007-02-03 22:41 UTC, Hans Meine
Details
arch-aware sandboxed install of java libpisock.so (pilot-link-0.12.1-java_install_destdir.patch,993 bytes, patch)
2007-02-03 22:43 UTC, Hans Meine
Details | Diff
fixes --with-python support in configure (pilot-link-0.12.1-python_configure.patch,350 bytes, patch)
2007-02-03 22:44 UTC, Hans Meine
Details | Diff
fix sandboxed python install (pilot-link-0.12.1-python_destdir.patch,506 bytes, patch)
2007-02-03 22:47 UTC, Hans Meine
Details | Diff
pilot-link-0.12.2.ebuild (pilot-link-0.12.2.ebuild,2.09 KB, text/plain)
2007-03-19 21:35 UTC, Chris Smith
Details
dev-libs/libmal-0.44.ebuild (libmal-0.44.ebuild,652 bytes, text/plain)
2007-03-19 21:38 UTC, Chris Smith
Details
kde-base/kpilot-3.5.6.ebuild (kpilot-3.5.6.ebuild,1.26 KB, text/plain)
2007-03-19 21:39 UTC, Chris Smith
Details
patchset for kpilot (pilot-link-0.12.2.patch,1.52 KB, patch)
2007-03-19 21:40 UTC, Chris Smith
Details | Diff
pilot-link-0.12.2.ebuild (pilot-link-0.12.2.ebuild,2.14 KB, patch)
2007-03-23 20:20 UTC, Chris Smith
Details | Diff
pilot-link-0.12.2-m4.patch (pilot-link-0.12.2-m4.patch,2.09 KB, patch)
2007-03-23 20:22 UTC, Chris Smith
Details | Diff
pilot-link-0.12.2.ebuild (pilot-link-0.12.2.ebuild,2.14 KB, text/plain)
2007-03-23 20:24 UTC, Chris Smith
Details
pilot-link-0.12.2.ebuild (pilot-link-0.12.2.ebuild,1.65 KB, text/plain)
2007-04-16 13:30 UTC, Michael Krelin
Details
pilot-link-0.12.2-build.patch (pilot-link-0.12.2-build.patch,2.74 KB, patch)
2007-04-16 13:31 UTC, Michael Krelin
Details | Diff
fixed pilot-link-0.12.2-build.patch (pilot-link-0.12.2-build.patch,2.75 KB, patch)
2007-05-10 14:21 UTC, Michael Krelin
Details | Diff
really fixed pilot-link-0.12.2-build.patch (pilot-link-0.12.2-build.patch,2.75 KB, patch)
2007-05-10 14:46 UTC, Michael Krelin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Assaf Berg 2005-04-20 08:27:07 UTC
Nice features put into this version (including some bugs that were patched in the 0.18 ebuild)

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Assaf Berg 2005-04-26 06:00:41 UTC
Using the ebuild for 11.8-r1 seems to work (after commenting out all the patches), but I get compilation errors if the java, python or tcltk use flags are on.
Comment 2 Alastair Tse (RETIRED) gentoo-dev 2005-04-26 06:23:36 UTC
0.12 is a major rewrite of the backend and lots of depending apps break because of this, most notably gnome-pilot. 
Comment 3 Assaf Berg 2005-04-26 06:36:32 UTC
So if an application that depends on it breaks with the new version is should block the upgrade, right?
Comment 4 Alastair Tse (RETIRED) gentoo-dev 2005-04-26 08:04:50 UTC
don't understand what you're asking. but if the underlying library breaks the applications that depend on it, i don't see any reason why we should add that library.
Comment 5 Jeff Norman 2005-05-04 19:08:59 UTC
Creating symlink seems to work for me.  Ugly though.  Wish I could find where upstream this was hard coded as i386
Comment 6 Assaf Berg 2005-05-05 11:35:38 UTC
To #4, what I'm saying is, if an updated version of a library breaks a dependency it doesn't mean that you don't want it. Some people don't have that dependency installed and may still enjoy the library. If someone does have that dependency installed, portage should prevent him from upgrading (blocking).
Comment 7 Christian Schmitt 2005-05-06 04:34:10 UTC
#6, I totally agree with you. 0.12.0-pre3 is out now and the 0.12 version adds a whole new bunch of features and fixes a lot of bugs. After all, kpilot aleady has support for 0.12.0 so it should really be added into portage.
Comment 8 Alastair Tse (RETIRED) gentoo-dev 2005-05-08 13:41:57 UTC

*** This bug has been marked as a duplicate of 87774 ***
Comment 9 Alastair Tse (RETIRED) gentoo-dev 2005-05-08 13:42:18 UTC
oops, wrong bug
Comment 10 Christian Schmitt 2005-07-03 15:20:08 UTC
Could someone please create an ebuild of the newest version and put it here? I
tried to to it but did not succeed. It was my first one ;-)
Thx.
Comment 11 Christian Schmitt 2005-07-04 02:36:44 UTC
Created attachment 62585 [details]
pilot-link-0.12.0-pre4 Ebuild

This one is my first ebuild and its not yet perfect. But ist works here.
Comment 12 Gabriel Devenyi 2005-11-23 18:05:09 UTC
I'd also like to see this get in, also, could you please add an option, or 
dependency for libusb and the --enable-libusb configure option. 
 
For more information, please see http://pilot-link.org/README.usb 
Comment 13 Leonardo Ferreira Fontenelle 2005-12-22 21:35:49 UTC
(In reply to comment #11)
> This one is my first ebuild and its not yet perfect. But ist works here.

Thank you, I was looking for this ebuild for some time, and I wasn't able to create one by myself. Unfortunately, the emerge failed, with the error message in the bottom. Emerging without the java USE flag resolved it. "./configure --help" gave me "--with-perl=perlexec"; does that mean that "yes" or "no" isn't enough? By the way, why are perl and python commented out?

Output from emerge:

creating reminders
make[3]: Leaving directory `/var/tmp/portage/pilot-link-0.12.0_pre4/work/pilot-link-0.12.0-pre4/src'
make[2]: Leaving directory `/var/tmp/portage/pilot-link-0.12.0_pre4/work/pilot-link-0.12.0-pre4/src'
Making all in bindings
make[2]: Entering directory `/var/tmp/portage/pilot-link-0.12.0_pre4/work/pilot-link-0.12.0-pre4/bindings'
Making all in Java
make[3]: Entering directory `/var/tmp/portage/pilot-link-0.12.0_pre4/work/pilot-link-0.12.0-pre4/bindings/Java'
/opt/blackdown-jdk-1.4.2.02/bin/javac -d . ./MidiMgr.java ./TestTodos.java ./org/gnu/pilotlink/AddressAppInfo.java ./org/gnu/pilotlink/AppInfo.java ./org/gnu/pilotlink/DBInfo.java ./org/gnu/pilotlink/DatabaseExistsException.java ./org/gnu/pilotlink/DatabaseNotFoundException.java ./org/gnu/pilotlink/DatebookAppInfo.java ./org/gnu/pilotlink/FTB3CostCatRecord.java ./org/gnu/pilotlink/MemoRecord.java ./org/gnu/pilotlink/PilotLink.java ./org/gnu/pilotlink/PilotLinkException.java ./org/gnu/pilotlink/RawAppInfo.java ./org/gnu/pilotlink/RawRecord.java ./org/gnu/pilotlink/SysInfo.java ./org/gnu/pilotlink/User.java ./org/gnu/pilotlink/Version.java ./org/gnu/pilotlink/AddressRecord.java ./org/gnu/pilotlink/FTB3TripRecord.java ./org/gnu/pilotlink/FTB3VehicleRecord.java ./org/gnu/pilotlink/DatebookRecord.java ./org/gnu/pilotlink/MidiRecord.java ./org/gnu/pilotlink/ToDoRecord.java ./org/gnu/pilotlink/Record.java ./test.java ./datebooktst.java ./adrtest.java
i686-pc-linux-gnu-g++ -I../../include -I ../../include -I ../../include -I /opt/blackdown-jdk-1.4.2.02/include -I /opt/blackdown-jdk-1.4.2.02/include/linux -fPIC -DHAVE_CONFIG_H -L ../../libpisock/.libs -lpisock -shared -o libjpisock.so ./libjpisock.c
./libjpisock.c: In function `_jobject* Java_org_gnu_pilotlink_PilotLink_readAppInfo(JNIEnv*, _jobject*, jint, jint)':
./libjpisock.c:107: error: invalid conversion from `jbyte*' to `int'
./libjpisock.c:107: error:   initializing argument 4 of `PI_ERR dlp_ReadAppBlock(int, int, int, int, pi_buffer_t*)'
./libjpisock.c:107: error: invalid conversion from `int' to `pi_buffer_t*'
./libjpisock.c:107: error:   initializing argument 5 of `PI_ERR dlp_ReadAppBlock(int, int, int, int, pi_buffer_t*)'
./libjpisock.c: In function `_jobject* Java_org_gnu_pilotlink_PilotLink_getAppInfoBlock(JNIEnv*, _jobject*, jint, _jstring*)':
./libjpisock.c:568: error: invalid conversion from `jbyte (*)[65535]' to `int'
./libjpisock.c:568: error:   initializing argument 4 of `PI_ERR dlp_ReadAppBlock(int, int, int, int, pi_buffer_t*)'
./libjpisock.c:568: error: invalid conversion from `int' to `pi_buffer_t*'
./libjpisock.c:568: error:   initializing argument 5 of `PI_ERR dlp_ReadAppBlock(int, int, int, int, pi_buffer_t*)'
./libjpisock.c: In function `_jobject* Java_org_gnu_pilotlink_PilotLink_getRecordByIndex(JNIEnv*, _jobject*, jint, jint, jint)':
./libjpisock.c:666: error: cannot convert `jbyte*' to `pi_buffer_t*' for argument `4' to `PI_ERR dlp_ReadRecordByIndex(int, int, int, pi_buffer_t*, recordid_t*, int*, int*)'
./libjpisock.c: In function `int pilot_connect(JNIEnv*, const char*)':
./libjpisock.c:881: error: cannot convert `sockaddr*' to `const char*' for argument `2' to `PI_ERR pi_bind(int, const char*)'./libjpisock.c:1005: error: invalid conversion from `int*' to `size_t*'
./libjpisock.c:1005: error:   initializing argument 5 of `int pi_setsockopt(int, int, int, const void*, size_t*)'
./libjpisock.c: In function `_jobject* Java_org_gnu_pilotlink_PilotLink_getResourceByIndex(JNIEnv*, _jobject*, jint, jint, jint)':
./libjpisock.c:1058: error: cannot convert `jbyte*' to `pi_buffer_t*' for argument `4' to `PI_ERR dlp_ReadResourceByIndex(int, int, int, pi_buffer_t*, long unsigned int*, int*)'
./libjpisock.c: In function `_jobject* Java_org_gnu_pilotlink_PilotLink_readDBList(JNIEnv*, _jobject*, jint, jint, jint, jint)':
./libjpisock.c:1181: error: cannot convert `DBInfo*' to `pi_buffer_t*' for argument `5' to `PI_ERR dlp_ReadDBList(int, int, int, int, pi_buffer_t*)'
make[3]: ** [java_lib] Erro 1
make[3]: Leaving directory `/var/tmp/portage/pilot-link-0.12.0_pre4/work/pilot-link-0.12.0-pre4/bindings/Java'
make[2]: ** [all-recursive] Erro 1
make[2]: Leaving directory `/var/tmp/portage/pilot-link-0.12.0_pre4/work/pilot-link-0.12.0-pre4/bindings'
make[1]: ** [all-recursive] Erro 1
make[1]: Leaving directory `/var/tmp/portage/pilot-link-0.12.0_pre4/work/pilot-link-0.12.0-pre4'
make: ** [all] Erro 2
Comment 14 Leonardo Ferreira Fontenelle 2005-12-22 22:14:57 UTC
(In reply to comment #11)
> Created an attachment (id=62585) [edit]
Please add support support for libusb in the ebuild.

1. Add libusb to IUSE
2. Bellow "readline? ( sys-libs/readline )" add:
       libusb? ( dev-libs/libusb )"
(watch the quote!)
3. Before "econf ${myconf} || die" add:
       use libusb \
               && myconf="${myconf} --enable-libusb"
Comment 15 Erik Musick 2006-01-03 22:16:01 UTC
Error in compiling on ~x86. Additional info on request. Happens with and without the additional changes in comment 14.


if /bin/sh ../libtool --tag=CC --mode=compile i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include -I../include     -march=athlon-xp -mtune=athlon-xp -O2 -fomit-frame-pointer -frename-registers -ftracer -finline-limit=600 -finline-all-stringops -pipe -fno-ident -Werror -MT libpisock_la-libusb.lo -MD -MP -MF ".deps/libpisock_la-libusb.Tpo" -c -o libpisock_la-libusb.lo `test -f 'libusb.c' || echo './'`libusb.c; \
then mv -f ".deps/libpisock_la-libusb.Tpo" ".deps/libpisock_la-libusb.Plo"; else rm -f ".deps/libpisock_la-libusb.Tpo"; exit 1; fi
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include -I../include -march=athlon-xp -mtune=athlon-xp -O2 -fomit-frame-pointer -frename-registers -ftracer -finline-limit=600 -finline-all-stringops -pipe -fno-ident -Werror -MT libpisock_la-libusb.lo -MD -MP -MF .deps/libpisock_la-libusb.Tpo -c libusb.c  -fPIC -DPIC -o .libs/libpisock_la-libusb.o
libusb.c: In function `u_write':
libusb.c:378: warning: passing arg 3 of `usb_bulk_write' discards qualifiers from pointer target type
make[2]: *** [libpisock_la-libusb.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/pilot-link-0.12.0_pre4/work/pilot-link-0.12.0-pre4/libpisock'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/pilot-link-0.12.0_pre4/work/pilot-link-0.12.0-pre4'
make: *** [all] Error 2
Comment 16 Christian Schmitt 2006-01-12 17:00:07 UTC
Created attachment 76960 [details]
pilot-link-0.12.0_pre4.ebuild 

added the libusb USE-flag and disabled python, since it does not compile properly
Comment 17 Stonki 2006-01-12 21:22:23 UTC
just for info: kpilot 3.5.0 does NOT compile against pilot-link-0.12pre4
Comment 18 Jan Dusek 2006-02-03 05:24:52 UTC
Hi, trying to emerge pilot-link-0.12.0_pre4 and this is what I get:

# emerge pilot-link
...
if i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/include -I../include  -I/usr/include      -O2 -march=pentium3 -pipe -fomit-frame-pointer -MT dlpsh.o -MD -MP -MF ".deps/dlpsh.Tpo" -c -o dlpsh.o dlpsh.c; \
then mv -f ".deps/dlpsh.Tpo" ".deps/dlpsh.Po"; else rm -f ".deps/dlpsh.Tpo"; exit 1; fi
/bin/sh ../libtool --tag=CC --mode=link i686-pc-linux-gnu-gcc  -O2 -march=pentium3 -pipe -fomit-frame-pointer   -o dlpsh  dlpsh.o libpiuserland.la -lpopt  ../libpisock/libpisock.la
i686-pc-linux-gnu-gcc -O2 -march=pentium3 -pipe -fomit-frame-pointer -o .libs/dlpsh dlpsh.o  ./.libs/libpiuserland.a /usr/lib/libpopt.so ../libpisock/.libs/libpisock.so
dlpsh.o: In function `handle_user_commands':
dlpsh.c:(.text+0xec1): undefined reference to `readline'
dlpsh.c:(.text+0xed4): undefined reference to `add_history'
collect2: ld returned 1 exit status


# emerge info
Portage 2.0.54 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r2, 2.6.15-gentoo-r1 i686)
=================================================================
System uname: 2.6.15-gentoo-r1 i686 Intel(R) Pentium(R) M processor 1400MHz
Gentoo Base System version 1.6.14
dev-lang/python:     2.3.5-r2, 2.4.2-r1
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium3 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/xsessions /var/qmail/control"CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.nl.gentoo.org/gentoo-portage"
USE="X acpi alsa avi cdr cups dvd foomaticdb gif gnome gtk gtk2 gtkhtml icq jpeg mmx mozilla mozsvg mpeg ncurses ogg opengl pam pda perl png pnp ppds quicktime sse ssl truetype trusted unicode usb vorbis win32codecs x86 xprint xv xvid userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 19 Simon Ruggier 2006-04-24 07:06:32 UTC
*** Bug 127233 has been marked as a duplicate of this bug. ***
Comment 20 Simon Ruggier 2006-04-24 07:20:30 UTC
In bug 127233 I made a patch to fix the java bindings compile error seen in comment #13, and also ported the existing patches to the newer ebuild as needed.  Feel free to use those files, and I apologize for not adding the libusb USE flag, I'm not booted into gentoo right now, and I'm a bit busy.
Comment 21 Tobias Ussing 2006-05-09 15:51:42 UTC
Concerning post #18

dlpsh.c:(.text+0xec1): undefined reference to `readline'
dlpsh.c:(.text+0xed4): undefined reference to `add_history'

Add readline as a useflag.. The configure script (as supplied by pilot-link) is broken.. If you do ./configure it will compiles, if you do it with --with-readline=yes it will compiles, but if you do it with --with-readline=no it won't(if you check the configure output it still says "yes" for the readline checks, i think because of the no it excludes some includes needed to compile it).

The ebuild adds a --with-readline=no unless you add readline as a useflag.

Comment 22 Alastair Tse (RETIRED) gentoo-dev 2006-07-20 03:56:10 UTC
Just a note, right on pilot-link.org's homepage is a message from the maintainers asking people not to package 0.12 for their distros. Until they say it is ok, I'm not going to look into adding this into portage.  But I'm happy for this to live in an overlay for people to test so we can be ready when the ban on packaging is lifted. Also note that gnome-pilot will require 2.0.14 to be released proper before pilot-link-0.12 goes in.
Comment 23 Gabriel Devenyi 2006-08-23 18:12:27 UTC
Anyone got libusb mode to actually work? Seems to hang every time for me.

Instructions at http://code.pilot-link.org/README.libusb
Comment 24 Neil Kennedy 2006-09-05 13:36:06 UTC
0.12.1 has been released, it works with the 0.12_pre4 ebuild as long as the java use flag has been disabled 
Comment 25 Gabriel Devenyi 2006-09-05 15:54:12 UTC
The userland tools don't seem to build with 0.12.1 ebuild, investigating...
Comment 26 Gabriel Devenyi 2006-09-05 15:58:55 UTC
needs --enable-conduits to build the userland tools
Comment 27 Alastair Tse (RETIRED) gentoo-dev 2006-09-19 12:27:15 UTC
anyone want to volunteer to modify the submitted ebuild that works with the new pilot link? 

thanks!
Comment 28 Jukka Palko 2006-09-21 00:48:00 UTC
Created attachment 97608 [details]
0.12.1 ebuild

Managed to get my system to have 0.12.1 pilot-link with this ebuild, but having java use flag causes a protection alarm on install:
ACCESS DENIED  open_wr:   /etc/java-config-2/current-system-vm/jre/lib/amd64/libjpisock.so

Works for me without having USE flags java nor tcltk turned on. tcltk USE flag causes the compile to fail when compiling tcl bits.

I will be happy to improve the ebuild if so desired as I really could use a working sync for my Palm TX. :)
Comment 29 Gour 2006-10-09 03:05:13 UTC
(In reply to comment #28)
> Created an attachment (id=97608) [edit]
> 0.12.1 ebuild
> 

The ebuild works here on ~amd64 with the following flags:

USE="perl png python readline -java -tcltk"

(tested with jpilot-0.99.9)

Sincerely,
Gour
Comment 30 Andrew Telford 2006-10-21 15:58:15 UTC
(In reply to comment #23)
> Anyone got libusb mode to actually work? Seems to hang every time for me.

Yes.  Libusb works well for me on amd64.  I modified the 0.12.1 ebuild attachment (dated 2006-09-21) as follows:

local myconf="--enable-libusb --enable-conduits --includedir=/usr/include/libpisock"

I had to copy /usr/share/pilot-link/udev/60-libpisock.rules to /etc/udev/rules.d. Perhaps this should be done by the ebuild.  Finally since this udev rules file created the devices files with group id dialout, I added my user to the "dialout" group. Should the udev rules file  use another group?  After logging out and back in again I could access the Tungsten E using the port "usb:". 
Comment 31 Paul Bredbury 2006-12-30 06:50:46 UTC
I've documented how to backup a Palm Tungsten T3:

http://forums.gentoo.org/viewtopic-p-3488734.html#3488734
Comment 32 Jakub Moc (RETIRED) gentoo-dev 2007-01-06 13:59:41 UTC
*** Bug 160451 has been marked as a duplicate of this bug. ***
Comment 33 Paul Taylor 2007-01-26 06:46:04 UTC
pilot-link 0.12.0 or later is required for kde-base/kpilot-3.5.6; see bug #163853.
Comment 34 Ryan Neufeld 2007-01-30 07:57:54 UTC
I am getting a sandbox violation when using this ebuild

if [ -e /etc/java-config-2/current-system-vm/jre/lib/i386 ]; then cp libjpisock.so /etc/java-config-2/current-system-vm/jre/lib/i386/; elif [ -e /etc/java-config-2/current-system-vm/jre/lib/amd64 ]; then cp libjpisock.so /etc/java-config-2/current-system-vm/jre/lib/amd64/; else echo "Unknown architecture. Copy lipijsock.so to /etc/java-config-2/current-system-vm/jre/lib/ARCH/"; fi
ACCESS DENIED  open_wr:   /etc/java-config-2/current-system-vm/jre/lib/i386/libjpisock.so
cp: cannot create regular file `/etc/java-config-2/current-system-vm/jre/lib/i386/libjpisock.so': Permission denied
make[2]: *** [install] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-pda/pilot-link-0.12.1/work/pilot-link-0.12.1/bindings/Java'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-pda/pilot-link-0.12.1/work/pilot-link-0.12.1/bindings'
make: *** [install-recursive] Error 1

!!! ERROR: app-pda/pilot-link-0.12.1 failed.
Call stack:
  ebuild.sh, line 1611:   Called dyn_install
  ebuild.sh, line 1057:   Called qa_call 'src_install'
  environment, line 3209:   Called src_install
  pilot-link-0.12.1.ebuild, line 83:   Called die

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/log/portage/app-pda:pilot-link-0.12.1:20070130-075444.log'.

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-app-pda_-_pilot-link-0.12.1-26933.log"

open_wr:   /etc/java-config-2/current-system-vm/jre/lib/i386/libjpisock.so (symlink to /opt/sun-jdk-1.5.0.10/jre/lib/i386/libjpisock.so)
--------------------------------------------------------------------------------
!!! This ebuild is from an overlay: '/usr/local/portage'


emerge -iPortage 2.1.2-r4 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.5-r0, 2.6.19-suspend2-r1 i686)
=================================================================
System uname: 2.6.19-suspend2-r1 i686 Genuine Intel(R) CPU           T2300  @ 1.66GHz
Gentoo Base System release 1.12.6
Timestamp of tree: Mon, 29 Jan 2007 18:30:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.31-r3
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer parallel-fetch prelink sandbox sfperms strict userpriv usersandbox"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -s"
LINGUAS="en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/layman/xeffects"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa avi bash-completion berkdb bitmap-fonts cdr cdrw cli cracklib crypt css cups dbus divx4linux dlloader dri dv dvd dvdr dvdread dvdrw emboss encode fam fame fbcon ffmpeg flac gdbm gif gnutls gpm gstreamer gtk hal iconv isdnlog jabber java jpeg kde kdeenablefinal kdehiddenvisibility kdexdeltas kerberos lame libg++ logrotate mikmod mmx mp3 mpeg msn musicbrainz ncurses nls nptl nptlonly nsplugin nvidia ogg opengl pam pcre pda perl pertty pic png pnp ppds pppd python qt qt3 qt4 quicktime readline reflection rss samba sdl seamonkey session spell spl sse sse2 sse3 ssl subtitles tcltk tcpd tetex tiff truetype truetype-fonts type1-fonts udev unicode usb userlocales vcd vorbis wifi win32codecs x86 xcomposite xinerama xml xorg xscreensaver xv xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US" USERLAND="GNU" VIDEO_CARDS="nv nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_RSYNC_EXTRA_OPTS
Comment 35 Hans Meine 2007-02-03 22:40:26 UTC
(In reply to comment #34)
> I am getting a sandbox violation when using this ebuild
I fixed that, and did some more changes (compared to the 0.11.8 ebuild, which is more or less equal to the one attached here so far):
* version bump
* support separate tcl/tk use flags instead of the deprecated tcltk one
  (TODO: not tested yet, as I do not like/use TCL)
* repair python support (patch sent to upstream authors)
* fix sandboxed Java install
* fix sandboxed Python install
* remove netsync patch (came from upstream, assume it was included long ago)
* remove M4 patch (included upstream, checked)
* added --enable-conduits for building userland tools
* added "usb" use flag for --enable-libusb
* TODO: install udev rules (with proper gid, see comment #30)?
Comment 36 Hans Meine 2007-02-03 22:41:58 UTC
Created attachment 109051 [details]
updated 0.12.1 ebuild w/ python/java/tcltk/USB/userland support

this is annoying: [no attachments can be made obsolete], actually this *does* obsolete the "0.12.1 ebuild"
Comment 37 Hans Meine 2007-02-03 22:43:16 UTC
Created attachment 109053 [details, diff]
arch-aware sandboxed install of java libpisock.so

sent to upstream ML
Comment 38 Hans Meine 2007-02-03 22:44:26 UTC
Created attachment 109054 [details, diff]
fixes --with-python support in configure

(equivalent patch) sent to upstream ML
Comment 39 Hans Meine 2007-02-03 22:47:23 UTC
Created attachment 109055 [details, diff]
fix sandboxed python install

equivalent to http://bugs.gentoo.org/attachment.cgi?id=82887 (which I found later)
Comment 40 Luca Botti 2007-02-04 08:47:47 UTC
Why not yet in portage, even hard masked? still missing the kde 3.5.6 pim application.
Comment 41 Aniruddha 2007-02-15 16:26:18 UTC
Can someone enlighten me on the situation with pilot-link? Why isn't it in portage already? Any chance this going to happen soon? Debian stable has the same version for crying out loud.I really would like to use the new kpilot (I have serious troubles with this one). Thanks in advance!

Debian:
http://packages.debian.org/cgi-bin/search_packages.pl?keywords=pilot-link+&searchon=names&subword=1&version=all&release=all
Comment 42 Lloeki 2007-02-17 20:15:10 UTC
0.12.2 is out (with great features).

ebuild above seems to work without the patches (commented out the epatch in src_unpack()
maybe some bluetooth use flag will be needed
Comment 43 Wickersheimer Jeremy 2007-02-25 03:55:16 UTC
Just to give some feedback:

0.12.1 works fine for me (but i needed to disable the tests)
0.12.2 compile but doesn't work zith kpilot-3.5.6.
Comment 44 Andy Botting 2007-02-26 04:20:03 UTC
Evolution doesn't compile against pilot-link-0.12.* without a patch. I found a patch in the gnome bugzilla to update the evolution conduits.

http://bugzilla.gnome.org/attachment.cgi?id=78892&action=view

This applies cleanly against evolution-2.8.3, and appears to work fine, for those who might be interested. 
Comment 45 Chris Smith 2007-03-19 21:35:51 UTC
Created attachment 113813 [details]
pilot-link-0.12.2.ebuild

Appears that pilot-link-0.12.2.ebuild does not need the patches, but it does need a newer libmal and some backport fixes to kpilot.
Comment 46 Chris Smith 2007-03-19 21:38:05 UTC
Created attachment 113815 [details]
dev-libs/libmal-0.44.ebuild

To support >=pilot-link-0.12.0.
Comment 47 Chris Smith 2007-03-19 21:39:33 UTC
Created attachment 113816 [details]
kde-base/kpilot-3.5.6.ebuild

This ebuild applies the backported patches for >=pilot-link-0.12.2.
Comment 48 Chris Smith 2007-03-19 21:40:46 UTC
Created attachment 113818 [details, diff]
patchset for kpilot

place in kpilot $FILESDIR
Comment 49 Chris Smith 2007-03-20 17:25:37 UTC
Just a note that pilot-link-0.12.2 + libmal-0.44 appear to work just fine with jpilot-0.99.9 (also not in the portage tree although released on 8/27/06).

WIth the newer pilot-link a friend can now sync his Palm m515, previously he couldn't.

Chris
Comment 50 Jukka Palko 2007-03-22 11:16:40 UTC
Looks like the 0.12.2 ebuild causes some problems with evince update:
>>> Emerging (1 of 6) app-text/evince-0.6.1-r2 to /
 * evince-0.6.1.tar.bz2 RMD160 ;-) ...                                                                                                                                   [ ok ]
 * evince-0.6.1.tar.bz2 SHA1 ;-) ...                                                                                                                                     [ ok ]
 * evince-0.6.1.tar.bz2 SHA256 ;-) ...                                                                                                                                   [ ok ]
 * evince-0.6.1.tar.bz2 size ;-) ...                                                                                                                                     [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                                     [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                                    [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                   [ ok ]
 * checking evince-0.6.1.tar.bz2 ;-) ...                                                                                                                                 [ ok ]
>>> Unpacking source...
>>> Unpacking evince-0.6.1.tar.bz2 to /var/tmp/portage/app-text/evince-0.6.1-r2/work
 * Applying evince-0.5.3-display-menu.patch ...                                                                                                                          [ ok ]
 * Applying evince-0.6.1-dbus-switch.patch ...                                                                                                                           [ ok ]
 * Running eautoreconf in '/var/tmp/portage/app-text/evince-0.6.1-r2/work/evince-0.6.1' ...
 * Running aclocal ...                                                                                                                                                   [ !! ]
 
 * Failed Running aclocal !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/app-text/evince-0.6.1-r2/temp/aclocal-17440.out
 
 
!!! ERROR: app-text/evince-0.6.1-r2 failed.
Call stack:
  ebuild.sh, line 1614:   Called dyn_unpack
  ebuild.sh, line 751:   Called qa_call 'src_unpack'
  environment, line 3654:   Called src_unpack
  evince-0.6.1-r2.ebuild, line 79:   Called eautoreconf
  autotools.eclass, line 93:   Called eaclocal
  autotools.eclass, line 130:   Called autotools_run_tool 'aclocal'
  autotools.eclass, line 218:   Called die
 
!!! Failed Running aclocal !
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/app-text/evince-0.6.1-r2/temp/build.log'.
 
# cat /var/tmp/portage/app-text/evince-0.6.1-r2/temp/aclocal-17440.out
***** aclocal *****
 
/usr/bin/m4:/usr/share/aclocal/pilot-link.m4:1: ERROR: end of file in string
autom4te-2.61: /usr/bin/m4 failed with exit status: 1
aclocal-1.10: autom4te failed with exit status: 1
Comment 51 Chris Smith 2007-03-22 16:54:07 UTC
(In reply to comment #50)
> Looks like the 0.12.2 ebuild causes some problems with evince update:

Strange, since pilot-link isn't a depend or an rdepend for evince.
As far as I can tell the two packages should have nothing to do with each other. But I'm not a developer, was just trying to help out a friend who needed to sync his palm. Most of the real work here was done by Hans Meine, finding/creating/etc. the patches and getting them to upstream.

The ebuilds work for me and others but it's one of those YMMV stories.

BTW evince fails here as well - it's not just a one off, but I don't use it so as a non-dev there is little I can do to help.

And since the devs haven't put this stuff in portage yet, there isn't much avenue for a real bug report. My feeling is that it's an ebuild bug, but also the evince version in the portage tree is old as 0.8.0 is out and only 0.6.1 is offered in portage. File a version bump bug, and maybe it will all work.

Chris

Comment 52 Chris Smith 2007-03-22 17:07:40 UTC
(In reply to comment #50)
> Looks like the 0.12.2 ebuild causes some problems with evince update:

Found this:
http://www.mail-archive.com/autoconf%40gnu.org/msg15786.html

Now all we need is someone who knows how to fix it....
Comment 53 Chris Smith 2007-03-23 20:20:52 UTC
Created attachment 114174 [details, diff]
pilot-link-0.12.2.ebuild

applies patch to fix m4 file
Comment 54 Chris Smith 2007-03-23 20:22:09 UTC
Created attachment 114176 [details, diff]
pilot-link-0.12.2-m4.patch

patch for pilot-link-0.12.2, place in $FILESDIR
Comment 55 Chris Smith 2007-03-23 20:24:38 UTC
Created attachment 114179 [details]
pilot-link-0.12.2.ebuild

oops..had this listed as patch previously

This fixes the evince hand on pilot-link.m4, although evince still doesn't build for me - I get other errors:
***** automake *****

gnome-doc-utils.make:63: HAVE_GNOME_DOC_UTILS does not appear in AM_CONDITIONAL
help/Makefile.am:3:   `gnome-doc-utils.make' included from here
gnome-doc-utils.make:74: if $(DOC_H_FILE: non-POSIX variable name
gnome-doc-utils.make:74: (probably a GNU make extension)
help/Makefile.am:3:   `gnome-doc-utils.make' included from here
gnome-doc-utils.make:77: if $(DOC_H_FILE: non-POSIX variable name
gnome-doc-utils.make:77: (probably a GNU make extension)
Comment 56 Chris Smith 2007-03-23 20:31:56 UTC
(In reply to comment #55)
> This fixes the evince hand on pilot-link.m4, although evince still doesn't
> build for me - I get other errors:
> ***** automake *****
> 
> gnome-doc-utils.make:63: HAVE_GNOME_DOC_UTILS does not appear in AM_CONDITIONAL

Actually, app-text/evince-0.6.1-r2 installs just fine now. I forgot I had been testing it renamed to app-text/evince-0.8.0 which apparently wont work without some patches.
Comment 57 Jukka Palko 2007-03-24 05:30:56 UTC
Shouldn't it be
epatch ${FILESDIR}/$(P)-m4.patch
in the ebuild?
Comment 58 Chris Smith 2007-03-24 18:20:41 UTC
(In reply to comment #57)
> Shouldn't it be
> epatch ${FILESDIR}/$(P)-m4.patch
> in the ebuild?

Works the same. It's a flexible naming convention that's probably more useful for gentoo specific patches that might change slightly with each package version. This patch is not gentoo specific, it's from upstream, and we probably wont need it again for the next release.

It's GPL, write it however you like.

Chris
Comment 59 Jukka Palko 2007-03-25 05:44:45 UTC
Okay, I'm just curious of gentoo ebuild writing "standards" and "policies". Best distro around and I'd like to be able to contribute into it in "the proper way". 

It's described in a way on gentoo developer info pages, but real life ebuilds teach much more than those definitions that are clear to people already involved in contributiog.
Comment 60 Chris Smith 2007-03-26 05:17:28 UTC
(In reply to comment #59)
> Okay, I'm just curious of gentoo ebuild writing "standards" and "policies".

so submit a patched ebuild and recommend it be included in the portage tree, no need to start a pissing contest over the semantics of an unofficial ebuild provided by someone who was just trying to help out

guess it's time for me to focus on writing apt packages instead
Comment 61 Jukka Palko 2007-03-26 05:37:40 UTC
No, you got me wrong, I didn't mean to start a pissing contest. I'm sorry if I explained myself badly.

I'm just interested in what gentoo developers consider to be the right way to do things.
Comment 62 Simon Ruggier 2007-03-26 05:39:52 UTC
(In reply to comment #60)
> so submit a patched ebuild and recommend it be included in the portage tree, no
> need to start a pissing contest over the semantics of an unofficial ebuild
> provided by someone who was just trying to help out

It's nice that you're helping out and all, but don't be rude, all he did was ask if a change made sense, I wouldn't call that starting a pissing contest.

With regards to the question, think about what would happen if you renamed the ebuild file to build a newer version of pilot-link.  If the name and version are hard coded, then that line will still attempt to apply the patch to the newer version of the source code, whereas if you have $(P) in there, you'll have to copy the patch file, or delete that epatch line.  It's not a big difference, but it doesn't make sense to put $(P) in on that line.
Comment 63 Jukka Palko 2007-03-27 10:10:26 UTC
Anyway, the 0.12.2 + the m4 patch confirmed to work nicely on my machine as well.
Comment 64 Carsten Lohrke (RETIRED) gentoo-dev 2007-04-06 09:38:51 UTC
Alastair, it's time to do something about this bug. The KPilot version which is blocked atm. fixes quite some bugs. And if I read the upstream information correctly, gnome-pilot 2.0.15 should work with 0.12.x. Please add it at least masked to the tree, so people can actually test if their app works with it.
Comment 65 Michael Krelin 2007-04-16 13:29:15 UTC
I am sorry for intervening at such a late stage of development, but I managed to come up with an ebuild of my own before I looked into the bug. And despite my modesty (which is my only fault, so it's not all that bad), I have to state that my ebuild is better in a number of ways. It

1. adds a bluetooth USE to control --with-bluez and also contains a patch that makes it work.
2. contains a fix for java bindings parallel build. It contains another java install fix too, but java binding won't work, anyway. It should pretty easy to fix, but since I have absolutely no expierence with it I'd leave it for those who do.
3. it adds threads USE-flag to control thread-safety.
4. it removes tk USE-flags which has no effect on the package.
5. it looks better (to me, don't take it to heart) ;-)

It has shortcomings too (not that other ebuilds don't suffer these). As I mentioned java bindings don't work and tcl as well, because it seems tcl-bindings don't go in sync with library. Well, I hope java and tcl guys can take care of it.

Thanks for your time, files follow...
Comment 66 Michael Krelin 2007-04-16 13:30:15 UTC
Created attachment 116442 [details]
pilot-link-0.12.2.ebuild
Comment 67 Michael Krelin 2007-04-16 13:31:11 UTC
Created attachment 116443 [details, diff]
pilot-link-0.12.2-build.patch
Comment 68 Michael Krelin 2007-04-16 16:49:07 UTC
Meanwhile, I've talked to upstream and they seem to accept most if not all patches for 0.12.3. And they're going to remove tcl bindings too, which sounds like a great relief ;-)
Comment 69 Carsten Lohrke (RETIRED) gentoo-dev 2007-04-17 17:16:37 UTC
Michael: Input is always appreciated. :)

pda team: If I do not get a reply, I'll go ahead.
Comment 70 Michael Krelin 2007-04-17 17:44:52 UTC
(In reply to comment #69)
> Michael: Input is always appreciated. :)

Good to hear ;-) I think we can safely drop tcl and java should be relatively easy  to install provided that someone has any idea about gentoo's java unlike me ;-)

And if, by chance, you will want more input feel free to find me @freenode as polyonymous (mostly on #gentoo-db) almost anytime.
Comment 71 Laurenz Gamper 2007-05-03 13:36:49 UTC
Is there a reason, why the ebuild is not even included in portage? e.g. Kpilot 3.5.6 depends on pilot-link >= 0.12
Comment 72 Neil Bothwick 2007-05-10 08:35:25 UTC
(In reply to comment #66)
> Created an attachment (id=116442) [edit]
> pilot-link-0.12.2.ebuild

I had to add the m4 patch to this, otherwise I was getting aclocal failures when emerging hal and xscreensaver.

Comment 73 Michael Krelin 2007-05-10 10:34:07 UTC
> 
> I had to add the m4 patch to this, otherwise I was getting aclocal failures
> when emerging hal and xscreensaver.
> 

Hmm... Strange, for what I see in the patch (from comment 67) the m4 patch is there.
Comment 74 Neil Bothwick 2007-05-10 10:38:50 UTC
It's not the same patch. The one in pilot-link-0.12.2-m4.patch is more extensive. I tried without and with pilot-link-0.12.2-m4.patch and the problem only went away after applying the separate patch, which I applied after pilot-link-0.12.2-build.patch

src_unpack() {
        unpack ${A}
        cd "${S}"
        epatch "${FILESDIR}/${P}-build.patch"
        epatch "${FILESDIR}/${P}-m4.patch"
        eautoconf
        eautomake
}
Comment 75 Michael Krelin 2007-05-10 11:34:34 UTC
(In reply to comment #74)
> It's not the same patch. The one in pilot-link-0.12.2-m4.patch is more
> extensive. I tried without and with pilot-link-0.12.2-m4.patch and the problem

Yes, but the m4 problem should be solved by the shorter one... Besides, I'm not sure if the extensive version contains anything but this short one and whitespace changes (haven't checked through, though).

> only went away after applying the separate patch, which I applied after
> pilot-link-0.12.2-build.patch
> 
> src_unpack() {
>         unpack ${A}
>         cd "${S}"
>         epatch "${FILESDIR}/${P}-build.patch"
>         epatch "${FILESDIR}/${P}-m4.patch"
>         eautoconf
>         eautomake
> }

This is strange, since I have my version installed here and experience no problem... Should, probably recheck it... The funny thing is that the m4 patch should not apply _after_ build one, it should fail... Well, again, need to check it once more.
Comment 76 Neil Bothwick 2007-05-10 11:58:46 UTC
(In reply to comment #75)
> Yes, but the m4 problem should be solved by the shorter one... 

Since when did computers do what they should.

I know I tried this on two systems, one ~amd64 and one ~ppc and the longer patch was needed to get rid of the errors. If it will help, I can reinstall with the shorter patch and let you have the error messages.


Comment 77 Sal Gonzalez 2007-05-10 12:21:14 UTC
Don't know if it helps, but I just installed pilot-link-0.12.2, with only the pilot-link-0.12.2-build.patch, as well ass kpilot-3.5.6 with the attached patchset and the attached libmal-0.44.  After unmasking oodles of kde 3.5.6 packages (split-ebuilds,)  I had no compile problems, for good measure I remerged hal.  This was done on one amd64 system and 2 x86 systems.  kpilot seems to be working properly.
Comment 78 Michael Krelin 2007-05-10 12:59:12 UTC
(In reply to comment #76)
> Since when did computers do what they should.

That depends on how convincing you sound when you try to persuade them ;-)

> I know I tried this on two systems, one ~amd64 and one ~ppc and the longer
> patch was needed to get rid of the errors. If it will help, I can reinstall
> with the shorter patch and let you have the error messages.

I think I'll try it myself if I get time. So, you install pilot-link and then install of xscreensaver fails on aclocal, right?

(In reply to comment #77)
> Don't know if it helps, but I just installed pilot-link-0.12.2, with only the
> pilot-link-0.12.2-build.patch, as well ass kpilot-3.5.6 with the attached
> patchset and the attached libmal-0.44.  After unmasking oodles of kde 3.5.6
> packages (split-ebuilds,)  I had no compile problems, for good measure I
> remerged hal.  This was done on one amd64 system and 2 x86 systems.  kpilot
> seems to be working properly.

The problem is not installing pilot-link, but doing auto* stuff afterwords. Not sure if kde is affected, although, most likely...
Comment 79 Sal Gonzalez 2007-05-10 13:31:12 UTC
I can confirm the xscreensaver-5.02 aclocal bug, on both amd64 & x86.  The output of aclocal is:

***** aclocal *****

configure.in:307: warning: underquoted definition of AC_PROG_CC_ANSI
configure.in:307:   run info '(automake)Extending aclocal'
configure.in:307:   or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
/usr/bin/m4:/usr/share/aclocal/pilot-link.m4:1: ERROR: end of file in string
autom4te-2.61: /usr/bin/m4 failed with exit status: 1
aclocal-1.10: autom4te failed with exit status: 1
Comment 80 Neil Bothwick 2007-05-10 14:08:47 UTC
(In reply to comment #78)
> So, you install pilot-link and then
> install of xscreensaver fails on aclocal, right?

Right.
Comment 81 Michael Krelin 2007-05-10 14:21:31 UTC
Created attachment 118752 [details, diff]
fixed pilot-link-0.12.2-build.patch

Thanks and sorry, here's an updated build patch.
Comment 82 Michael Krelin 2007-05-10 14:23:47 UTC
(In reply to comment #80)
> (In reply to comment #78)
> > So, you install pilot-link and then
> > install of xscreensaver fails on aclocal, right?
> 
> Right.

Once again, thanks and, as usually, computer have done exactly what it should have done, but I haven't :)
Comment 83 Neil Bothwick 2007-05-10 14:40:36 UTC
Sorry, it still doesn't work. If I emerge pilot-link with the new build.patch and then emerge hal, I get this

 * Running eautoreconf in '/var/tmp/portage/sys-apps/hal-0.5.9-r1/work/hal-0.5.9' ...
 * Running aclocal ...                                                                                                                                                                       [ !! ]

 * Failed Running aclocal !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/sys-apps/hal-0.5.9-r1/temp/aclocal-1698.out


!!! ERROR: sys-apps/hal-0.5.9-r1 failed.

And

% cat /var/tmp/portage/sys-apps/hal-0.5.9-r1/temp/aclocal-1698.out
***** aclocal *****

/usr/share/aclocal/wxwin.m4:36: warning: underquoted definition of AM_OPTIONS_WXCONFIG
/usr/share/aclocal/wxwin.m4:36:   run info '(automake)Extending aclocal'
/usr/share/aclocal/wxwin.m4:36:   or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
/usr/bin/m4:/usr/share/aclocal/pilot-link.m4:1: ERROR: end of file in string
autom4te-2.61: /usr/bin/m4 failed with exit status: 1
aclocal-1.10: autom4te failed with exit status: 1

When I added the separate m4 patch to the ebuild, it worked again.
Comment 84 Michael Krelin 2007-05-10 14:46:45 UTC
Created attachment 118753 [details, diff]
really fixed pilot-link-0.12.2-build.patch

oops ;-)
Comment 85 Michael Krelin 2007-05-10 14:48:25 UTC
(In reply to comment #83)
> Sorry, it still doesn't work. If I emerge pilot-link with the new build.patch

Yes, I know :-( attached too soon.
Comment 86 Sal Gonzalez 2007-05-10 15:13:17 UTC
xscreensaver-5.02 now gets past aclocal fine with 'really fixed pilot-link-0.12.2-build.patch' on amd64 & x86 for me.
Comment 87 Michael Krelin 2007-05-10 15:23:41 UTC
> xscreensaver-5.02 now gets past aclocal fine with 'really fixed
> pilot-link-0.12.2-build.patch' on amd64 & x86 for me.

Thanks for report, Sal!
Comment 88 Neil Bothwick 2007-05-10 16:12:55 UTC
It's working now, on ~amd64 and ~ppc. Thanks for the fix.
Comment 89 Michael Krelin 2007-05-10 17:12:50 UTC
(In reply to comment #88)
> It's working now, on ~amd64 and ~ppc. Thanks for the fix.

Thanks for the report, Neil.
Comment 90 Marcus D. Hanwell (RETIRED) gentoo-dev 2007-05-26 20:12:02 UTC
Had to allow kpilot-3.5.5 with kde 3.5.7. This is far from ideal but at least works for now with the split ebuilds. It would be good to get this bumped for those kpilot users. Personally I do not use this stuff and so cannot test.
Comment 91 Daniel Seifert 2007-06-15 21:07:19 UTC
0.12.2 is now out for over 4 months and the latest ebuild in portage is for 0.11.8 (released 4 years ago). There are significant improvements in 0.12.x and it would be helpful for many users to be able to use 0.12. I urge the maintainers to please look into this (again) and make an ebuild available via portage.
Comment 92 Laurenz Gamper 2007-06-21 11:53:19 UTC
xscreensaver and hal emerge without problems on my system after installing with the really fixed patch.

I'd be happy if this ebuild would make it soon into the portage tree.
Comment 93 Marek Szuba gentoo-dev 2007-07-12 07:26:20 UTC
I would also like to request the inclusion of pilot-link-0.12.2 into the portage tree. Among other things, the new branch makes it possible to transfer Palm standard-violating program files with resources exceeding 64 kB (two such files are included in the IBM WebSphere Java environment for PalmOS), which with older versions would make it impossible to back one's Palm up without creating exclusion lists for pilot-xfer.
Comment 94 juantxorena@gmail.com 2007-07-20 19:18:18 UTC
A working ebuild for the new version is provided here, and this is a blocking bug for kde-3.5.7 stabilization. What are we waiting for? KDE-5.0?
Comment 95 juantxorena@gmail.com 2007-07-26 11:10:04 UTC
Hello, pda people? Is someone alive? There is an ebuild, you only have to put it on portage tree.
Comment 96 Wulf Krueger (RETIRED) gentoo-dev 2007-08-25 17:22:24 UTC
(In reply to comment #95)
> Hello, pda people? Is someone alive? There is an ebuild, you only have to put
> it on portage tree.

Yes, and this ebuild unfortunately has numerous issues:

- automagic deps on readline, libpng
- the threads USE flag doesn't work, i. e. another automagic dep
- debugging is unconditionally switched on (i. e. debug USE flag is missing)
- java handling is wrong (cf. java-pkg-opt-2.eclass)
- the tcl bindings don't compile here and upstream says they should be disabled.
- virtual/libc shouldn't be in RDEPEND.
- a DEPEND on dev-libs/popt is missing
- DEPEND contains virtual/jre which is wrong
- doesn't compile with -readline
- instead of eautoconf and eautomake, eautoreconf should be used.
- etc. etc.

I'm working on an ebuild but am battling myself with several automagic problems, the worst of which being bluez.
Comment 97 Michael Krelin 2007-08-25 18:36:54 UTC
I can fix some of these issues with my ebuild, but not all. In particular, I don't want to mess with java part. Anyway, I'm willing to help and of the gentoo channels you can find me on #gentoo-db as a 'polyonymous'. Feel free to /msg too. I didn't want to disturb you with /msg-ing and don't see an appropriate channel in your /whois.
 
> - automagic deps on readline, libpng
> - the threads USE flag doesn't work, i. e. another automagic dep
> - debugging is unconditionally switched on (i. e. debug USE flag is missing)
> - java handling is wrong (cf. java-pkg-opt-2.eclass)
> - the tcl bindings don't compile here and upstream says they should be
> disabled.
> - virtual/libc shouldn't be in RDEPEND.
> - a DEPEND on dev-libs/popt is missing
> - DEPEND contains virtual/jre which is wrong
> - doesn't compile with -readline
> - instead of eautoconf and eautomake, eautoreconf should be used.
> - etc. etc.
> 
> I'm working on an ebuild but am battling myself with several automagic
> problems, the worst of which being bluez.

Comment 98 Wulf Krueger (RETIRED) gentoo-dev 2007-08-25 19:49:08 UTC
 (In reply to comment #97)
> I can fix some of these issues with my ebuild, but not all. In particular, I
> don't want to mess with java part. Anyway, I'm willing to help and of the gentoo
> channels you can find me on #gentoo-db as a 'polyonymous'. Feel free to /msg
> too. I didn't want to disturb you with /msg-ing and don't see an appropriate
> channel in your /whois.

Don't worry about disturbing me. You (and anyone else) can /query or /msg me at any time - just an answer is not guaranteed at all times. ;-)

Anyway, I was more stubborn than pilot-link ;) and, thus, 0.12.2 is now in the tree. At the moment, it's package.mask'ed because it would cause other packages to break and so I've filed bug 190218 to the maintainers/herds of the affected packages.

Please test it in any way you can and gives us feedback here. (Leaving this bug open for now.)

Thanks, Michael, for your efforts here. They are appreciated - this is just one of those package versions from hell. ;-)
Comment 99 Michael Krelin 2007-08-25 21:12:24 UTC
> Don't worry about disturbing me. You (and anyone else) can /query or /msg me at
> any time - just an answer is not guaranteed at all times. ;-)

I will keep that in mind ;-)

> Anyway, I was more stubborn than pilot-link ;) and, thus, 0.12.2 is now in the
> tree. At the moment, it's package.mask'ed because it would cause other

Built fine. I use it once in a rare while, so I haven't tested it extensively, but reporting as much as I can  ;-)

> Thanks, Michael, for your efforts here. They are appreciated - this is just one
> of those package versions from hell. ;-)

You're welcome, I was just scratching my own itch and letting others benefit from itch ;-)
Comment 100 Wulf Krueger (RETIRED) gentoo-dev 2007-09-17 21:30:36 UTC
I've unmasked 0.12.2 earlier today. Thus: Fixed in CVS.