Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 87804 - Patches for kde to compile with gcc4
Summary: Patches for kde to compile with gcc4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 99498 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-04-03 09:48 UTC by Genady Okrain
Modified: 2005-09-25 13:27 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
konqueror-3.4.0-konq_mainwindow.patch (konqueror-3.4.0-konq_mainwindow.patch,1.60 KB, text/plain)
2005-04-03 09:49 UTC, Genady Okrain
Details
libkdenetwork-3.4.0-gcc4.patch (libkdenetwork-3.4.0-gcc4.patch,419 bytes, text/plain)
2005-04-03 09:49 UTC, Genady Okrain
Details
admin-visibility.patch (admin-visibility.patch,820 bytes, text/plain)
2005-04-03 09:50 UTC, Genady Okrain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Genady Okrain 2005-04-03 09:48:52 UTC
ugly disable visibility hack and more ugly hacks :(

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Genady Okrain 2005-04-03 09:49:19 UTC
Created attachment 55197 [details]
konqueror-3.4.0-konq_mainwindow.patch
Comment 2 Genady Okrain 2005-04-03 09:49:49 UTC
Created attachment 55198 [details]
libkdenetwork-3.4.0-gcc4.patch
Comment 3 Genady Okrain 2005-04-03 09:50:23 UTC
Created attachment 55199 [details]
admin-visibility.patch

must be patched to all kde-base apps
Comment 4 SpanKY gentoo-dev 2005-04-03 10:08:50 UTC
no point in adding ugly hacks ... might as well get a proper fix from upstream ...
Comment 5 Genady Okrain 2005-04-03 10:24:44 UTC
It's a temporal fix until they will fix it.
Comment 6 Gregorio Guidi (RETIRED) gentoo-dev 2005-04-03 16:09:29 UTC
Were the patches filed at bugs.kde.org already?
Comment 7 Hanno Boeck gentoo-dev 2005-05-04 08:29:21 UTC
I'm not sure if it's the same issue, but it seems gcc generates wrong code within kde:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=20973

Maybe the gcc-fixes should be added to the gcc4-ebuild (or a cvs-branch-update to the gcc-ebuild to fix all regressions found lately in the gcc 4.0.0 release).
Comment 8 Mark Loeser (RETIRED) gentoo-dev 2005-05-13 15:39:09 UTC
I updated the GCC4 ebuild to the newest snapshot the other day.  That build contains the fixes for the wrong code generation.
Comment 9 SpanKY gentoo-dev 2005-05-14 11:49:50 UTC
is this an issue for gcc-3.4 + visiblity too ?  if so, we should add the patches to our 3.4 toolchain ...
Comment 10 Gregorio Guidi (RETIRED) gentoo-dev 2005-07-19 04:48:53 UTC
*** Bug 99498 has been marked as a duplicate of this bug. ***
Comment 11 Mark Loeser (RETIRED) gentoo-dev 2005-09-11 10:43:17 UTC
Are these patches still needed?
Comment 12 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-09-25 13:27:35 UTC
This should not be needed anymore. 
The visibility stuff has bad behavior against other c++ libraries so must be 
blacklisted.