Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 87613 - x11-base/xorg-x11-6.8.2-r1 can't find libfl
Summary: x11-base/xorg-x11-6.8.2-r1 can't find libfl
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 88005 88092 88566 89087 89171 92837 93459 98011 98577 99032 100433 100517 101072 102589 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-04-01 17:04 UTC by postmodern
Modified: 2005-08-15 06:00 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description postmodern 2005-04-01 17:04:26 UTC
was emerging xorg-x11 and this happened out of the blue.

Reproducible: Always
Steps to Reproduce:
1. emerge xorg-x11
2.
3.

Actual Results:  
i686-pc-linux-gnu-gcc -o pswrap -pipe -O3 -march=i686 -fno-strict-aliasing -ansi
-pedantic -Wno-return-type -w     -L../../exports/lib   main.o pswparser.o
lexer.o pswdict.o pswfile.o         systemnames.o psw.o pswstring.o
pswsemantics.o     -lfl  -Wl,-rpath-link,../../exports/lib
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5/../../../../i686-pc-linux-gnu/bin/ld:
cannot find -lfl
collect2: ld returned 1 exit status
make[4]: *** [pswrap] Error 1
make[4]: Leaving directory
`/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/config/pswrap'
make[3]: *** [../../config/pswrap/pswrap] Error 2
make[3]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/lib/dps'
make[2]: *** [includes] Error 2
make[2]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/lib'
make[1]: *** [includes] Error 2
make[1]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc'
make: *** [World] Error 2

!!! ERROR: x11-base/xorg-x11-6.8.2-r1 failed.
!!! Function build, Line 951, Exitcode 2
!!! make World failed
!!! If you need support, post the topmost build error, NOT this status message.


Expected Results:  
success.

Gentoo Base System version 1.4.16
Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5, glibc-2.3.4.20041102-r1,
2.6.11-gentoo-r3 i686)
=================================================================
System uname: 2.6.11-gentoo-r3 i686 
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Mar 10 2005, 18:18:11)]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.5, 1.6.3, 1.8.5-r3, 1.7.9-r1, 1.4_p6, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r1
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-pipe -O3 -march=i686"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-pipe -O3 -march=i686"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apm avi berkdb bitmap-fonts crypt emboss encode flac foomaticdb
fortran gdbm gif gnome gpm gtk gtk2 imlib ipv6 jpeg libg++ libwww mad mikmod
motif mp3 mpeg ncurses network oggvorbis opengl oss pam pdflib perl png python
quicktime readline sdl speex spell ssl svga tcpd theora truetype truetype-fonts
type1-fonts xml2 xv zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY
Comment 1 Dion Sole 2005-04-01 17:20:10 UTC
Does "/usr/lib/libfl.a" exist?
Comment 2 postmodern 2005-04-01 17:36:18 UTC
/usr/lib/libfl* does not exist.
Comment 3 Dion Sole 2005-04-01 18:21:44 UTC
Could you try "emerge --oneshot sys-devel/flex", and see if that fixes the issue?

Xorg-x11 depends on this, and it is the package that provides the libfl* files.
I dunno why it isn't installed, as it should have been pulled in as part of the xorg emerge.
Comment 4 Donnie Berkholz (RETIRED) gentoo-dev 2005-04-01 18:52:54 UTC
It looks like you didn't read the documentation when you installed.

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=6

Note the --emptytree argument. You can alternately use --newuse.
Comment 5 postmodern 2005-04-01 20:29:16 UTC
oneshoting dev-lang/flex in then emerging xorg-x11 solved the problem.

As for not reading the documentation, your going to have to be alittle more specific on what the mistake and solution were.
Comment 6 postmodern 2005-04-01 20:32:12 UTC
Nevermind, I see my mistake now. I will adjust my scripts to the new stage2 -> stage3 procedure.
Comment 7 Donnie Berkholz (RETIRED) gentoo-dev 2005-04-05 08:56:21 UTC
*** Bug 88005 has been marked as a duplicate of this bug. ***
Comment 8 Donnie Berkholz (RETIRED) gentoo-dev 2005-04-05 20:02:36 UTC
*** Bug 88092 has been marked as a duplicate of this bug. ***
Comment 9 Donnie Berkholz (RETIRED) gentoo-dev 2005-04-10 13:45:00 UTC
*** Bug 88566 has been marked as a duplicate of this bug. ***
Comment 10 Donnie Berkholz (RETIRED) gentoo-dev 2005-04-14 13:01:36 UTC
*** Bug 89087 has been marked as a duplicate of this bug. ***
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2005-04-25 02:16:06 UTC
*** Bug 89171 has been marked as a duplicate of this bug. ***
Comment 12 Donnie Berkholz (RETIRED) gentoo-dev 2005-05-16 15:19:38 UTC
*** Bug 92837 has been marked as a duplicate of this bug. ***
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2005-05-21 12:22:00 UTC
*** Bug 93459 has been marked as a duplicate of this bug. ***
Comment 14 Jakub Moc (RETIRED) gentoo-dev 2005-07-05 08:05:31 UTC
*** Bug 98011 has been marked as a duplicate of this bug. ***
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2005-07-10 10:46:03 UTC
*** Bug 98577 has been marked as a duplicate of this bug. ***
Comment 16 Jakub Moc (RETIRED) gentoo-dev 2005-07-14 15:25:21 UTC
*** Bug 99032 has been marked as a duplicate of this bug. ***
Comment 17 AP Fritts 2005-07-16 10:42:24 UTC
the problem was fixed after I did:

emerge flex
Comment 18 Stephen Leaf 2005-07-16 20:58:36 UTC
I believe I have found the problem! 
I started from stage 2 and in that stage file libfl.a does not exist! 
however if I do a emerge -p flex it says it's already installed. 
thus the reason why flex is not brought in by an emerge xorg-x11 
 
So the problem does not exist in the ebuild itself but rather the stage 
tarballs 
it includes an incomplete install of flex. 
 
This is all done from a chroot'ed stage2 tarball. 
here you'll see that flex is installed. both flex and flex++ exist but the 
libfl.a does not. 
 
hotaru / # emerge -p flex 
 
These are the packages that I would merge, in order: 
 
Calculating dependencies ...done! 
[ebuild   R   ] sys-devel/flex-2.5.4a-r5 
hotaru / # emerge -ep xorg-x11 | grep flex 
[ebuild  N    ] sys-devel/flex-2.5.4a-r5 
hotaru / # nano a.cpp 
hotaru / # gcc -lfl a.cpp 
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5/../../../../i686-pc-linux-gnu/bin/ld: 
cannot find -lfl 
collect2: ld returned 1 exit status 
hotaru / # flex 
flex    flex++ 
hotaru / # ls -l /usr/lib/libfl.a 
ls: /usr/lib/libfl.a: No such file or directory 
hotaru / # find / | grep libfl.a 
hotaru / # 
Comment 19 Donnie Berkholz (RETIRED) gentoo-dev 2005-07-18 00:13:14 UTC
It's not a problem, it's intentional. That's what comment #4 is about.
Comment 20 Stephen Leaf 2005-07-18 04:48:31 UTC
Is it documented on why you intentionally do this? 
is there any *good* reason to intentionally break packages? 
Comment 21 Donnie Berkholz (RETIRED) gentoo-dev 2005-07-18 11:06:52 UTC
It's not broken, if you follow the instructions. flex doesn't install static
libraries under USE=build (among some other packages), because that takes up
room on the stages/LiveCD's. That's why we specifically tell you what you need
to do in the documentation.
Comment 22 Jakub Moc (RETIRED) gentoo-dev 2005-07-27 00:06:03 UTC
*** Bug 100433 has been marked as a duplicate of this bug. ***
Comment 23 Jakub Moc (RETIRED) gentoo-dev 2005-07-27 14:18:42 UTC
*** Bug 100517 has been marked as a duplicate of this bug. ***
Comment 24 Carsten Lohrke (RETIRED) gentoo-dev 2005-08-02 03:07:00 UTC
*** Bug 101072 has been marked as a duplicate of this bug. ***
Comment 25 Petr Chyba 2005-08-02 03:28:38 UTC
(In reply to comment #21)
> It's not broken, if you follow the instructions.
IMHO it is broken. If you use --newuse (as stated in comment #4 and in the
docs), flex gets rebuilt after xorg-x11, so error stands. You have to do emerge
flex to get rid of it, which is NOT in docs.
Also, if you begin at stage1, it is IMHO not necessary to do even --newuse,
because you did everything from scratch and din't change USE flags after
bootstrap. And result is same (as I wrote in Bug 101072, sorry for the dup,
didn't find this one). If it is necessary, maybe it should be documented, too.
Comment 26 Brian Harring gentoo-dev 2005-08-04 14:28:21 UTC
I would kind of view this as borkage also...
Guessing the solution would be a use dep on flex though?
Comment 27 Jakub Moc (RETIRED) gentoo-dev 2005-08-15 06:00:25 UTC
*** Bug 102589 has been marked as a duplicate of this bug. ***