Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 871621 - media-gfx/inkscape-1.2.1-r2 fails tests
Summary: media-gfx/inkscape-1.2.1-r2 fails tests
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mikle Kolyada
URL: https://gitlab.com/inkscape/inbox/-/i...
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2022-09-19 00:56 UTC by Jonathan Lovelace
Modified: 2022-10-02 16:28 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
LastTest.log (LastTest.log,381.40 KB, text/x-log)
2022-09-19 00:57 UTC, Jonathan Lovelace
Details
media-gfx:inkscape-1.2.1-r2:20220918-202428.log.gz (media-gfx:inkscape-1.2.1-r2:20220918-202428.log.gz,63.48 KB, application/gzip)
2022-09-19 01:00 UTC, Jonathan Lovelace
Details
emerge-info.txt (emerge-info.txt,9.14 KB, text/plain)
2022-09-19 01:00 UTC, Jonathan Lovelace
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Lovelace 2022-09-19 00:56:24 UTC
=media-gfx/inkscape-1.2.1-r2 fails its test phase for me; the test log (and the build log itself) indicate that this is because the test programs weren't built before ctest tried to run them. Searching the Web, I found https://gitlab.com/inkscape/inbox/-/issues/4424 , which isn't *precisely* the same because cmake_src_test calls ctest directly rather than through "make test", but I suspect the solution found there of either passing "--build-and-test" to ctest or calling "emake tests" before calling ctest should fix the issue.
Comment 1 Jonathan Lovelace 2022-09-19 00:57:20 UTC
Created attachment 812593 [details]
LastTest.log
Comment 2 Jonathan Lovelace 2022-09-19 01:00:07 UTC
Created attachment 812596 [details]
media-gfx:inkscape-1.2.1-r2:20220918-202428.log.gz
Comment 3 Jonathan Lovelace 2022-09-19 01:00:52 UTC
Created attachment 812599 [details]
emerge-info.txt
Comment 4 Jonathan Lovelace 2022-09-21 01:55:16 UTC
I tried adding "emake tests" to the ebuild, but there isn't a Makefile there (or anywhere outside of $S/src/3rdparty except $S/share/extensions). Adding a call to "eninja tests" (making sure $PWD at that point is the build directory, $WORKDIR/${P}_build), on the other hand, allows the tests to run successfully.

(I also tried adding --build-and-test to the "myctestargs" array, and eventually got it to work as well (it requires source-dir and build-dir as arguments, and also requires the --build-generator option with its own argument), but that appeared to completely rebuild everything from scratch, so it's a far inferior solution.)