Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 851522 - net-irc/irssi-1.4.1[perl]: inline.h:3489:5: error: ISO C90 forbids mixed declarations and code
Summary: net-irc/irssi-1.4.1[perl]: inline.h:3489:5: error: ISO C90 forbids mixed decl...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sven Wegener
URL:
Whiteboard:
Keywords:
: 851534 851681 (view as bug list)
Depends on:
Blocks: perl-5.36
  Show dependency tree
 
Reported: 2022-06-12 10:17 UTC by yongxiang
Modified: 2022-06-13 07:29 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,197.25 KB, text/plain)
2022-06-12 10:19 UTC, yongxiang
Details
emerge-info (emerge-info,7.51 KB, application/octet-stream)
2022-06-12 10:20 UTC, yongxiang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yongxiang 2022-06-12 10:17:45 UTC
x86_64-pc-linux-gnu-gcc -Isrc/perl/libperl_core.so.p -I. -I../irssi-1.4.1 -Isrc/perl -I../irssi-1.4.1/src/perl -I/usr/include/glib-2.0 -
I/usr/lib64/glib-2.0/include -I/usr/lib64/perl5/5.36/x86_64-linux-thread-multi/CORE -fdiagnostics-color=always -Wall -Winvalid-pch -O0 -
Werror=declaration-after-statement -fno-strict-aliasing -O2 -pipe -march=native -fdiagnostics-color=always -frecord-gcc-switches -ggdb -
fPIC -D_REENTRANT -D_GNU_SOURCE -march=native -fdiagnostics-color=always -frecord-gcc-switches -fwrapv -fno-strict-aliasing -D_LARGEFILE
_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC -pthread '-DSCRIPTDIR="/usr/share/irssi/scripts"' '-DPERL_USE_LIB=""' -DPERL_STATIC_LIBS=0 -MD -MQ
src/perl/libperl_core.so.p/perl-sources.c.o -MF src/perl/libperl_core.so.p/perl-sources.c.o.d -o src/perl/libperl_core.so.p/perl-sources
.c.o -c ../irssi-1.4.1/src/perl/perl-sources.c
In file included from /usr/lib64/perl5/5.36/x86_64-linux-thread-multi/CORE/perl.h:7244,
                 from ../irssi-1.4.1/src/perl/module.h:8,
                 from ../irssi-1.4.1/src/perl/perl-sources.c:23:
/usr/lib64/perl5/5.36/x86_64-linux-thread-multi/CORE/inline.h: In function ‘Perl_cop_file_avn’:
/usr/lib64/perl5/5.36/x86_64-linux-thread-multi/CORE/inline.h:3489:5: error: ISO C90 forbids mixed declarations and code [-Werror=declaration-after-statement]
 3489 |     const char *file = CopFILE(cop);
      |     ^~~~~
cc1: some warnings being treated as errors


Reproducible: Always
Comment 1 yongxiang 2022-06-12 10:19:11 UTC
Created attachment 784274 [details]
build.log

build.log
Comment 2 yongxiang 2022-06-12 10:20:02 UTC
Created attachment 784277 [details]
emerge-info

emerge-info
Comment 3 Larry the Git Cow gentoo-dev 2022-06-12 10:42:10 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d5bde60aca1e5821685c1488d88edf16228eea84

commit d5bde60aca1e5821685c1488d88edf16228eea84
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2022-06-12 10:42:03 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2022-06-12 10:42:03 +0000

    net-irc/irssi: fix build w/ Perl 5.36
    
    Closes: https://bugs.gentoo.org/851522
    Signed-off-by: Sam James <sam@gentoo.org>

 net-irc/irssi/files/irssi-1.4.1-no-werror-decl.patch | 14 ++++++++++++++
 net-irc/irssi/irssi-1.4.1.ebuild                     |  4 ++++
 2 files changed, 18 insertions(+)
Comment 4 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-06-12 12:25:32 UTC
*** Bug 851534 has been marked as a duplicate of this bug. ***
Comment 5 Stephan Hartmann gentoo-dev 2022-06-13 07:29:38 UTC
*** Bug 851681 has been marked as a duplicate of this bug. ***