Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 81416 - dev-python/pylucene (new package)
Summary: dev-python/pylucene (new package)
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://lucene.apache.org/pylucene/
Whiteboard:
Keywords: EBUILD, InOverlay
Depends on: 258896 258902 258903 258905 258906 258907 258908 259312
Blocks: 153512
  Show dependency tree
 
Reported: 2005-02-09 14:50 UTC by Vaclav Slavik
Modified: 2016-10-11 09:02 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-python/pylucene/pylucene-0.9.7.ebuild (pylucene-0.9.7.ebuild,1019 bytes, text/plain)
2005-02-09 14:50 UTC, Vaclav Slavik
Details
pylucene-makefile.patch (pylucene-makefile.patch,679 bytes, patch)
2005-02-09 14:51 UTC, Vaclav Slavik
Details | Diff
dev-python/pylucene/pylucene-0.9.7.ebuild (pylucene-0.9.7.ebuild,1.02 KB, text/plain)
2005-05-16 15:02 UTC, Vaclav Slavik
Details
dev-python/pylucene/pylucene-1.9.1.ebuild (pylucene-1.9.1.ebuild,1.02 KB, text/plain)
2005-12-27 15:30 UTC, Vaclav Slavik
Details
pylucene-1.9.1.ebuild.patch (pylucene-1.9.1.ebuild.diff,460 bytes, patch)
2006-05-01 06:31 UTC, Nicolas Lalevee
Details | Diff
dev-python/pylucene-1.9.1.ebuild (pylucene-1.9.1.ebuild,1.26 KB, text/plain)
2006-06-24 15:44 UTC, Vaclav Slavik
Details
pylucene-makefile.patch (pylucene-makefile.patch,675 bytes, patch)
2006-06-24 15:45 UTC, Vaclav Slavik
Details | Diff
dev-python/pylucene-2.0.0-r1.ebuild (pylucene-2.0.0-r1.ebuild,1.49 KB, text/plain)
2006-07-04 17:13 UTC, Vaclav Slavik
Details
pylucene-2.0-perms.patch (pylucene-2.0-perms.patch,717 bytes, patch)
2006-07-04 17:14 UTC, Vaclav Slavik
Details | Diff
pylucene-2.0-nostrip.patch (pylucene-2.0-nostrip.patch,330 bytes, patch)
2006-07-04 17:14 UTC, Vaclav Slavik
Details | Diff
dev-python/pylucene-2.0.0-r1.ebuild (pylucene-2.0.0-r1.ebuild,1.58 KB, text/plain)
2006-08-13 09:23 UTC, Vaclav Slavik
Details
pylucene-2.0.0-r1.ebuild (pylucene-2.0.0-r1.ebuild,1.68 KB, text/plain)
2006-08-17 02:45 UTC, Vaclav Slavik
Details
New ebuild for pylucene-2.4.0-2 (pylucene-2.4.0.2.ebuild,4.69 KB, text/plain)
2009-02-14 09:03 UTC, Jacob Floyd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vaclav Slavik 2005-02-09 14:50:07 UTC
PyLucene is a GCJ-compiled version of Java Lucene integrated with Python via SWIG. Its goal is to allow you to use Lucene's text indexing and searching capabilities from Python. It is designed to be API compatible with the latest version of Java Lucene.

Lucene is a high-performance, full-featured text search engine library written entirely in Java. It is a technology suitable for nearly any application that requires full-text search, especially cross-platform.

If included, Documancer (already in Portage) could use it, see bug #31999.
Comment 1 Vaclav Slavik 2005-02-09 14:50:44 UTC
Created attachment 50863 [details]
dev-python/pylucene/pylucene-0.9.7.ebuild

Attaching the ebuild...
Comment 2 Vaclav Slavik 2005-02-09 14:51:15 UTC
Created attachment 50864 [details, diff]
pylucene-makefile.patch
Comment 3 Anton Romanov 2005-04-19 07:55:33 UTC
i suppose this ebuild should check wether gcc is installed with 'gcj' USE flag
Comment 4 Anton Romanov 2005-04-29 02:13:41 UTC
analyzers/analysis/nl/WordlistLoader.java: In class `org.apache.lucene.analysis.nl.WordlistLoader':
analyzers/analysis/nl/WordlistLoader.java: In method `org.apache.lucene.analysis.nl.WordlistLoader.getStemDict(java.io.File)':
analyzers/analysis/nl/WordlistLoader.java:71: error: Can't find method `split(Ljava/lang/String;I)' in type `java.lang.String'.
           wordstem = line.split("\t", 2);
                          ^
Comment 5 Vaclav Slavik 2005-05-01 14:02:08 UTC
Re comment #3: yes, but how? I didn't find anything in Ebuild HOWTO nor in ebuilds under /usr/portage...

Re comment #4: and your gcc version is...?
Comment 6 Anton Romanov 2005-05-05 02:29:55 UTC
1.see an example in x11-libs/wxmozilla
2.sys-devel/gcc-3.3.5.20050130-r1
Comment 7 Vaclav Slavik 2005-05-16 15:02:14 UTC
Created attachment 59063 [details]
dev-python/pylucene/pylucene-0.9.7.ebuild

Attaching new ebuild with dependency on gcc >= 3.4, PyLucene apparently
requires its implementation.

As for checking gcj USE flag, this ebuild does it since its first version in
the same way that wxmozilla ebuild does, so I'm more than a little confused by
comment #3.
Comment 8 Anton Romanov 2005-05-17 00:26:48 UTC
i'm confused to, because first time i wanted to emerge pylucene it died during
COMPILATION because it couldn't find gcj :)
Comment 9 Vaclav Slavik 2005-12-27 15:30:11 UTC
Created attachment 75647 [details]
dev-python/pylucene/pylucene-1.9.1.ebuild

Updated to the latest stable upstream version.
Comment 10 Lukasz Strzygowski (RETIRED) gentoo-dev 2006-01-29 04:36:54 UTC
Reassigned to maintainer-wanted. 
Comment 11 Vaclav Slavik 2006-03-26 06:42:52 UTC
The same ebuild works for latest 1.9.1 version.
Comment 12 Nicolas Lalevee 2006-05-01 06:31:10 UTC
Created attachment 85922 [details, diff]
pylucene-1.9.1.ebuild.patch

the 1.9.1 version compiles for me. But I had to modify a little bit the ebuild. The package source tarball hasn't the right name, and it needs swig-1.3.24
Comment 13 Peter Fein 2006-05-23 15:18:10 UTC
This ebuild should probably test for gcc > 3.4, per http://svn.osafoundation.org/pylucene/branches/release-1.9/INSTALL

Looks like I'm gonna need to upgrade. ;(
Comment 14 Vaclav Slavik 2006-06-24 15:44:03 UTC
Created attachment 90057 [details]
dev-python/pylucene-1.9.1.ebuild

Updated the ebuild to work with either gcc-config or eselect-compiler.
Comment 15 Vaclav Slavik 2006-06-24 15:45:24 UTC
Created attachment 90058 [details, diff]
pylucene-makefile.patch

updated pylucene-makefile.patch needed by the latest version of the ebuild
Comment 16 Vaclav Slavik 2006-07-04 17:13:46 UTC
Created attachment 90919 [details]
dev-python/pylucene-2.0.0-r1.ebuild

Updated for latest upstream version ("-r1" is because upstream has 2.0.0-1 packages). Also made some cleanup: Python bytecode is now compiled and stripping of the binary is left to Portage so that /usr/lib/debug works. SWIG is no longer used by upstream.
Comment 17 Vaclav Slavik 2006-07-04 17:14:31 UTC
Created attachment 90920 [details, diff]
pylucene-2.0-perms.patch
Comment 18 Vaclav Slavik 2006-07-04 17:14:52 UTC
Created attachment 90921 [details, diff]
pylucene-2.0-nostrip.patch
Comment 19 Dustin J. Mitchell 2006-07-24 20:30:54 UTC
This doesn't compile on amd64, because it's a multilib system -- `gcc-config -L` returns a colon-separated list of directories, which the ebuild puts into the make variable GCJ_LIBDIR, which the Makefile expects to contain a single directory name.

I'm not much of an ebuild author, so while I'll look the right way to solve this, any pointers would be appreciated.
Comment 20 Dustin J. Mitchell 2006-07-24 20:52:42 UTC
This seems to work -- change the GCC_LDPATH assignment in the ebuild to:
        GCC_LDPATH=$(gcc-config -L | sed 's/:.*//')
(this is taken from gnustep-base/gnustep-base/gnustep-base-1.10.1-r1.ebuild)

Thoughts?
Comment 21 Dustin J. Mitchell 2006-07-24 20:59:46 UTC
I should add that such a patched ebuild could be keyworded ~amd64 -- it compiles and imports into Python, at least.
Comment 22 Vaclav Slavik 2006-07-25 01:22:33 UTC
(In reply to comment #20)
> Thoughts?

The files PyLucene needs are platform independent, so it should be OK to use any of them. Could you please check if the same problem exists (and fix works for) "eselect compiler getval LDPATH" (using eselect-compiler package)? TIA!
Comment 23 Dustin J. Mitchell 2006-08-10 11:09:30 UTC
I installed eselect-compiler and used it without modification:
          GCC_LDPATH=`eselect compiler getval LDPATH`
and it worked fine.

Sorry for the delay.
Comment 24 Vaclav Slavik 2006-08-13 09:23:42 UTC
Created attachment 94153 [details]
dev-python/pylucene-2.0.0-r1.ebuild

New ebuild with amd64 fixes, thanks for the info!
Comment 25 Vaclav Slavik 2006-08-17 02:45:08 UTC
Created attachment 94440 [details]
pylucene-2.0.0-r1.ebuild

I'm getting crashes in PyLucene when indexing and when compiled with gcc-4.1 as well as 4.0, so this version adds checks to verify that gcc-3.4, which works, is used for compilation.
Comment 26 Dustin J. Mitchell 2006-09-12 20:07:48 UTC
Interesting -- your latest revision gives:
  /path/to/pylucene-2.0.0-r1.ebuild: line 29: gcc-version: command not found
I'm not sure what package `gcc-version' is in, but either way, that's probably not going to work!
Comment 27 Vaclav Slavik 2006-09-13 00:20:29 UTC
(In reply to comment #26)
> Interesting -- your latest revision gives:
>   /path/to/pylucene-2.0.0-r1.ebuild: line 29: gcc-version: command not found
> I'm not sure what package `gcc-version' is in, but either way, that's probably
> not going to work!

It's in gcc-config ("qfile gcc-config") and if you look at the ebuild, you can see that a) it has a dependency on it (or eselect-compiler) and b) it checks if gcc-config exists before calling, so the only explanation I have is that you do have /usr/bin/gcc-config (not executable, broken symlink, whatever).
Comment 28 Dustin J. Mitchell 2006-09-13 09:45:24 UTC
(In reply to comment #27)
> It's in gcc-config ("qfile gcc-config") and if you look at the ebuild, you can
> see that a) it has a dependency on it (or eselect-compiler) and b) it checks if
> gcc-config exists before calling, so the only explanation I have is that you do
> have /usr/bin/gcc-config (not executable, broken symlink, whatever).

Yes, I have `gcc-config', but not `gcc-version':

sword-of-justice / $ file /usr/bin/gcc-config
/usr/bin/gcc-config: Bourne-Again shell script text executable
sword-of-justice / $ file /usr/bin/gcc-version
/usr/bin/gcc-version: cannot open `/usr/bin/gcc-version' (No such file or directory)
sword-of-justice / $ equery f gcc-config
[ Searching for packages matching gcc-config... ]
* Contents of sys-devel/gcc-config-1.3.13-r3:
/usr
/usr/bin
/usr/bin/gcc-config
/usr/lib64
/usr/lib64/misc
/usr/lib64/misc/gcc-config

No need to be hostile -- really.
Comment 29 Vaclav Slavik 2006-09-21 09:26:00 UTC
Sorry, misread the report :( gcc-version is a function defined in toolchain-funcs.eclass (which this ebuild inherits), so I don't see how could it possibly be undefined for you (which is probably why I misread it in the first place). Can you see something I'm missing? Hope that saying I don't know is not "hostile" in your eyes.
Comment 30 Dustin J. Mitchell 2006-09-21 18:58:03 UTC
It's my turn for a sheepish grin -- I had updated the ebuild, but missed the change to the 'inherit' declaration when merging it with my local changes.  So gcc-version *is*, in fact, available.

Many apologies.
Comment 31 Ryan 2006-12-11 13:41:11 UTC
the requirement for gcc 3.4 isn't required any more, just successfully compiled with 4.1.1 on amd64
Comment 32 Piotr Malinski 2007-02-11 13:39:30 UTC
It works with gcc 4.1.1 on amd64 (pylucene 2.0.0-8) :)
Comment 33 Gokdeniz Karadag 2008-12-02 18:41:38 UTC
There are newer versions of PyLucene, they depend on JCC, source tarballs exist at
http://downloads.osafoundation.org/PyLucene/jcc/

JCC is bundled within PyLucene, the source tarball can be downloaded seperately from 
http://pypi.python.org/packages/source/J/JCC/JCC-2.1.tar.gz
http://pypi.python.org/pypi/JCC/2.1
Comment 34 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-01-19 21:15:39 UTC
(this is an automated message based on filtering criteria that matched this bug)
'EBUILD' is in the KEYWORDS which should mean that there is a ebuild attached 
to this bug.
This bug is assigned to maintainer-wanted which means that it is not in the 
main tree.

Hello, The Gentoo Team would like to firstly thank you for your ebuild 
submission. We also apologize for not being able to accommodate you in a timely
manner. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The 
sunrise overlay[1] is a overlay for Gentoo which we allow trusted users to 
commit to and all users can have ebuilds reviewed by Gentoo devs for entry 
into the overlay. So, the sunrise team is suggesting that you look into this 
and submit your ebuild to the overlay where even *you* can commit to. =)

Because this is a mass message, we are also asking you to be patient with us. 
We anticipate a large number of requests in a short time. 

Thanks,
On behalf of the Gentoo Sunrise Team,
Jeremy.

[1]: http://www.gentoo.org/proj/en/sunrise/
[2]: http://overlays.gentoo.org/proj/sunrise/wiki/SunriseFaq
Comment 35 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-01-22 21:49:45 UTC
FYI: You can find pylucene-2.0.0-r1 in liquidx's overlay. If anyone has a 2.4.0 ebuild, it is still eligable for sunrise ;)

http://overlays.gentoo.org/dev/liquidx/browser/dev-python/pylucene
Comment 36 Jacob Floyd 2009-02-10 01:00:35 UTC
FYI - an OSAF dev mentioned that pylucene has moved to apache:
http://lucene.apache.org/pylucene/
Comment 37 Jacob Floyd 2009-02-14 00:27:13 UTC
This blocks Bug#77914
Comment 38 Jacob Floyd 2009-02-14 09:03:14 UTC
Created attachment 181977 [details]
New ebuild for pylucene-2.4.0-2

The ebuild builds, and seems to work for me (~x86). However the jakarta useflag does not quite work yet - do not enable it. I'm working with upstream on how to enable it. I'm submitting this ebuild here in preparation for submission to sunrise. Any finishing touches (like the jakarta flag) will be worked out there. Also, with the move to apache, there will be a new version of pylucene soon and the java will change slightly (from org.osafoundation to org.apache) an update will be needed when this happens.
Comment 39 Jacob Floyd 2009-02-19 02:19:08 UTC
After a bit of work and lots of help on #gentoo-java (thanks weisso and
Serkan!) I've redone the ebuild to be a whole lot cleaner and it takes into
account a few other un-niceties in the ebuild I'd already submitted. It uses
the ant-python task which would mean a dependency on dev-java/ant-python
(meaning that this bug would depend on Bug#259312)

As soon as I can I'll get this put up on some overlay or other. e-mail me if you need a copy right away.
Comment 40 Jacob Floyd 2009-04-09 19:23:17 UTC
Version 2.4.1-1 Now available in the java-experimental overlay. All tests work for me on x86. Please test on other arches.
https://overlays.gentoo.org/svn/proj/java/java-experimental/dev-python/pylucene/
(Please add [java-experimental] to the status whiteboard)

This obsoletes all ebuilds attached to this bug.
Comment 41 Patrice Clement gentoo-dev 2016-10-11 09:02:19 UTC
Happy birthday! We're past the 10 years anniversary for this bug report! On a more serious note, PyLucene packaging hasn't happened in the past 10 years and it most likely won't (ever happen). If you're still interested in having this library in the tree, feel free to reopen. I'm also closing depending/blocking bugs.