Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 813312 - dev-python/python-poppler-qt5-0.75.0 - error: command /usr/bin/sip failed with exit code 1
Summary: dev-python/python-poppler-qt5-0.75.0 - error: command /usr/bin/sip failed wit...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 820464
  Show dependency tree
 
Reported: 2021-09-16 07:16 UTC by Toralf Förster
Modified: 2022-05-31 02:52 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.42 KB, text/plain)
2021-09-16 07:16 UTC, Toralf Förster
Details
dev-python:python-poppler-qt5-0.75.0:20210916-005844.log (dev-python:python-poppler-qt5-0.75.0:20210916-005844.log,3.75 KB, text/plain)
2021-09-16 07:16 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,121.12 KB, text/plain)
2021-09-16 07:16 UTC, Toralf Förster
Details
environment (environment,113.66 KB, text/plain)
2021-09-16 07:16 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,21.39 KB, application/x-bzip)
2021-09-16 07:16 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,25.74 KB, application/x-bzip)
2021-09-16 07:16 UTC, Toralf Förster
Details
half-baked ebuild that at least gets it buildling... (python-poppler-qt5-0.75.0-r1.ebuild,627 bytes, text/plain)
2022-01-02 21:38 UTC, Gerard Whitehead
Details
Ebuild for latest release (python-poppler-qt5-21.1.0.ebuild,1.12 KB, text/plain)
2022-03-15 11:01 UTC, Jan Breig
Details
Patch for release 21.1.0 (python-poppler-qt5-21.1.0-unsupported-function-return-type.patch,2.76 KB, patch)
2022-03-15 11:02 UTC, Jan Breig
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-09-16 07:16:31 UTC
/usr/bin/sip -I /usr/share/sip -t POPPLER_V0_74_0 -c /var/tmp/portage/dev-python/python-poppler-qt5-0.75.0/work/python-poppler-qt5-0.75.0-python3_9/temp.linux-x86_64-3.9 -b /var/tmp/portage/dev-python/python-poppler-qt5-0.75.0/work/python-poppler-qt5-0.75.0-python3_9/temp.linux-x86_64-3.9/poppler-qt5.sbf -I /usr/share/sip/PyQt5 -n PyQt5.sip -t Qt_5_15_0 -t WS_X11 -x PyQt_WebChannel poppler-qt5.sip
sip: Unable to find file "QtCore/QtCoremod.sip"
error: command '/usr/bin/sip' failed with exit code 1
 * ERROR: dev-python/python-poppler-qt5-0.75.0::gentoo failed (compile phase):
 *   (no error message)
 * 
 * Call stack:

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_plasma_systemd-j4_abi32+64-20210914-181204

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-11.2.0 *
/usr/lib/llvm/12
12.0.1
Python 3.9.7
Available Ruby profiles:
  (none found)
Available Rust versions:
  [1]   rust-1.55.0 *
The Glorious Glasgow Haskell Compilation System, version 8.10.4
  (none found)

  HEAD of ::gentoo
commit 6668e79536adf33a62a3b3e239389b8cdfed0244
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Wed Sep 15 23:51:29 2021 +0000

    2021-09-15 23:51:28 UTC

emerge -qpvO dev-python/python-poppler-qt5
[ebuild  N    ] dev-python/python-poppler-qt5-0.75.0  PYTHON_TARGETS="python3_9 -python3_8"
Comment 1 Toralf Förster gentoo-dev 2021-09-16 07:16:32 UTC
Created attachment 739515 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-09-16 07:16:33 UTC
Created attachment 739518 [details]
dev-python:python-poppler-qt5-0.75.0:20210916-005844.log
Comment 3 Toralf Förster gentoo-dev 2021-09-16 07:16:34 UTC
Created attachment 739521 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2021-09-16 07:16:36 UTC
Created attachment 739524 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2021-09-16 07:16:37 UTC
Created attachment 739527 [details]
etc.portage.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-09-16 07:16:38 UTC
Created attachment 739530 [details]
temp.tar.bz2
Comment 7 Andreas K. Hüttel archtester gentoo-dev 2021-10-15 09:06:07 UTC
Confirmed in a (mostly) stable installation (on gcc-11 global rebuild)
Comment 8 Davide Pesavento gentoo-dev 2021-10-15 15:45:39 UTC
(In reply to Andreas K. Hüttel from comment #7)
> Confirmed in a (mostly) stable installation (on gcc-11 global rebuild)
Does that mean sip-4.19.25-r1 and PyQt5-5.15.4-r1? Is sip-5.x or 6.x also installed?
Comment 9 Andreas K. Hüttel archtester gentoo-dev 2021-10-16 21:17:57 UTC
(In reply to Davide Pesavento from comment #8)
> (In reply to Andreas K. Hüttel from comment #7)
> > Confirmed in a (mostly) stable installation (on gcc-11 global rebuild)
> Does that mean sip-4.19.25-r1 and PyQt5-5.15.4-r1? Is sip-5.x or 6.x also
> installed?

dev-python/sip-4.19.25-r1 and dev-python/sip-6.2.0

dev-python/PyQt5-5.15.5_pre2107091435

OK, that's not stable, sorry :)
Comment 10 Andrey Grozin gentoo-dev 2021-10-31 14:47:26 UTC
Same here
sip-6.4.0
PyQt5-5.15.6
Comment 11 N. Andrew Walsh 2021-11-13 15:55:06 UTC
(In reply to Andrey Grozin from comment #10)
> Same here
> sip-6.4.0
> PyQt5-5.15.6

same here. python-targets 3.9 and 3.10
Comment 12 Claus-Justus Heine 2021-11-16 10:56:22 UTC
Me too:

dev-python/sip-6.4.0:5::gentoo
dev-python/PyQt5-5.15.6::gentoo

Python-3.9
Comment 13 Claus-Justus Heine 2021-11-16 11:14:06 UTC
I found that

/usr/bin/sip

on my system belongs to sip v4 (which is also pulled in when trying to emerge python-poppler-qt5. However, trying to reinstall PyQt5 pulls in sip v6.

Also, manually sym-linking /usr/lib/python3.9/site-packages/PyQt5/bindings to /usr/share/sip/PyQt5/ results in a syntax error.

So it seems that we have here an incompatibility in the usage of sip v4 vs v6. The sip v6 package also does not provide /usr/bin/sip.

And well, yes: dev-python/PyQt5-5.15.6 is only ~amd64, so ...

There is also a new python-poppler-qt5 v21.1.0 upstream release. Perhaps that one just builds out of the box.
Comment 14 Gerard Whitehead 2022-01-02 21:38:29 UTC
Created attachment 761120 [details]
half-baked ebuild that at least gets it buildling...

Looks like upstream python-poppler-qt5 amended their build systems to support >=sip-5 a while ago and have been recommending away from the old setup.py which uses sip-4.  This is the ebuild I'm using to at least get it to build (correctly generates an importable python module, and subsequently allows Frescobaldi to build and run without issues).  The deeper issue seems to be upstream components having upgraded away from setup.py-style builds that no longer allow sip-4 to do its thing.

I'm by no means an expert at this, and I can see how using sip-install might be unacceptable for use in the main tree (looks like sip-build seems to be OK based on other ebuilds).  Maybe this will be enough inspiration for someone more knowledgable than me to finish the job?  Otherwise I'll try to continue to learn until I can provide something more generally usable.
Comment 15 Jan Breig 2022-03-15 11:01:55 UTC
Created attachment 767098 [details]
Ebuild for latest release

This ebuild works for me.
Tested with dev-python/sip-6.5.0 and PYTHON_TARGETS="python3_9 python3_10".
Release 21.1.0 does not build out of the box. It works by either using the latest git version on master or by using the release and applying the next few commits via patch.
Comment 16 Jan Breig 2022-03-15 11:02:23 UTC
Created attachment 767099 [details, diff]
Patch for release 21.1.0
Comment 17 Davide Pesavento gentoo-dev 2022-04-10 19:43:28 UTC
(In reply to Jan Breig from comment #15)
> Created attachment 767098 [details]
> Ebuild for latest release
> 
> This ebuild works for me.
> Tested with dev-python/sip-6.5.0 and PYTHON_TARGETS="python3_9 python3_10".
> Release 21.1.0 does not build out of the box. It works by either using the
> latest git version on master or by using the release and applying the next
> few commits via patch.

This comment in the ebuild is incorrect:

	# sip does not support separate build and installation

You can use `sip-build` or `sip-build --no-make` for that. For an example, see https://gitweb.gentoo.org/repo/gentoo.git/plain/dev-python/qscintilla-python/qscintilla-python-2.13.1.ebuild
Comment 18 Andrey Grozin gentoo-dev 2022-04-11 03:45:54 UTC
The ebuild for the latest release https://bugs.gentoo.org/attachment.cgi?id=767098 no longer works with qt-5.15.3 because there is no qmake in the $PATH (only qmake5). This ebuild (with the patch https://bugs.gentoo.org/attachment.cgi?id=767099) works if I make the symlink /usr/bin/qmake.
Comment 19 Jan Breig 2022-04-11 14:40:44 UTC
(In reply to Davide Pesavento from comment #17)
> (In reply to Jan Breig from comment #15)
> > Created attachment 767098 [details]
> > Ebuild for latest release
> > 
> > This ebuild works for me.
> > Tested with dev-python/sip-6.5.0 and PYTHON_TARGETS="python3_9 python3_10".
> > Release 21.1.0 does not build out of the box. It works by either using the
> > latest git version on master or by using the release and applying the next
> > few commits via patch.
> 
> This comment in the ebuild is incorrect:
> 
> 	# sip does not support separate build and installation
> 
> You can use `sip-build` or `sip-build --no-make` for that. For an example,
> see
> https://gitweb.gentoo.org/repo/gentoo.git/plain/dev-python/qscintilla-python/
> qscintilla-python-2.13.1.ebuild
I was trying to improve the ebuild from comment #14. The problem was, that `sip-install` compiles AND copies the files to the target location regardless of whether this has been done before by `sip-build`. So using both `sip-build` and `sip-install` does the compilation twice. That's why I put this comment there.
The correct way would probably be to only use sip for compilation and then use some other method for installation but idk how to do that.
Comment 20 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-05-31 02:46:35 UTC
(In reply to Andrey Grozin from comment #18)
> The ebuild for the latest release
> https://bugs.gentoo.org/attachment.cgi?id=767098 no longer works with
> qt-5.15.3 because there is no qmake in the $PATH (only qmake5). This ebuild
> (with the patch https://bugs.gentoo.org/attachment.cgi?id=767099) works if I
> make the symlink /usr/bin/qmake.

See bug 544108 etc.
Comment 21 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-05-31 02:52:11 UTC
commit 238bd01c800450289ebf3ac52b5956c386530104
Author: Michał Górny <mgorny@gentoo.org>
Date:   Sun May 8 16:04:44 2022 +0200

    dev-python/python-poppler-qt5: Bump to 21.3.0

    Signed-off-by: Michał Górny <mgorny@gentoo.org>

I think this might be resolved by ^ and the switch to the sip PEP517 backend.