Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 808903 - dev-util/bazel-1.2.1 - external/.../zlib_client.h: error: numeric_limits is not a member of std (maybe gcc-11 related)
Summary: dev-util/bazel-1.2.1 - external/.../zlib_client.h: error: numeric_limits is n...
Status: RESOLVED DUPLICATE of bug 808827
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Zac Medico
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-08-18 16:08 UTC by Toralf Förster
Modified: 2021-08-29 14:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,18.68 KB, text/plain)
2021-08-18 16:08 UTC, Toralf Förster
Details
dev-util:bazel-1.2.1:20210818-152241.log (dev-util:bazel-1.2.1:20210818-152241.log,140.91 KB, text/plain)
2021-08-18 16:08 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,493.10 KB, text/plain)
2021-08-18 16:08 UTC, Toralf Förster
Details
environment (environment,117.09 KB, text/plain)
2021-08-18 16:08 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,37.76 KB, application/x-bzip)
2021-08-18 16:08 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,10.89 KB, application/x-bzip)
2021-08-18 16:08 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-08-18 16:08:42 UTC
    Compiling external/bazel_tools/.../util/logging.cc [for host]; 0s local
In file included from external/bazel_tools/third_party/ijar/zlib_client.cc:20:
external/bazel_tools/third_party/ijar/zlib_client.h:64:46: error: 'numeric_limits' is not a member of 'std'
   64 |   static const size_t MAX_BUFFER_SIZE = std::numeric_limits<int32_t>::max();
      |                                              ^~~~~~~~~~~~~~
external/bazel_tools/third_party/ijar/zlib_client.h:64:68: error: expected primary-expression before '>' token
   64 |   static const size_t MAX_BUFFER_SIZE = std::numeric_limits<int32_t>::max();

  -------------------------------------------------------------------

  This is an stable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_plasma_systemd-j3_stable-20210810-092808

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.1
 [2] x86_64-pc-linux-gnu-10.3.1
 [3] x86_64-pc-linux-gnu-11.2.0 *
/usr/lib/llvm/12
12.0.1
Python 3.9.6
Available Ruby profiles:
  [1]   ruby26 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.53.0
  [2]   rust-1.53.0 *
The following VMs are available for generation-2:
1)	IcedTea JDK 3.16.0 [icedtea-bin-8]
2)	JamVM JDK 2.0.0 [jamvm]
*)	AdoptOpenJDK 8.292_p10 [openjdk-bin-8]
4)	AdoptOpenJDK JRE 8.292_p10 [openjdk-jre-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8 
  [2]   jamvm 
  [3]   openjdk-bin-8  system-vm
  [4]   openjdk-jre-bin-8 

  [1]   php7.3
  [2]   php7.4 *

  HEAD of ::gentoo
commit 18c9e17df45c895b72e617a65d12762817880318
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Wed Aug 18 14:36:38 2021 +0000

    2021-08-18 14:36:34 UTC

emerge -qpvO dev-util/bazel
[ebuild  N    ] dev-util/bazel-1.2.1  USE="examples -tools"
Comment 1 Toralf Förster gentoo-dev 2021-08-18 16:08:43 UTC
Created attachment 733889 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-08-18 16:08:45 UTC
Created attachment 733891 [details]
dev-util:bazel-1.2.1:20210818-152241.log
Comment 3 Toralf Förster gentoo-dev 2021-08-18 16:08:46 UTC
Created attachment 733893 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2021-08-18 16:08:48 UTC
Created attachment 733895 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2021-08-18 16:08:49 UTC
Created attachment 733897 [details]
etc.portage.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-08-18 16:08:51 UTC
Created attachment 733899 [details]
logs.tar.bz2
Comment 7 Jakov Smolić gentoo-dev 2021-08-29 14:27:12 UTC

*** This bug has been marked as a duplicate of bug 808827 ***