Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 808827 - dev-util/bazel-1.2.1 - ./.../zlib_client.h: error: numeric_limits is not a member of std (maybe gcc-11 related)
Summary: dev-util/bazel-1.2.1 - ./.../zlib_client.h: error: numeric_limits is not a me...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Zac Medico
URL:
Whiteboard:
Keywords:
: 808903 (view as bug list)
Depends on:
Blocks: gcc-11 boost-1.77
  Show dependency tree
 
Reported: 2021-08-18 07:13 UTC by Toralf Förster
Modified: 2021-10-09 16:35 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,18.24 KB, text/plain)
2021-08-18 07:13 UTC, Toralf Förster
Details
dev-util:bazel-1.2.1:20210818-014435.log (dev-util:bazel-1.2.1:20210818-014435.log,147.59 KB, text/plain)
2021-08-18 07:13 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,442.48 KB, text/plain)
2021-08-18 07:13 UTC, Toralf Förster
Details
environment (environment,116.86 KB, text/plain)
2021-08-18 07:13 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,31.04 KB, application/x-bzip)
2021-08-18 07:13 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,11.26 KB, application/x-bzip)
2021-08-18 07:13 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-08-18 07:13:31 UTC
    Compiling third_party/zlib/gzwrite.c; 0s local
In file included from third_party/ijar/zlib_client.cc:20:
./third_party/ijar/zlib_client.h:64:46: error: 'numeric_limits' is not a member of 'std'
   64 |   static const size_t MAX_BUFFER_SIZE = std::numeric_limits<int32_t>::max();
      |                                              ^~~~~~~~~~~~~~
./third_party/ijar/zlib_client.h:64:68: error: expected primary-expression before '>' token
   64 |   static const size_t MAX_BUFFER_SIZE = std::numeric_limits<int32_t>::max();

  -------------------------------------------------------------------

  This is an stable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_gnome_systemd-j3_stable-20210811-165947

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-11.2.0 *
clang version 12.0.1
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/12/bin
/usr/lib/llvm/12
12.0.1
Python 3.9.6
Available Ruby profiles:
  [1]   ruby26 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.53.0
  [2]   rust-1.53.0 *
The following VMs are available for generation-2:
1)	JamVM JDK 2.0.0 [jamvm]
*)	AdoptOpenJDK 8.292_p10 [openjdk-bin-8]
3)	AdoptOpenJDK JRE 8.292_p10 [openjdk-jre-bin-8]
Available Java Virtual Machines:
  [1]   jamvm 
  [2]   openjdk-bin-8  system-vm
  [3]   openjdk-jre-bin-8 


  HEAD of ::gentoo
commit 93880c86f41f6707fb6626b6b17e99215b06cf09
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Wed Aug 18 00:08:10 2021 +0000

    2021-08-18 00:08:08 UTC

emerge -qpvO dev-util/bazel
[ebuild  N    ] dev-util/bazel-1.2.1  USE="-examples -tools"
Comment 1 Toralf Förster gentoo-dev 2021-08-18 07:13:32 UTC
Created attachment 733689 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-08-18 07:13:34 UTC
Created attachment 733691 [details]
dev-util:bazel-1.2.1:20210818-014435.log
Comment 3 Toralf Förster gentoo-dev 2021-08-18 07:13:36 UTC
Created attachment 733693 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2021-08-18 07:13:37 UTC
Created attachment 733695 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2021-08-18 07:13:38 UTC
Created attachment 733697 [details]
etc.portage.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-08-18 07:13:40 UTC
Created attachment 733699 [details]
logs.tar.bz2
Comment 7 Jakov Smolić gentoo-dev 2021-08-29 14:27:12 UTC
*** Bug 808903 has been marked as a duplicate of this bug. ***
Comment 8 Sam James archtester gentoo-dev Security 2021-09-18 09:18:10 UTC
ping
Comment 9 Larry the Git Cow gentoo-dev 2021-09-19 01:38:49 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4ee781d18fd2bbba3e78c70229f7aacd7d6c5a13

commit 4ee781d18fd2bbba3e78c70229f7aacd7d6c5a13
Author:     Kerin Millar <kfm@plushkava.net>
AuthorDate: 2021-09-14 03:48:51 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-09-19 01:38:16 +0000

    dev-util/bazel: >=glibc-2.30 and gcc:11 compatibility fixes
    
    Ensure that versions 0.22.0, 0.24.1 and 0.27.2 are also patched so as not to
    conflict with glibc's gettid(2) function. Have all versions include the
    <limits> header, where required, for compatibility with gcc:11. Revise the
    dubious test for the presence of ccache so as to consider the value of
    FEATURES instead. Drop version 2.0.0 in favour of 2.0.1.
    
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=720032
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=787248
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=808827
    Signed-off-by: Kerin Millar <kfm@plushkava.net>
    Signed-off-by: Sam James <sam@gentoo.org>

 dev-util/bazel/Manifest                            |   5 +-
 dev-util/bazel/bazel-0.22.0.ebuild                 |   8 +-
 dev-util/bazel/bazel-0.24.1.ebuild                 |   8 +-
 dev-util/bazel/bazel-0.27.2.ebuild                 |   6 +-
 dev-util/bazel/bazel-0.29.1.ebuild                 |  15 ++-
 dev-util/bazel/bazel-1.0.1.ebuild                  |   8 +-
 dev-util/bazel/bazel-1.2.0-r1.ebuild               | 114 -------------------
 dev-util/bazel/bazel-1.2.1.ebuild                  |  13 +--
 dev-util/bazel/bazel-2.0.0.ebuild                  | 109 ------------------
 .../{bazel-1.2.0.ebuild => bazel-2.0.1.ebuild}     |   7 +-
 dev-util/bazel/bazel-3.2.0.ebuild                  |   5 +-
 dev-util/bazel/bazel-3.7.2.ebuild                  |   5 +-
 .../bazel-0.22.0-include-limits-for-gcc-11.patch   | 125 +++++++++++++++++++++
 .../bazel-0.22.0-rename-gettid-functions.patch     |  44 ++++++++
 .../bazel-0.24.1-rename-gettid-functions.patch     |  66 +++++++++++
 .../bazel-3.2.0-include-limits-for-gcc-11.patch    |  25 +++++
 16 files changed, 310 insertions(+), 253 deletions(-)