Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 80202 - GnomeMeeting fails to compile if OpenH323 compiled with novideo USE-flag
Summary: GnomeMeeting fails to compile if OpenH323 compiled with novideo USE-flag
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Stefan Knoblich (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-31 05:50 UTC by Jean-Charles Salzeber
Modified: 2006-07-23 08:28 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Charles Salzeber 2005-01-31 05:50:56 UTC
Hi,

(First, I'm a new Gentoo user, and this is my first bug report there, so please don't flame me if I've done something wrong.)
Emerging gnomemeeting will fail to compile, when someone try to compile it with a version of OpenH323 that doesn't support video.

Reproducible: Always
Steps to Reproduce:
1. Add the 'novideo' flag globally or in package.use
2. emerge openh323 (well, optionnal since it's a dependency of gnomemetting anyway)
3. emerge gnomemeeting

Actual Results:  
In file included from gnomemeeting.h:43,
                 from callbacks.cpp:44:
endpoint.h:240: error: `H323VideoCodec' has not been declared
endpoint.h:240: error: ISO C++ forbids declaration of `parameter' with no type
make[2]: *** [callbacks.o] Error 1
make[2]: Leaving directory
`/var/tmp/portage/gnomemeeting-1.2.0/work/gnomemeeting-1.2.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
`/var/tmp/portage/gnomemeeting-1.2.0/work/gnomemeeting-1.2.0'
make: *** [all] Error 2


Expected Results:  
Well, the ebuild may give a warning/error before actually trying to compile.
There seems to be no way to compile gnomemeeting without video support at this
time, but it would be better.

Portage 2.0.51-r15 (default-linux/x86/2004.3, gcc-3.4.3,
glibc-2.3.4.20041102-r0, 2.6.10-nitro4 i586)
=================================================================
System uname: 2.6.10-nitro4 i586 AMD-K6tm w/ multimedia extensions
Gentoo Base System version 1.6.8
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Jan 11 2005, 19:27:44)]
distcc 2.18.3 i586-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.7.9-r1, 1.8.5-r3, 1.6.3, 1.9.4, 1.5
sys-devel/binutils:  2.15.92.0.2-r2
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=k6 -mtune=k6 -mmmx -mpreferred-stack-boundary=2
-fomit-frame-pointer -ftracer -fweb -pipe"
CHOST="i586-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=k6 -mtune=k6 -mmmx -mpreferred-stack-boundary=2
-fomit-frame-pointer -ftracer -fweb -pipe -fvisibility-inlines-hidden"
DISTDIR="/var/cache/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks notitles sandbox sfperms
userpriv usersandbox"
GENTOO_MIRRORS="http://mir.zyrianes.net/gentoo/
http://mirror.datapipe.net/gentoo http://pandemonium.tiscali.de/pub/gentoo/
http://mirrors.acm.cs.rpi.edu/gentoo/"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -s"
MAKEOPTS=""
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/state/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.fr.gentoo.org/gentoo-portage"
USE="x86 X aalib alsa apm berkdb bitmap-fonts cdr crypt cups dga dio doc encode
f77 fbcon font-server foomaticdb gdbm gif gpm gtk gtk2 iconv imagemagick imlib
jpeg libg++ libwww mad maildir mmx motif mpeg ncurses nls nptl nptlonly
offensive oggvorbis opengl pam pdflib perl png python qt quicktime readline real
samba scanner spell ssl tcpd tetex tiff truetype truetype-fonts type1-fonts
unicode usb xml2 xmms xv zlib video_cards_mach64 linguas_fr linguas_eo linguas_en"
Unset:  ASFLAGS, CBUILD, CTARGET, LC_ALL
Comment 1 John N. Laliberte (RETIRED) gentoo-dev 2005-06-24 04:50:20 UTC
reassigning to maintainer
Comment 2 Gilles Dartiguelongue gentoo-dev 2006-06-05 00:43:28 UTC
I think this is fixed by now or maybe look at my comment here : https://bugs.gentoo.org/show_bug.cgi?id=73314
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-07-23 08:28:03 UTC
Deprecated and package.masked for removal.

# Stefan Schweizer <genstef@gentoo.org> (18 Jul 2006)
# Masked for removal, please use ekiga now, #136615
net-im/gnomemeeting