Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 73314 - gnomemeeting 1.0.2 prints error "Failed to load avcodec_set_print_fn" and dies soon after.
Summary: gnomemeeting 1.0.2 prints error "Failed to load avcodec_set_print_fn" and die...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Stefan Knoblich (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-04 02:19 UTC by Ivan Yosifov
Modified: 2006-07-23 08:28 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Apply this to openh323-1.13.5.ebuild to get rid of "Failed to load avcodec_set_print_fn" (openh323-1.13.5.ebuild.diff,111 bytes, patch)
2004-12-11 06:55 UTC, Ivan Yosifov
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Yosifov 2004-12-04 02:19:14 UTC
I am (trying to) using gnomemeeting 1.0.2. When I run it:

obelix@localhost ~ $ gnomemeeting
Failed to load avcodec_set_print_fn
/usr/share/themes/Nuvola/gtk-2.0/iconrc:23: Unable to locate image file in pixmap_path: "stock_stock.svg"
/usr/share/themes/Nuvola/gtk-2.0/iconrc:54: Unable to locate image file in pixmap_path: "stock_ok.svg"
Xlib: unexpected async reply (sequence 0x355)!
/usr/share/themes/Nuvola/gtk-2.0/iconrc:23: Unable to locate image file in pixmap_path: "stock_stock.svg"
/usr/share/themes/Nuvola/gtk-2.0/iconrc:54: Unable to locate image file in pixmap_path: "stock_ok.svg"

Right after the last message I get a "The Application "gnomemeeting" has quit unexpectedly" box.I suspect that the real problem has to do with the first message "Failed to load avcodec_set_print_fn" ,not with the icon stuff.

Reproducible: Always
Steps to Reproduce:
1.emerge gnomemeeting 1.0.2
2.run it in a shell
3.watch it die

Actual Results:  
obelix@localhost ~ $ gnomemeeting
Failed to load avcodec_set_print_fn
/usr/share/themes/Nuvola/gtk-2.0/iconrc:23: Unable to locate image file in
pixmap_path: "stock_stock.svg"
/usr/share/themes/Nuvola/gtk-2.0/iconrc:54: Unable to locate image file in
pixmap_path: "stock_ok.svg"
Xlib: unexpected async reply (sequence 0x355)!
/usr/share/themes/Nuvola/gtk-2.0/iconrc:23: Unable to locate image file in
pixmap_path: "stock_stock.svg"
/usr/share/themes/Nuvola/gtk-2.0/iconrc:54: Unable to locate image file in
pixmap_path: "stock_ok.svg"

<CRASH>

Expected Results:  
A working gnomemeeting install

Portage 2.0.51-r3 (default-linux/x86/2004.2, gcc-3.4.3, glibc-2.3.4.20040808-r1,
2.6.9-gentoo-r9 i686)
=================================================================
System uname: 2.6.9-gentoo-r9 i686 Intel(R) Pentium(R) 4 CPU 3.20GHz
Gentoo Base System version 1.4.16
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake:
sys-devel/automake-1.8.5-r2,sys-devel/automake-1.5,sys-devel/automake-1.4_p6,sys-devel/automake-1.6.3,sys-devel/automake-1.7.9,sys-devel/automake-1.9.3
Binutils: sys-devel/binutils-2.15.92.0.2-r2,sys-devel/binutils-2.14.90.0.8-r1
Headers:  sys-kernel/linux26-headers-2.6.8.1-r1
Libtools: sys-devel/libtool-1.5.2-r7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=pentium4 -fomit-frame-pointer -pipe -fprefetch-loop-arrays
-fforce-addr -falign-functions=4"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium4 -fomit-frame-pointer -pipe -fprefetch-loop-arrays
-fforce-addr -falign-functions=4"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms test"
GENTOO_MIRRORS="http://gentoo.ITDNet.net/gentoo"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aalib alsa arts avi berkdb bitmap-fonts cdr crypt cups dba doc encode esd
f77 fam flac foomaticdb fortran gd gdbm gif gnome gpm gstreamer gtk gtk2 guile
imagemagick imlib jack java jpeg junit kde ldap libg++ libwww mad mikmod mmap
motif mozilla mpeg ncurses nls nptl oggvorbis opengl pam pdflib perl png
postgres python qt quicktime readline sdl slang spell ssl svga tcltk tcpd tetex
tiff truetype unicode usb x86 xml xml2 xmms xv zlib"
Comment 1 Ivan Yosifov 2004-12-04 02:22:19 UTC
Check out comment 17 of http://bugs.gentoo.org/show_bug.cgi?id=46877 . I think it has to do with the current issue.

Ivan Yosifov.
Comment 2 Ivan Yosifov 2004-12-04 04:15:47 UTC
As explained in the referanced comment I removed the openh323-1.13.5-ffmpeg.diff patch from the openh323 ebuild (I am using openh323-1.13.5). This solved the "Failed to load avcodec_set_print_fn" , however gnomemeeting still crashes right after the last icon warning.

Ivan Yosifov.
Comment 3 Ivan Yosifov 2004-12-04 04:33:21 UTC
Ok , this one is wierd.
Even though I have the "The Application "gnomemeeting" has quit unexpectedly" box right in the center of my screen , gnomemeeting appears to be still running. I mean I can move away the i-am-dead box and click on the menues , open the config dialog , edit my config. I can not currently test if conferencing actually works.
Any suggestions ?

Ivan Yosifov.
Comment 4 Dead Schorsch 2004-12-06 03:45:23 UTC
It doesn't do at my side, after the application crashed dialogue has appeared, clicking on the window's close icon or the dialogue's close button makes gnomemeeting disappear from screen and memory with no further error message. Only output when starting from console is:

Failed to load avcodec_set_print_fn

(gnome_segv:32253): Gtk-WARNING **: Theme directory 48x48/mimetypes of theme Snow-Apple has no size field

UPDATE: While writing this report, I re-emerged openh323 and gnomemeeting, because there have been recent updates of pwlib (mentioned in bug 46877) and glibc. And now - it work's again. Simple re-emerging gnomemeeting didn't work, openh323 did it.

Christoph
Comment 5 Ivan Yosifov 2004-12-07 01:10:16 UTC
I re-emerged openh323(1.13.5),pwlib(1.6.6-r1),gnomemeeting(1.0.2) and this time it is:

obelix@localhost ~ $ gnomemeeting
Failed to load avcodec_set_print_fn
Xlib: unexpected async reply (sequence 0xac)!
<CRASH BOX>

This time it is dead in background.

What are your versions of openh323,pwlib,gnomemeeting,glibc ?

Ivan Yosifov.
Comment 6 crusaderky 2004-12-07 16:45:48 UTC
I've got "Failed to load avcodec_set_print_fn", too, but gnomemeeting works perfectly for me, so it looks like it's completely unrelated.
Comment 7 Ivan Yosifov 2004-12-08 00:21:45 UTC
Hello CRV
Comment 8 Ivan Yosifov 2004-12-08 00:21:45 UTC
Hello CRV§ADER//KY , Christoph Dahlen ,

What versions of openh323,pwlib,gnomemeeting,glibc,<anything else you feel is relevant> and what platform (x86,amd64...) are you using ?

Ivan Yosifov.
Comment 9 Mark R. Pariente 2004-12-10 22:51:42 UTC
Hello,

Got all the same problems (Failed to load avcodec_set_print_fn crash first and Xlib: unexpected async reply after a openh323 recompile).

Was using gcc 3.4.3 in all this. Compiling gnomemeeting (only) with gcc 3.3 fixed the problems, gnomemeeting works now.
Comment 10 Ivan Yosifov 2004-12-11 06:53:33 UTC
I rebuilt gnomemeeting with gcc 3.3.4. The crash is no more , however I am still getting "Failed to load avcodec_set_print_fn".
Comment 11 Ivan Yosifov 2004-12-11 06:55:08 UTC
Created attachment 45739 [details, diff]
Apply this to openh323-1.13.5.ebuild to get rid of "Failed to load avcodec_set_print_fn"

Explained in http://bugs.gentoo.org/show_bug.cgi?id=46877#c17
Comment 12 Ivan Yosifov 2004-12-11 07:02:02 UTC
It is my understanding that the problematic openh323-ffmpeg patch was added for http://bugs.gentoo.org/show_bug.cgi?id=32754 . If the attached diff makes in into portage , 32754 should be reopened and fixed correctly this time.

Ivan Yosifov.
Comment 13 John N. Laliberte (RETIRED) gentoo-dev 2005-06-24 04:49:02 UTC
reassigning to maintainer
Comment 14 Gilles Dartiguelongue gentoo-dev 2006-06-05 00:41:55 UTC
maybe this bug could be closed as ekiga is out and much superior to gnomemeeting. Moreover openh323 is now at version 1.15.6 in portage tree, so maybe this is really fixed now.
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2006-07-23 08:28:03 UTC
Deprecated and package.masked for removal.

# Stefan Schweizer <genstef@gentoo.org> (18 Jul 2006)
# Masked for removal, please use ekiga now, #136615
net-im/gnomemeeting