Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 788157 - x11-misc/xplanet-1.3.1-r2 calls ar directly
Summary: x11-misc/xplanet-1.3.1-r2 calls ar directly
Status: RESOLVED DUPLICATE of bug 726292
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2021-05-04 15:01 UTC by Agostino Sarubbo
Modified: 2021-05-04 15:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,40.88 KB, text/plain)
2021-05-04 15:01 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2021-05-04 15:01:34 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: x11-misc/xplanet-1.3.1-r2 calls ar directly.
Discovered on: amd64 (internal ref: ci)

NOTE:
This machine uses GCC-11: https://gcc.gnu.org/gcc-11/porting_to.html
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different AR implementation (like llvm-ar). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks].
Comment 1 Agostino Sarubbo gentoo-dev 2021-05-04 15:01:37 UTC
Created attachment 705984 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2021-05-04 15:01:39 UTC
Possible context of error(s):

make[3]: ar: No such file or directory
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2021-05-04 15:02:31 UTC

*** This bug has been marked as a duplicate of bug 726292 ***