Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 726292 - x11-misc/xplanet calls ar directly
Summary: x11-misc/xplanet calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: PullRequest
: 788157 (view as bug list)
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-30 11:26 UTC by Agostino Sarubbo
Modified: 2021-05-04 15:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,13.15 KB, text/plain)
2020-05-30 11:26 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-30 11:26:36 UTC
This is an auto-filed bug because x11-misc/xplanet calls ar directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to x86_64-pc-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-30 11:26:41 UTC
Created attachment 642760 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2021-05-04 14:55:53 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2e19c9194cfa6ed199bc31345f8ea65ae166f1b4

commit 2e19c9194cfa6ed199bc31345f8ea65ae166f1b4
Author:     Matt Smith <matt@offtopica.uk>
AuthorDate: 2021-05-04 14:19:25 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2021-05-04 14:55:38 +0000

    x11-misc/xplanet: Don't call AR directly
    
    Closes: https://bugs.gentoo.org/726292
    Package-Manager: Portage-3.0.18, Repoman-3.0.3
    Signed-off-by: Matt Smith <matt@offtopica.uk>
    Closes: https://github.com/gentoo/gentoo/pull/20680
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>

 x11-misc/xplanet/xplanet-1.3.1-r2.ebuild | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2021-05-04 15:02:31 UTC
*** Bug 788157 has been marked as a duplicate of this bug. ***