Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 787875 - net-libs/srt-1.4.2 fails to compile with gcc-11
Summary: net-libs/srt-1.4.2 fails to compile with gcc-11
Status: RESOLVED DUPLICATE of bug 787023
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Luca Barbato
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-05-03 10:08 UTC by Agostino Sarubbo
Modified: 2021-05-03 10:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,165.08 KB, text/plain)
2021-05-03 10:08 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2021-05-03 10:08:28 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: net-libs/srt-1.4.2 fails to compile with gcc-11.
Discovered on: amd64 (internal ref: ci)

NOTE:
This machine uses GCC-11: https://gcc.gnu.org/gcc-11/porting_to.html
Comment 1 Agostino Sarubbo gentoo-dev 2021-05-03 10:08:31 UTC
Created attachment 705684 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2021-05-03 10:08:33 UTC
Possible context of error(s):

/var/tmp/portage/net-libs/srt-1.4.2/work/srt-1.4.2/srtcore/sync.h:182:68: error: ‘numeric_limits’ was not declared in this scope
Comment 3 Sam James archtester gentoo-dev Security 2021-05-03 10:14:07 UTC

*** This bug has been marked as a duplicate of bug 787023 ***