Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 787023 - net-libs/srt-1.4.2: error: ‘::min’ has not been declared; did you mean ‘std::min’? (gcc 11)
Summary: net-libs/srt-1.4.2: error: ‘::min’ has not been declared; did you mean ‘std::...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Luca Barbato
URL:
Whiteboard:
Keywords: PATCH
: 787875 787908 (view as bug list)
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-04-30 03:32 UTC by Petronio Coelho
Modified: 2021-05-05 08:55 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,75.06 KB, text/plain)
2021-04-30 03:33 UTC, Petronio Coelho
Details
patch for gcc 11 compile from upstream (bug1806.patch,189 bytes, patch)
2021-05-01 18:09 UTC, Benjamin Réveillé
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Petronio Coelho 2021-04-30 03:32:43 UTC
net-libs/srt-1.4.2 fails to build with gcc-11.1.0 . Bumping to 1.4.3 resolves the issue.

Reproducible: Always
Comment 1 Petronio Coelho 2021-04-30 03:33:06 UTC
emerge --info
Portage 3.0.18 (python 3.9.4-final-0, default/linux/amd64/17.1/desktop/gnome/systemd, gcc-11.1.0, glibc-2.33, 5.12.0-gentoo x86_64)
=================================================================
System uname: Linux-5.12.0-gentoo-x86_64-Intel-R-_Core-TM-_i7-7700HQ_CPU_@_2.80GHz-with-glibc2.33
KiB Mem:    32720504 total,  22750192 free
KiB Swap:   16359420 total,  16359420 free
Timestamp of repository gentoo: Fri, 30 Apr 2021 02:07:15 +0000
Head commit of repository gentoo: f738abe7d5cce96e97a99956ef2b459312460b33

sh bash 5.1_p4
ld GNU ld (Gentoo 2.36.1 p3) 2.36.1
app-shells/bash:          5.1_p4::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.32.1::gentoo
dev-lang/python:          3.8.9::gentoo, 3.9.4::gentoo
dev-lang/rust:            1.51.0-r2::gentoo
dev-util/cmake:           3.20.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7-r2::gentoo
sys-apps/sandbox:         2.23::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.3-r1::gentoo
sys-devel/binutils:       2.36.1-r1::gentoo
sys-devel/gcc:            11.1.0::gentoo
sys-devel/gcc-config:     2.4::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.12::gentoo (virtual/os-headers)
sys-libs/glibc:           2.33::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gentoo.git
    priority: -1000
    sync-git-verify-commit-signature: true

localrepo
    location: /usr/local/portage
    masters: gentoo

calculate
    location: /var/lib/layman/calculate
    masters: gentoo
    priority: 50

jorgicio
    location: /var/lib/layman/jorgicio
    masters: gentoo
    priority: 50

laurentb
    location: /var/lib/layman/laurentb
    masters: gentoo
    priority: 50

lto-overlay
    location: /var/lib/layman/lto-overlay
    masters: gentoo mv
    priority: 50

mv
    location: /var/lib/layman/mv
    masters: gentoo
    priority: 50

pentoo
    location: /var/lib/layman/pentoo
    masters: gentoo
    priority: 50

sakaki-tools
    location: /var/lib/layman/sakaki-tools
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -flto=8 -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -flto=8 -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs 9 --load-average 8 --with-bdeps=y"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -flto=8 -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline"
FEATURES="assume-digests binpkg-dostrip binpkg-logs binpkg-multi-instance buildpkg cgroup clean-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync mount-sandbox multilib-strict network-sandbox news parallel-fetch parallel-install pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms split-elog split-log strict strict-keepdir unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -flto=8 -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--sort-common -Wl,--hash-style=gnu -march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -flto=8 -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline"
LINGUAS="en"
MAKEOPTS="-j9 -l8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aacs acl acpi alsa amd64 amr aom audit avif bcrypt bdplus berkdb blake2 bluetooth bluray branding brotli btrfs bzip2 cairo caps cdda cdr cli colord corefonts crypt cups curl custom-cflags daap dbus djvu dri dts dvb dvd dvdr dvi ed25519 emboss encode evo exif faad fam fdk ffmpeg filecaps firewalld flac fontconfig fontforge fortran fpx fuse gdbm gif gme gmp gnome gnome-keyring gnome-online-accounts gpm graphviz gsf gsm gstreamer gtk gtk3 gui hdri heif iconv icu idn inotify introspection iproute2 iptc ipv6 jbig jit jpeg jpeg2k lcms lensfun libaom libass libdrm libglvnd libidn2 libnotify libsecret libtirpc libva live lm_sensors lto lz4 lzma lzo mad matroska mms mng modplug mp3 mp4 mpeg mtp multilib musepack nautilus ncurses networkmanager nftables nls nptl oauth ogg openexr opengl openh264 openmp openssl opus orc pam pango pcre pdf pgo plymouth png policykit postscript ppds pulseaudio qt5 raw readline samba sctp sdl seccomp sftp sha3 shout smp speex spell split-usr srt ssl startup-notification svg sysprof system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-llvm system-zlib systemd t1lib taglib tcpd theora threads tiff tracker truetype udev udisks unicode unwind upnp upnp-av upower usb v4l vaapi vorbis vpx wavpack wayland webp wmf x264 x265 xattr xcb xcrypt xml xmp xpm xps xv xvid xxhash xz zeroconf zlib zsh-completion zstd zvbi" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt rdrand sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" L10N="en en-US" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="BPF WebAssembly" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_10 python3_9" PYTHON_TARGETS="python3_8 python3_10 python3_9" RUBY_TARGETS="ruby26 ruby27 ruby30" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RUSTFLAGS
Comment 2 Petronio Coelho 2021-04-30 03:33:46 UTC
Created attachment 704130 [details]
build.log
Comment 3 Nikolaos Chatzidakis 2021-04-30 18:33:14 UTC
Same issue here, but not only for net-libs/srt, but for qt-creator and libfilezilla as well.
Comment 4 Sam James archtester gentoo-dev Security 2021-04-30 23:31:43 UTC
(In reply to Nikolaos Chatzidakis from comment #3)
> Same issue here, but not only for net-libs/srt, but for qt-creator and
> libfilezilla as well.

Please file bugs for each where they don’t already exist.
Comment 5 Benjamin Réveillé 2021-05-01 18:09:31 UTC
Created attachment 705003 [details, diff]
patch for gcc 11 compile from upstream

Taken from https://github.com/Haivision/srt/commit/f1b35cbf5b9b42b031e9b119e4c802b5f744468c
Comment 6 Sam James archtester gentoo-dev Security 2021-05-03 10:14:07 UTC
*** Bug 787875 has been marked as a duplicate of this bug. ***
Comment 7 Bernd Feige 2021-05-04 06:12:20 UTC
(In reply to Benjamin Réveillé from comment #5)
> Created attachment 705003 [details, diff] [details, diff]
> patch for gcc 11 compile from upstream

That fixes it, thanks!
Comment 8 Sam James archtester gentoo-dev Security 2021-05-04 22:47:14 UTC
*** Bug 787908 has been marked as a duplicate of this bug. ***
Comment 9 Larry the Git Cow gentoo-dev 2021-05-04 22:49:26 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=332813b29e4350f990a51934bc7a975794ef4fda

commit 332813b29e4350f990a51934bc7a975794ef4fda
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-05-04 22:49:11 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-05-04 22:49:11 +0000

    net-libs/srt: fix build with GCC 11
    
    Closes: https://bugs.gentoo.org/787023
    Signed-off-by: Sam James <sam@gentoo.org>

 net-libs/srt/files/srt-1.4.2-cxx-include-gcc11.patch | 19 +++++++++++++++++++
 net-libs/srt/srt-1.4.2.ebuild                        |  1 +
 2 files changed, 20 insertions(+)