Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 776859 - sys-fs/lde-2.6.1-r1 does not respect CFLAGS
Summary: sys-fs/lde-2.6.1-r1 does not respect CFLAGS
Status: RESOLVED DUPLICATE of bug 776862
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: cflags
  Show dependency tree
 
Reported: 2021-03-17 07:58 UTC by Agostino Sarubbo
Modified: 2021-04-29 17:44 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,6.65 KB, text/plain)
2021-03-17 07:58 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2021-03-17 07:58:02 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: sys-fs/lde-2.6.1-r1 does not respect CFLAGS.
Discovered on: amd64 (internal ref: tinderbox)

NOTE:
To reproduce this issue you may want to add "-frecord-gcc-switches" to CFLAGS/CXXFLAGS/FFLAGS/FCFLAGS. If this is not something about c/c++ context see this bug as an hint to hide the QA warning (with QA_FLAGS_IGNORED) where is not possible to respect CFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2021-03-17 07:58:04 UTC
Created attachment 691992 [details]
build.log

build log and emerge --info
Comment 2 Jakov Smolic 2021-04-29 17:34:36 UTC
> configure: error: cannot find required auxiliary files: ar-lib install-sh
Something else went wrong here. Other than that, unable to reproduce this
Comment 3 Sam James archtester gentoo-dev Security 2021-04-29 17:35:54 UTC
(In reply to Jakov Smolic from comment #2)
> > configure: error: cannot find required auxiliary files: ar-lib install-sh
> Something else went wrong here. Other than that, unable to reproduce this

autoconf 2.7x probably
Comment 4 Jakov Smolic 2021-04-29 17:44:32 UTC
(In reply to Sam James from comment #3)
> (In reply to Jakov Smolic from comment #2)
> > > configure: error: cannot find required auxiliary files: ar-lib install-sh
> > Something else went wrong here. Other than that, unable to reproduce this
> 
> autoconf 2.7x probably

Yeah, looks like it

*** This bug has been marked as a duplicate of bug 776862 ***