Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 775596 - dev-libs/libltdl-2.4.6 ltdl.c:(.text+0xdbb): undefined reference to `lt_libltdl_LTX_preloaded_symbols' when using slibtool
Summary: dev-libs/libltdl-2.4.6 ltdl.c:(.text+0xdbb): undefined reference to `lt_liblt...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: 842426 (view as bug list)
Depends on:
Blocks: slibtool
  Show dependency tree
 
Reported: 2021-03-12 10:02 UTC by Alessandro Barbieri
Modified: 2022-05-03 13:00 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
libltdl-2.4.6:20210312-100052.log (libltdl-2.4.6:20210312-100052.log,28.13 KB, text/plain)
2021-03-12 10:03 UTC, Alessandro Barbieri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro Barbieri 2021-03-12 10:02:46 UTC
slibtool: link: ar crs .libs/dlopen.a loaders/.libs/dlopen.o
slibtool: link: ln -s ../dlopen.la .libs/dlopen.la                                                       
slibtool: link: ln -s ../dlopen.la .libs/dlopen.lai
slibtool: compile: x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/tmp/portage/dev-libs/libltdl-2.4.6/work/libtool-2.4.6/libltdl -DLTDLOPEN=libltdl -DLT_CONFIG_H=<config.h> -DLTDL -I. -I/var/tmp/portage/dev-l
ibs/libltdl-2.4.6/work/libtool-2.4.6/libltdl -Ilibltdl -I/var/tmp/portage/dev-libs/libltdl-2.4.6/work/libtool-2.4.6/libltdl/libltdl -Os -pipe -march=native -Os -pipe -march=native -Wimplicit-function-declaration
 -Wno-error=implicit-function-declaration -c /var/tmp/portage/dev-libs/libltdl-2.4.6/work/libtool-2.4.6/libltdl/ltdl.c -o libltdl_la-ltdl.o
slibtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc  -Os -pipe -march=native -Os -pipe -march=native -Wimplicit-function-declaration -Wno-error=implicit-function-declaration -no-undefined -version-info 10:1
:3 -dlpreopen dlopen.la  -Wl,-O1 -Wl,--as-needed -o libltdl.la -rpath /usr/lib64 loaders/libltdl_la-preopen.lo libltdl_la-lt__alloc.lo libltdl_la-lt_dlloader.lo libltdl_la-lt_error.lo libltdl_la-ltdl.lo libltdl_
la-slist.lo lt__strl.lo 
slibtool: link: ar crs .libs/libltdl.a loaders/.libs/libltdl_la-preopen.o .libs/libltdl_la-lt__alloc.o .libs/libltdl_la-lt_dlloader.o .libs/libltdl_la-lt_error.o .libs/libltdl_la-ltdl.o .libs/libltdl_la-slist.o 
.libs/lt__strl.o
slibtool: link: x86_64-pc-linux-gnu-gcc -Wl,--whole-archive .libs/dlopen.a -Wl,--no-whole-archive loaders/.libs/libltdl_la-preopen.o .libs/libltdl_la-lt__alloc.o .libs/libltdl_la-lt_dlloader.o .libs/libltdl_la-l
t_error.o .libs/libltdl_la-ltdl.o .libs/libltdl_la-slist.o .libs/lt__strl.o -Os -pipe -march=native -Os -pipe -march=native -Wimplicit-function-declaration -Wno-error=implicit-function-declaration -L.libs -ldl -
Wl,-O1 -Wl,--as-needed -shared -fPIC -Wl,--no-undefined -Wl,-soname -Wl,libltdl.so.7 -o .libs/libltdl.so.7.3.1
/usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: .libs/libltdl_la-ltdl.o: in function `lt_dlinit':
ltdl.c:(.text+0xdbb): undefined reference to `lt_libltdl_LTX_preloaded_symbols'
collect2: error: ld returned 1 exit status
slibtool: exec error upon slbt_exec_link_create_library(), line 1446: (see child process error messages). 
slibtool: < returned to > slbt_exec_link(), line 1836.
make[1]: *** [Makefile:627: libltdl.la] Error 2
make[1]: Leaving directory '/var/tmp/portage/dev-libs/libltdl-2.4.6/work/libtool-2.4.6/libltdl-abi_x86_64.amd64'
make: *** [Makefile:504: all] Error 2
 * ERROR: dev-libs/libltdl-2.4.6::gentoo failed (compile phase):
 *   emake failed
Comment 1 Alessandro Barbieri 2021-03-12 10:03:14 UTC
Created attachment 690951 [details]
libltdl-2.4.6:20210312-100052.log

buildlog
Comment 2 orbea 2021-03-17 14:18:28 UTC
I don't have a fix for this yet, but similar to slibtool there is sltdl which could eventually replace libltdl.

https://dev.midipix.org/cross/sltdl

Unfortunately this can't be tested as easily with an environment variable like slibtool.
Comment 3 orbea 2021-03-23 02:53:54 UTC
This upstream slibtool issue is relevant.

https://dev.midipix.org/cross/slibtool/issue/2
Comment 4 orbea 2021-03-24 00:54:31 UTC
This fails because -dlpreopen is a no-op in slibtool and seems to be really needed here.

Do any other packages fail with this error? The other two I know about, bind and pulseaudio no longer seem to use it upstream.
Comment 5 Toralf Förster gentoo-dev 2022-05-03 13:00:59 UTC
*** Bug 842426 has been marked as a duplicate of this bug. ***