Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 767796 - media-video/vlc-3.0.12.1-r100 w/ gcc-11: .../SegmentInformation.cpp:397:23: error: ‘numeric_limits’ is not a member of ‘std’
Summary: media-video/vlc-3.0.12.1-r100 w/ gcc-11: .../SegmentInformation.cpp:397:23: e...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 760114 768405 (view as bug list)
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-01-29 02:42 UTC by Geoff Leach
Modified: 2021-04-23 08:09 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (log-emerge-vlc.2,972.09 KB, text/plain)
2021-01-29 02:42 UTC, Geoff Leach
Details
patch to #include <limits> in several files (vlc-limits.patch,768 bytes, patch)
2021-01-29 02:43 UTC, Geoff Leach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Geoff Leach 2021-01-29 02:42:44 UTC
Created attachment 684999 [details]
build log

Same issue as in bug 760114, two files need 

#include <limits> 

same patch attached here.



(gcc-11 ICE issue mentioned in bug 760114 now resolved)
Comment 1 Geoff Leach 2021-01-29 02:43:54 UTC
Created attachment 685002 [details, diff]
patch to #include <limits> in several files
Comment 2 Geoff Leach 2021-01-29 02:49:13 UTC
*** Bug 760114 has been marked as a duplicate of this bug. ***
Comment 3 Andreas Sturmlechner gentoo-dev 2021-02-02 11:08:46 UTC
Is this already reported upstream somewhere?
Comment 4 Ionen Wolkens 2021-02-02 22:24:58 UTC
*** Bug 768405 has been marked as a duplicate of this bug. ***
Comment 6 Larry the Git Cow gentoo-dev 2021-04-23 08:09:50 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8cbc565e4786eacec418155e7a1efe1e5a89ed22

commit 8cbc565e4786eacec418155e7a1efe1e5a89ed22
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2021-04-23 08:09:36 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2021-04-23 08:09:47 +0000

    media-video/vlc: tweak for gcc-11
    
    Reported-by: Geoff Leach
    Closes: https://bugs.gentoo.org/767796
    Package-Manager: Portage-3.0.18, Repoman-3.0.3
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 media-video/vlc/files/vlc-3.0.12.1-limits-p1.patch | 32 +++++++++++++++
 media-video/vlc/files/vlc-3.0.12.1-limits-p2.patch | 48 ++++++++++++++++++++++
 media-video/vlc/vlc-3.0.12.1-r100.ebuild           |  1 +
 3 files changed, 81 insertions(+)