Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 760114 - media-video/vlc-3.0.11.1 missing <limits> fails to build
Summary: media-video/vlc-3.0.11.1 missing <limits> fails to build
Status: RESOLVED DUPLICATE of bug 767796
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2020-12-16 07:14 UTC by Geoff Leach
Modified: 2021-01-29 02:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch to #include <limits> (vlc-limits.patch,768 bytes, patch)
2020-12-16 07:14 UTC, Geoff Leach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Geoff Leach 2020-12-16 07:14:16 UTC
Created attachment 678415 [details, diff]
patch to #include <limits>

Two files need 

#include <limits> 

otherwise with clang++-10 get e.g. 

demux/adaptive/playlist/SegmentInformation.cpp:397:23: error: no member named
      'numeric_limits' in namespace 'std'
    if(number == std::numeric_limits<uint64_t>::max())

Also (separate issue) with g++-11 I'm getting internal compiler errors, but don't have g++-10 installed to test patch with it

video_chroma/copy.c: In function ‘CopyFromUswc’:
video_chroma/copy.c:141:13: internal compiler error: Segmentation fault
  141 | static void CopyFromUswc(uint8_t *dst, size_t dst_pitch,
      |             ^~~~~~~~~~~~
Comment 1 Sam James archtester gentoo-dev Security 2020-12-16 07:15:42 UTC
re g++11, please file https://wiki.gentoo.org/wiki/Gcc-ICE-reporting-guide in a separate bug and we can speak to the toolchain folks.
Comment 2 Geoff Leach 2021-01-29 02:46:51 UTC
With the gcc-11 ICE resolved, same missing <limits> issue (naturally) then arises. I've opened bug 767769. This one can be closed (which I'll do if I can).
Comment 3 Geoff Leach 2021-01-29 02:47:43 UTC

*** This bug has been marked as a duplicate of bug 767769 ***
Comment 4 Geoff Leach 2021-01-29 02:49:12 UTC

*** This bug has been marked as a duplicate of bug 767796 ***
Comment 5 Geoff Leach 2021-01-29 02:50:21 UTC
(In reply to Geoff Leach from comment #3)
> 
> *** This bug has been marked as a duplicate of bug 767769 ***

sorry, wrong bug number, is dupe of 767796