Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 762823 - dev-libs/libverto misconfigures if /bin/sh -> /bin/dash
Summary: dev-libs/libverto misconfigures if /bin/sh -> /bin/dash
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Eray Aslan
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: nonbash
  Show dependency tree
 
Reported: 2020-12-31 18:29 UTC by Nick Bowler
Modified: 2021-01-07 14:20 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch to fix bashisms in configure.ac (libverto-0.3.1-configure-bashisms.patch,5.37 KB, patch)
2021-01-01 05:50 UTC, Nick Bowler
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Bowler 2020-12-31 18:29:29 UTC
It seems that after updating my systems, gssproxy is completely busted
on all of them.  It simply fails to start either from the init script or
manually, for example:

  # gssproxy -d -i
  [2020/12/31 17:53:34]: Debug Enabled (level: 1)
  [2020/12/31 17:53:34]: Service: nfs-client, Keytab: /etc/krb5.keytab, Enctype: 18
  [2020/12/31 17:53:34]: Service: nfs-server, Keytab: /etc/krb5.keytab, Enctype: 18
  Failed to initialize event loop. Is there at least one libverto backend installed?

There was no update to gssproxy package so I imagine something else
must have caused this.  Unfortunately I did not notice this problem until
after all machines had been updated and I literally no longer have any
computer with a functional gssproxy installation.

I see that libverto-0.3.1 was very recently stabilized and the failures
started after my systems updated to that (and the previous version promptly
deleted from the repositories making it annoyingly difficult to retest with
the prior version, ugh...).

However if I resurrect the previous stable libverto-0.2.5-r1 ebuild,
installing it does not correct this problem.  So I'm not (yet) sure what
update caused this breakage, only that my systems were all working on
the previous boot and now none of them are.  I'll keep looking...

Portage 3.0.9 (python 3.8.6-final-0, default/linux/amd64/17.1, gcc-9.3.0, glibc-2.32-r3, 5.10.1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.10.1-x86_64-Intel-R-_Core-TM-_i5-5200U_CPU_@_2.20GHz-with-glibc2.2.5
KiB Mem:     8059396 total,   2803776 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Thu, 31 Dec 2020 00:45:01 +0000
sh dash 0.5.11.2
ld GNU ld (Gentoo 2.33.1 p2) 2.33.1
ccache version 3.7.12 [enabled]
app-shells/bash:          5.0_p18::gentoo
dev-lang/perl:            5.30.3::gentoo
dev-lang/python:          2.7.18-r4::gentoo, 3.6.12::gentoo, 3.7.9::gentoo, 3.8.6::gentoo, 3.9.0::gentoo
dev-util/ccache:          3.7.12::gentoo
dev-util/cmake:           3.17.4-r1::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.20::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.13.4-r2::gentoo, 1.16.2-r1::gentoo
sys-devel/binutils:       2.33.1-r1::gentoo, 2.34-r2::gentoo
sys-devel/gcc:            9.3.0-r2::gentoo
sys-devel/gcc-config:     2.3.2-r1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.32-r3::gentoo
Repositories:

gentoo
    location: /srv/repos/gentoo
    sync-type: squashmirror
    sync-uri: /srv/gentoo
    sync-user: root
    priority: -1000
    squash-compression: xz
    squash-cache-location: /var/cache/portage
    squash-extra-opts: -e distfiles -e packages -e local

gentoo-draconx
    location: /srv/repos/gentoo-draconx
    sync-type: null
    sync-uri: null
    masters: gentoo

gentoo-fixes
    location: /srv/repos/gentoo-fixes
    sync-type: null
    sync-uri: null
    masters: gentoo

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE @OTHER-FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=broadwell -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=broadwell -pipe"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="-j3 --keep-going --dynamic-deps=n --autounmask --autounmask-write=n --unordered-display --verbose-conflicts --binpkg-respect-use=y --with-bdeps-auto=n"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -march=broadwell -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs binpkg-multi-instance ccache config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -march=broadwell -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
INSTALL_MASK="/usr/share/cursors/xorg-x11/default 	/usr/share/alsa/alsa.conf.d/*.conf /etc/alsa/conf.d/*.conf 	/etc/portage/*postsync.d 	/etc/gssproxy/??-*.conf 	/etc/profile.d/qtgui4.sh 	/etc/????.d/wpa_supplicant"
LANG="en_CA.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4 -l5"
PKGDIR="/var/cache/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X aacs acl alsa amd64 berkdb bluray bs2b bzip2 cairo cdda cjk cli crypt cups dav1d doc dri dts dv exif fbcon flac fontconfig fortran gdbm gpm gtk gtk-doc iconv icu idn ipv6 jpeg jpeg2k kerberos libglvnd libtirpc mp3 multilib ncurses nls nptl ogg opengl openmp opus pam pango pcre perl png python readline seccomp smp split-usr ssl svg tcpd theora threads tiff truetype unicode vaapi vim-syntax vorbis webp xattr xft xinerama zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2 php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_8" PYTHON_TARGETS="python2_7 python3_8" RUBY_TARGETS="ruby25 ruby26" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

dev-libs/libverto-0.3.1::gentoo was built with the following:
USE="libev threads -glib -libevent -static-libs -tevent" ABI_X86="32 (64) (-x32)"


net-nds/gssproxy-0.8.3::gentoo was built with the following:
USE="-debug -hardened (-selinux) -systemd" ABI_X86="(64)"
Comment 1 Sam James archtester gentoo-dev Security 2020-12-31 22:56:41 UTC
How about installing the old libverto and rebuilding gssproxy?
Comment 2 Nick Bowler 2021-01-01 03:51:22 UTC
(In reply to Sam James from comment #1)
> How about installing the old libverto and rebuilding gssproxy?

This does not make any difference in behaviour.

However, I think I've identified the cause / workaround: the problem is corrected if I update /bin/sh to bash and recompile libverto (any version).  So it seems that libverto miscompiles if /bin/sh is dash as I normally use.

I guess the reason this never turned up is because this is always one of the first packages to install after unpacking a stage3 tarball on a new system, and the recent stabilization is the 

Normally, I have /bin/sh -> dash).  But since gssproxy would be one of the first packages to install from stage3 I guess I have literally never installed a libverto update ever, since it appears the last time a libverto stabilization occurred gentoo repo was still in CVS.
Comment 3 Nick Bowler 2021-01-01 05:50:33 UTC
Created attachment 680488 [details, diff]
patch to fix bashisms in configure.ac

This patch enables libverto to install a working library with /bin/sh -> dash.
Comment 4 Matt Turner gentoo-dev 2021-01-01 17:19:39 UTC
(In reply to Nick Bowler from comment #3)
> Created attachment 680488 [details, diff] [details, diff]
> patch to fix bashisms in configure.ac
> 
> This patch enables libverto to install a working library with /bin/sh ->
> dash.

Nice! Could you please make a pull request upstream at https://github.com/latchset/libverto ?
Comment 5 Larry the Git Cow gentoo-dev 2021-01-07 14:20:25 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1a720b41737ae88adc368418b296bcd26a0eb742

commit 1a720b41737ae88adc368418b296bcd26a0eb742
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-01-07 14:20:19 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-01-07 14:20:19 +0000

    dev-libs/libverto: fix runtime breakage with non-bash
    
    Thanks-to: Nick Bowler <nbowler@draconx.ca>
    Closes: https://bugs.gentoo.org/762823
    Package-Manager: Portage-3.0.12, Repoman-3.0.2
    Signed-off-by: Sam James <sam@gentoo.org>

 .../libverto/files/libverto-0.3.1-non-bash.patch   | 133 +++++++++++++++++++++
 ...verto-0.3.1.ebuild => libverto-0.3.1-r1.ebuild} |  10 +-
 2 files changed, 140 insertions(+), 3 deletions(-)