Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 760105 - app-admin/rsyslog-8.2012.0 does not install systemd unit
Summary: app-admin/rsyslog-8.2012.0 does not install systemd unit
Status: RESOLVED DUPLICATE of bug 740262
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Thomas Deutschmann
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-16 06:05 UTC by Andrej Filipcic
Modified: 2021-02-04 18:55 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrej Filipcic 2020-12-16 06:05:03 UTC
See also bug #740262

The systemd service unit file is not included in source any more, it has to be added to the ebuild. It can be the same as the one in 8.2006.0, the last working verion:

# cat /lib/systemd/system/rsyslog.service
[Unit]
Description=System Logging Service
;Requires=syslog.socket
Wants=network.target network-online.target
After=network.target network-online.target
Documentation=man:rsyslogd(8)
Documentation=http://www.rsyslog.com/doc/

[Service]
Type=notify
ExecStart=/usr/sbin/rsyslogd -n -iNONE
StandardOutput=null
Restart=on-failure

# Increase the default a bit in order to allow many simultaneous
# files to be monitored, we might need a lot of fds.
LimitNOFILE=16384

[Install]
WantedBy=multi-user.target
;Alias=syslog.service
Comment 1 Andrej Filipcic 2021-01-20 09:26:52 UTC
This one is now critical. The last systemd-working rsyslog release was removed from portage.
Comment 2 Thomas Deutschmann gentoo-dev Security 2021-02-04 18:55:32 UTC

*** This bug has been marked as a duplicate of bug 740262 ***