Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 740262 - app-admin/rsyslog-8.2008.0 should install systemd unit files
Summary: app-admin/rsyslog-8.2008.0 should install systemd unit files
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Thomas Deutschmann
URL:
Whiteboard:
Keywords:
: 760105 (view as bug list)
Depends on:
Blocks: 768675
  Show dependency tree
 
Reported: 2020-09-04 02:24 UTC by foufou33
Modified: 2021-04-05 23:41 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description foufou33 2020-09-04 02:24:23 UTC
after the upgrade to 8.2008.0 from 8.2008.0 I can no longer start or stop rsyslog usint systemctl, the service file no longer exists

systemctl  list-units  | grep rsyslog
● rsyslog.service                                                                           not-found active running   rsyslog.service

with 8.2006.0
equery  files rsyslog  | grep rsyslog.service
/lib/systemd/system/rsyslog.service


with 8.2006.0
equery  files rsyslog  | grep rsyslog.service
return's nothing

the upstream commit that removed it
https://github.com/rsyslog/rsyslog/commit/cfd07503ba055100a84d75d1a78a5c6cceb9fdab


Reproducible: Always

Steps to Reproduce:
1.upgrade to 8.2008.0 
2. systemctl restart rsyslog
3.
Actual Results:  
Failed to restart rsyslog.service: Unit rsyslog.service not found.


Expected Results:  
the service is restarted
Comment 1 Andrej Filipcic 2020-10-23 09:45:00 UTC
I have checked the rhel8 builds, the service file is not included in source any more, it has to be added  to the ebuild. The same for version 8.2010.0.
Comment 2 Christian Roessner 2020-12-21 12:06:04 UTC
Are there any updates? I had to copy a Debian unit file for rsyslog to get things working again. It is very annoying that the unit file is missing. :-)
Comment 3 Pavel Volkovitskiy 2021-01-01 20:03:36 UTC
Same issue with 8.2012.0 version
Comment 4 Thomas Deutschmann gentoo-dev Security 2021-02-04 18:55:32 UTC
*** Bug 760105 has been marked as a duplicate of this bug. ***
Comment 5 Thomas Deutschmann gentoo-dev Security 2021-02-04 19:36:54 UTC
I am going with the Debian service file.

I don't have a Gentoo systemd system at the moment to test.

I am not sure about the consequences of "Requires=syslog.socket" and I wonder if default rsyslog.conf should need a config directive to read from /run/systemd/journal/syslog to make sense.
Comment 6 Larry the Git Cow gentoo-dev 2021-02-04 19:39:53 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8dce6794495e734990897619806aac5fefe8c6d0

commit 8dce6794495e734990897619806aac5fefe8c6d0
Author:     Thomas Deutschmann <whissi@gentoo.org>
AuthorDate: 2021-02-04 19:39:03 +0000
Commit:     Thomas Deutschmann <whissi@gentoo.org>
CommitDate: 2021-02-04 19:39:49 +0000

    app-admin/rsyslog: add systemd unit
    
    Upstream has stopped providing a default unit file since v8.2008.0.
    
    Link 1: https://github.com/rsyslog/rsyslog/commit/cfd07503ba055100a84d75d1a78a5c6cceb9fdab
    Bug: https://bugs.gentoo.org/740262
    Package-Manager: Portage-3.0.14, Repoman-3.0.2
    Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>

 app-admin/rsyslog/files/rsyslog.service      |  20 ++
 app-admin/rsyslog/rsyslog-8.2012.0-r1.ebuild | 483 +++++++++++++++++++++++++++
 2 files changed, 503 insertions(+)
Comment 7 Larry the Git Cow gentoo-dev 2021-04-05 23:37:32 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0d1455ab4a584695dfd81f7a1df9ce05aea4f27d

commit 0d1455ab4a584695dfd81f7a1df9ce05aea4f27d
Author:     Thomas Deutschmann <whissi@gentoo.org>
AuthorDate: 2021-04-05 23:36:48 +0000
Commit:     Thomas Deutschmann <whissi@gentoo.org>
CommitDate: 2021-04-05 23:37:28 +0000

    app-admin/rsyslog: update systemd service file
    
    Bug: https://bugs.gentoo.org/740262
    Package-Manager: Portage-3.0.18, Repoman-3.0.3
    Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>

 app-admin/rsyslog/files/rsyslog.service | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)