Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 746596 - media-gfx/digikam-7.1.0, media-libs/opencv-4.5.0 and virtual/lapacke-3.8-r1 stabilisation
Summary: media-gfx/digikam-7.1.0, media-libs/opencv-4.5.0 and virtual/lapacke-3.8-r1 s...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andreas K. Hüttel
URL:
Whiteboard:
Keywords: CC-ARCHES
: 747787 (view as bug list)
Depends on: 700176 733796 747163 747427 747949 749681
Blocks: qtwebkit-removal python3.8-stable, python38-stable-needed
  Show dependency tree
 
Reported: 2020-10-04 19:51 UTC by Andreas Sturmlechner
Modified: 2020-11-12 20:57 UTC (History)
8 users (show)

See Also:
Package list:
media-gfx/digikam-7.1.0 amd64 x86 media-libs/opencv-4.5.0 virtual/lapacke-3.8-r1
Runtime testing required: ---
nattka: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2020-10-04 19:51:27 UTC
Much to my dismay they made that unconditional. Objections?
Comment 1 NATTkA bot gentoo-dev 2020-10-04 19:52:55 UTC
Sanity check failed:

> media-gfx/digikam-7.1.0
>   depend amd64 stable profile default/linux/amd64/17.0 (39 total)
>     >=media-libs/opencv-3.3.0:=[contrib,contribdnn]
>   depend amd64 dev profile default/linux/amd64/17.0/no-multilib/prefix/kernel-3.2+ (2 total)
>     >=media-libs/opencv-3.3.0:=[contrib,contribdnn]
>   rdepend amd64 stable profile default/linux/amd64/17.0 (39 total)
>     >=media-libs/opencv-3.3.0:=[contrib,contribdnn]
>   rdepend amd64 dev profile default/linux/amd64/17.0/no-multilib/prefix/kernel-3.2+ (2 total)
>     >=media-libs/opencv-3.3.0:=[contrib,contribdnn]
Comment 2 Andreas K. Hüttel gentoo-dev 2020-10-04 20:14:30 UTC
(In reply to Andreas Sturmlechner from comment #0)
> Much to my dismay they made that unconditional. Objections?

No objections at all from me, it just means we need to drop the stablemask of these useflags on opencv. This may lead to additional dependencies.
Comment 3 Larry the Git Cow gentoo-dev 2020-10-09 19:14:16 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9efcfcc31a6b6e2f6aa90fdee161ca15c0ad951a

commit 9efcfcc31a6b6e2f6aa90fdee161ca15c0ad951a
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2020-10-09 19:12:58 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2020-10-09 19:14:12 +0000

    package.use.stable.mask: Un-stable-mask contrib, contribdnn of opencv-4.4
    
    Needed for digikam
    
    Bug: https://bugs.gentoo.org/746596
    Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>

 profiles/arch/amd64/package.use.stable.mask | 4 +++-
 profiles/arch/x86/package.use.stable.mask   | 4 +++-
 2 files changed, 6 insertions(+), 2 deletions(-)
Comment 4 NATTkA bot gentoo-dev 2020-10-09 23:52:52 UTC
Sanity check failed:

> media-gfx/digikam-7.1.0
>   depend amd64 stable profile default/linux/amd64/17.0 (39 total)
>     >=media-libs/opencv-3.3.0:=[contrib,contribdnn]
>   depend amd64 dev profile default/linux/amd64/17.0/no-multilib/prefix/kernel-3.2+ (2 total)
>     >=media-libs/opencv-3.3.0:=[contrib,contribdnn]
>   rdepend amd64 stable profile default/linux/amd64/17.0 (39 total)
>     >=media-libs/opencv-3.3.0:=[contrib,contribdnn]
>   rdepend amd64 dev profile default/linux/amd64/17.0/no-multilib/prefix/kernel-3.2+ (2 total)
>     >=media-libs/opencv-3.3.0:=[contrib,contribdnn]
Comment 5 NATTkA bot gentoo-dev 2020-10-11 19:20:50 UTC Comment hidden (obsolete)
Comment 6 NATTkA bot gentoo-dev 2020-10-12 16:12:49 UTC Comment hidden (obsolete)
Comment 7 NATTkA bot gentoo-dev 2020-10-12 16:16:50 UTC Comment hidden (obsolete)
Comment 8 Sam James archtester gentoo-dev Security 2020-10-23 14:56:08 UTC
I'll add bug 700176 as a blocker too but we may leave that one.
Comment 9 NATTkA bot gentoo-dev 2020-11-03 07:41:03 UTC Comment hidden (obsolete)
Comment 10 Andreas Sturmlechner gentoo-dev 2020-11-03 14:28:26 UTC
*** Bug 747787 has been marked as a duplicate of this bug. ***
Comment 11 Sam James archtester gentoo-dev Security 2020-11-10 00:37:52 UTC
@asturm, ready when you are, I reckon.
Comment 12 Andreas Sturmlechner gentoo-dev 2020-11-10 19:16:06 UTC
digikam was ready since Oct 9th ;)
Comment 13 Sam James archtester gentoo-dev Security 2020-11-11 04:31:05 UTC
arm64 done
Comment 14 Sam James archtester gentoo-dev Security 2020-11-11 04:34:44 UTC
(In reply to Andreas Sturmlechner from comment #12)
> digikam was ready since Oct 9th ;)

Touche!
Comment 15 Sam James archtester gentoo-dev Security 2020-11-11 15:38:00 UTC
amd64 done
Comment 16 Larry the Git Cow gentoo-dev 2020-11-11 18:30:35 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=59e71fa4f13d8efbe534c22326f5b6aebd7c2fa9

commit 59e71fa4f13d8efbe534c22326f5b6aebd7c2fa9
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-11-11 17:59:25 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-11-11 18:30:06 +0000

    profiles: plasma: Enable media-libs/opencv[contrib,contribdnn] for digikam
    
    Bug: https://bugs.gentoo.org/746596
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 profiles/targets/desktop/plasma/package.use | 3 +++
 1 file changed, 3 insertions(+)
Comment 17 Sam James archtester gentoo-dev Security 2020-11-12 15:26:48 UTC
x86 done

all arches done
Comment 18 Larry the Git Cow gentoo-dev 2020-11-12 20:57:10 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4fa1aa29036ddd5aa09bf9bbae8bf0ce7c42e756

commit 4fa1aa29036ddd5aa09bf9bbae8bf0ce7c42e756
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-11-12 18:32:21 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-11-12 20:56:57 +0000

    media-gfx/digikam: Drop 6.4.0-r1
    
    Closes: https://bugs.gentoo.org/746596
    Package-Manager: Portage-3.0.9, Repoman-3.0.2
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 media-gfx/digikam/Manifest                         |   1 -
 media-gfx/digikam/digikam-6.4.0-r1.ebuild          | 155 ---------------------
 media-gfx/digikam/files/digikam-6.3.0-cmake.patch  |  66 ---------
 .../digikam/files/digikam-6.4.0-qt-5.15.patch      |  38 -----
 media-gfx/digikam/metadata.xml                     |   3 -
 5 files changed, 263 deletions(-)