Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 736709 (python38-stable-needed) - [TRACKER] Packages without Python 3.8 in stable version
Summary: [TRACKER] Packages without Python 3.8 in stable version
Status: CONFIRMED
Alias: python38-stable-needed
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Python Gentoo Team
URL: https://qa-reports.gentoo.org/output/...
Whiteboard:
Keywords: Tracker
Depends on: 708940 718326 729018 736701 736717 736727 737290 737526 gnome-3.36-stable 739920 740154 747787 700490 718038 725152 725574 CVE-2020-14019 732620 CVE-2020-10699, CVE-2020-13867 736703 736705 736711 736715 736719 736721 736723 736728 736730 736732 736734 736736 736738 736740 736818 736900 736902 737030 737288 737292 737294 737520 737522 737524 737530 737532 737584 CVE-2020-8620, CVE-2020-8621, CVE-2020-8622, CVE-2020-8623, CVE-2020-8624 738730 738952 738954 738956 739270 739690 739936 739958 739960 739962 739964 741168
Blocks: python3.8-compat
  Show dependency tree
 
Reported: 2020-08-11 09:03 UTC by Sam James
Modified: 2020-10-22 20:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sam James archtester gentoo-dev Security 2020-08-11 09:03:38 UTC
This is definitely quite early, but I'd rather thave the bugs now blocking this tracker so we can keep track, than having to do a huge amount of work later on filing them in a rush.

The target date for Python 3.8 in the default PYTHON_TARGETS is ~1st December this year.

See https://wiki.gentoo.org/wiki/Project:Python/Implementations#Implementation_support_timeline for more information.