Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 744850 - dev-libs/libxml2-2.9.10-r3 libxml2-2.9.10-r3-patchset.tar.xz does not exist
Summary: dev-libs/libxml2-2.9.10-r3 libxml2-2.9.10-r3-patchset.tar.xz does not exist
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 744865 744874 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-26 17:18 UTC by Frank Krömmelbein
Modified: 2020-09-26 20:43 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Krömmelbein 2020-09-26 17:18:38 UTC
Update fails for me:
[ebuild     U  ] dev-libs/libxml2-2.9.10-r3:2::gentoo [2.9.10-r1:2::gentoo] USE="icu ipv6 lzma python readline -debug -examples -static-libs -test" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python3_7 -python3_6 -python3_8 (-python3_9) (-python2_7%*)" 0 KiB

>>> Emerging (1 of 1) dev-libs/libxml2-2.9.10-r3::gentoo
 * libxml2-2.9.10.tar.gz BLAKE2B SHA512 size ;-) ...                                                                                               [ ok ]
 * libxml2-2.9.10-r1-patchset.tar.xz BLAKE2B SHA512 size ;-) ...                                                                                   [ ok ]
>>> Unpacking source...
>>> Unpacking libxml2-2.9.10.tar.gz to /var/tmp/portage/dev-libs/libxml2-2.9.10-r3/work
>>> Unpacking libxml2-2.9.10-r3-patchset.tar.xz to /var/tmp/portage/dev-libs/libxml2-2.9.10-r3/work
 * ERROR: dev-libs/libxml2-2.9.10-r3::gentoo failed (unpack phase):
 *   unpack: libxml2-2.9.10-r3-patchset.tar.xz does not exist
 * 
 * Call stack:
 *          ebuild.sh, line  125:  Called src_unpack
 *        environment, line 3648:  Called unpack 'libxml2-2.9.10-r3-patchset.tar.xz'
 *   phase-helpers.sh, line  350:  Called die
 * The specific snippet of code:
 *              [[ ! -s ${srcdir}${x} ]] && die "unpack: ${x} does not exist"
 * 
 * If you need support, post the output of `emerge --info '=dev-libs/libxml2-2.9.10-r3::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-libs/libxml2-2.9.10-r3::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-libs/libxml2-2.9.10-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/libxml2-2.9.10-r3/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-libs/libxml2-2.9.10-r3/work'
 * S: '/var/tmp/portage/dev-libs/libxml2-2.9.10-r3/work/libxml2-2.9.10'



Reproducible: Always
Comment 1 Frank Krömmelbein 2020-09-26 17:26:34 UTC
It seems this commit caused this issue:
https://github.com/gentoo/gentoo/commit/393ba05e59d2bdbfab81d35d7005021c2cac9e3a
Comment 2 Ionen Wolkens gentoo-dev 2020-09-26 17:30:13 UTC
(In reply to Frank Krömmelbein from comment #1)
> It seems this commit caused this issue
Are you sure? Should be the opposite, it caused it. It updated the link but didn't update "unpack ${PF}-patchset.tar.xz"
Comment 3 Ionen Wolkens gentoo-dev 2020-09-26 17:31:14 UTC
(In reply to Ionen Wolkens from comment #2)
> (In reply to Frank Krömmelbein from comment #1)
> > It seems this commit caused this issue
> Are you sure? Should be the opposite, it caused it. It updated the link but
> didn't update "unpack ${PF}-patchset.tar.xz"

Err, I misread the "caused" as "fixed" for some reason :| Yeah, it's that.
Comment 4 Sam James archtester gentoo-dev Security 2020-09-26 17:56:42 UTC
Can fix if nobody else is able to, but an hour or two before back at a shell.
Comment 5 Larry the Git Cow gentoo-dev 2020-09-26 17:57:37 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c9507383c6d13e62b52c9d0044c79427b4864e62

commit c9507383c6d13e62b52c9d0044c79427b4864e62
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: 2020-09-26 17:55:13 +0000
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: 2020-09-26 17:57:25 +0000

    dev-libs/libxml2: Fix unpacking patchset
    
    Closes: https://bugs.gentoo.org/744850
    Signed-off-by: Michał Górny <mgorny@gentoo.org>

 dev-libs/libxml2/libxml2-2.9.10-r3.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 6 Sam James archtester gentoo-dev Security 2020-09-26 19:59:12 UTC
*** Bug 744865 has been marked as a duplicate of this bug. ***
Comment 7 Sam James archtester gentoo-dev Security 2020-09-26 20:43:08 UTC
*** Bug 744874 has been marked as a duplicate of this bug. ***