Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 74457 - [3.4/ICE] gcc bombs in sweep_string_variable with ssp
Summary: [3.4/ICE] gcc bombs in sweep_string_variable with ssp
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
: 76466 77752 81191 94229 97166 103500 107833 109833 117174 119586 120569 122349 122765 125583 126427 127325 128238 133759 134901 136712 137698 137873 140363 142246 142890 148594 158298 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-12-15 01:23 UTC by Mark
Modified: 2007-03-14 00:37 UTC (History)
36 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Preprocessed source leading to internal compiler error (ccCS59Rh.out.gz,106.24 KB, application/octet-stream)
2005-08-14 15:04 UTC, Howard B. Golden
Details
Pre-processed code causing an ICE with i686-pc-linux-gnu-3.4.4 (ccVMKFeL.out.gz,426.17 KB, application/octet-stream)
2005-10-22 18:32 UTC, Preston A. Elder (RETIRED)
Details
preprocessed.c++.bz2 (preprocessed.c++.bz2,82.52 KB, application/x-bzip)
2005-12-10 23:41 UTC, Péter Werner
Details
Avoid sweep string variable ICE; issue a warning when it occurs (gcc-3.4.4-sweepregwarn.patch,1.19 KB, patch)
2006-01-08 06:59 UTC, Kevin F. Quinn (RETIRED)
Details | Diff
preprocessed source that fails to compile (failed.cc.bz2,118.81 KB, application/x-bzip)
2006-01-28 06:12 UTC, Michal Suchanek
Details
another failed source (fpx-failed.cc.bz2,53.34 KB, application/x-bzip)
2006-02-07 08:38 UTC, Michal Suchanek
Details
Reduced testcase (test.cc,455 bytes, text/plain)
2006-03-09 09:52 UTC, Mark Loeser (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark 2004-12-15 01:23:43 UTC
emerging dclib 0.3.3(-r1) with g++ (GCC) 3.4.3 20041125 (Gentoo Linux 3.4.3-r1, ssp-3.4.3-0, pie-8.7.7) does not work because of an internal compiler error.

cmd5.cpp: In function `std::ostream& operator<<(std::ostream&, CMD5)':
cmd5.cpp:294: internal compiler error: in sweep_string_variable, at protector.c:1158
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
Preprocessed source stored into /var/tmp/portage/dclib-0.3.3-r1/temp/ccroW5HV.out file, please attach this to your bugreport.
make[3]: *** [cmd5.lo] Fehler 1


Solution: CFLAGS must be reduced to CFLAGS="-march=athlon-xp -m3dnow -O3 -pipe" (see used CFLAGS in "additional information") and it will emerge without problems.

Reproducible: Always
Steps to Reproduce:
1. Set aggressive CFLAGS
2. emerge dclib
3. Set safe CFLAGS




Portage 2.0.51-r8 (default-linux/x86/2004.0, gcc-3.4.3,  
glibc-2.3.4.20041102-r0, 2.6.9-gentoo-r4 i686)  
=================================================================  
System uname: 2.6.9-gentoo-r4 i686 AMD Athlon(tm) XP 1700+  
Gentoo Base System version 1.6.7  
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Oct 31 2004, 11:46:53)]  
distcc 2.17 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632)  
[disabled]  
ccache version 2.3 [enabled]  
dev-lang/python:     2.3.4  
sys-devel/autoconf:  2.59-r6, 2.13  
sys-devel/automake:  1.5, 1.4_p6, 1.6.3, 1.7.9, 1.9.3  
sys-devel/binutils:  2.15.92.0.2-r1, 2.15.92.0.2-r2  
sys-devel/libtool:   1.5.10-r1  
virtual/os-headers:  2.6.8.1-r1  
ACCEPT_KEYWORDS="x86 ~x86"  
AUTOCLEAN="yes"  
CFLAGS="-march=athlon-xp -m3dnow -mfpmath=sse -O3 -pipe -fforce-addr  
-fomit-frame-pointer -funroll-loops -falign-functions=4  
-maccumulate-outgoing-args -ffast-math -fprefetch-loop-arrays  
-fstack-protector"  
CHOST="i686-pc-linux-gnu"  
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"  
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"  
CXXFLAGS="-march=athlon-xp -m3dnow -mfpmath=sse -O3 -pipe -fforce-addr  
-fomit-frame-pointer -funroll-loops -falign-functions=4  
-maccumulate-outgoing-args -ffast-math -fprefetch-loop-arrays  
-fstack-protector"  
DISTDIR="/usr/portage/distfiles"  
FEATURES="autoaddcvs autoconfig ccache digest distlocks sandbox sfperms"  
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo  
ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/  
http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"  
MAKEOPTS="-j4"  
PKGDIR="/usr/portage/packages"  
PORTAGE_TMPDIR="/var/tmp"  
PORTDIR="/usr/portage"  
PORTDIR_OVERLAY="/usr/local/portage"  
SYNC="rsync://rsync.gentoo.org/gentoo-portage"  
USE="3dnow X acpi alsa apache2 arts artswrappersuid avi bash-completion cdr  
crypt cups curl dga directfb divx4linux dvd encode exif extensions f77 fbcon  
ftp gif gpm gtk gtk2 icq imagemagick jabber java jikes jpeg kde lesstif libwww  
maildirmmx motif mozilla mpeg mysql ncurses network nls nptl nptlonly  
oggvorbis ooo-kde opengl oscar pam pdflib perl png posix ppds python qt  
quicktime readline real samba scanner sdl slang speex spell sse ssl svg svga  
tcltk tetex tiff truetype unicode usb wmf wxwindows x86 xine xml xml2 xmms  
xosd xv xvid zlib linguas_de"
Comment 1 Charlie Gehlin 2004-12-15 06:53:21 UTC
I have the problem if using gcc-3.3.3. I only did 'gcc-config 2' (2=gcc-3.4.3) and 'source /etc/profile' and it compiled fine even with CFLAGS="-O3 -march=athlon-xp -mfpmath=sse -mmmx -msse -mno-sse2 -mno-sse3 -m3dnow -funroll-loops -fomit-frame-pointer -pipe".
Comment 2 Alexandre Rostovtsev (RETIRED) gentoo-dev 2004-12-15 19:31:50 UTC
I have the same error, but only with hardened gcc-3.4.3 (vanilla gcc-3.4.3 works fine) and CFLAGS="-march=athlon-xp -O2 -pipe -frename-registers -fomit-frame-pointer ".
Comment 3 SpanKY gentoo-dev 2005-05-27 18:46:46 UTC
*** Bug 76466 has been marked as a duplicate of this bug. ***
Comment 4 SpanKY gentoo-dev 2005-05-27 18:47:06 UTC
*** Bug 77752 has been marked as a duplicate of this bug. ***
Comment 5 SpanKY gentoo-dev 2005-05-27 18:47:10 UTC
*** Bug 94229 has been marked as a duplicate of this bug. ***
Comment 6 SpanKY gentoo-dev 2005-05-27 18:47:20 UTC
*** Bug 81191 has been marked as a duplicate of this bug. ***
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2005-07-02 09:29:34 UTC
*** Bug 97166 has been marked as a duplicate of this bug. ***
Comment 8 Howard B. Golden 2005-08-14 14:57:41 UTC
I'm getting the same internal compiler error when compiling
net-libs/libtorrent-0.7.1 using gcc (GCC) 3.4.4 (Gentoo 3.4.4, ssp-3.4.4-1.0,
pie-8.7.8):

g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I. -I./.. -I../.. -march=athlon-xp -O2
-pipe -fstack-protector -DNDEBUG -I/usr/include/sigc++-2.0
-I/usr/lib/sigc++-2.0/include -c connection_list.cc  -fPIC -DPIC -o
connection_list.lo
/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/include/g++-v3/bits/stl_algo.h: In function
`_RandomAccessIterator std::find_if(_RandomAccessIterator,
_RandomAccessIterator, _Predicate, std::random_access_iterator_tag) [with
_RandomAccessIterator =
__gnu_cxx::__normal_iterator<torrent::PeerConnectionBase**,
std::vector<torrent::PeerConnectionBase*,
std::allocator<torrent::PeerConnectionBase*> > >, _Predicate =
rak::_equal<torrent::PeerInfo, std::const_mem_fun_t<const torrent::PeerInfo&,
torrent::PeerConnectionBase> >]':
/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/include/g++-v3/bits/stl_algo.h:292:
internal compiler error: in sweep_string_variable, at protector.c:1158

Preprocessed source attached as requested.
Comment 9 Howard B. Golden 2005-08-14 15:04:41 UTC
Created attachment 65975 [details]
Preprocessed source leading to internal compiler error

Preprocessed source for comment #8.
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2005-08-24 04:54:27 UTC
*** Bug 103500 has been marked as a duplicate of this bug. ***
Comment 11 Preston A. Elder (RETIRED) gentoo-dev 2005-10-22 18:32:29 UTC
Created attachment 71237 [details]
Pre-processed code causing an ICE with i686-pc-linux-gnu-3.4.4

I get the same ICE:

/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/include/g++-v3/bits/stl_pair.h: In
function `std::pair<_T1, _T2> std::make_pair(_T1, _T2) [with _T1 = const
XML_Char*, _T2 = boost::variant<bool, int8_t, uint8_t, int16_t, uint16_t,
int32_t, uint32_t, int64_t, uint64_t, float, double, std::string, std::wstring,
boost::gregorian::date, mantra::duration, boost::posix_time::ptime,
mantra::NullValue, boost::detail::variant::void_,
boost::detail::variant::void_, boost::detail::variant::void_>]':
/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/include/g++-v3/bits/stl_pair.h:144:
internal compiler error: in sweep_string_variable, at protector.c:1158
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
Preprocessed source stored into /tmp/ccVMKFeL.out file, please attach this to
your bugreport.

I've attached the pre-processed code.  Though the original source file
(http://www.neuromancy.net/viewcvs/Mantra-I/src/storage/xml.cpp?root=mantra&rev=1.40&view=markup)
is only 1400 lines (including comments), when I try to compile this code, I've
seen it use >330mb of RAM.
Comment 12 Kevin F. Quinn (RETIRED) gentoo-dev 2005-11-26 09:26:56 UTC
Could everyone who has this problem, please post combinations of:

1) Compiler version
2) CFLAGS

which cause the ICE?
Comment 13 Barral 2005-12-05 10:06:42 UTC
(In reply to comment #12)
> Could everyone who has this problem, please post combinations of:
> 
> 1) Compiler version
> 2) CFLAGS
> 
> which cause the ICE?
> 
ICE occurs during compilation of libfpx-1.2.0.9

1) gcc-config gives   i686-pc-linux-gnu-3.4.4

2) CFLAGS="-O2 -march=i686 -pipe"
Comment 14 Péter Werner 2005-12-10 23:27:58 UTC
Compiles successfully with:
i686-pc-linux-gnu-3.3.6
i686-pc-linux-gnu-3.4.4-vanilla

Fails with:
i686-pc-linux-gnu-3.4.4
CFLAGS,CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CFLAGS,CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CFLAGS,CXXFLAGS=""
Comment 15 Péter Werner 2005-12-10 23:41:08 UTC
Created attachment 74471 [details]
preprocessed.c++.bz2

The ICE reproducible by simply "g++ -c preprocessed.c++".
fails for: 6,7
compiles for: 1,2,3,4,5,8,9,10

gcc-config -l
 [1] i686-pc-linux-gnu-3.3.6
 [2] i686-pc-linux-gnu-3.3.6-hardenednopie
 [3] i686-pc-linux-gnu-3.3.6-hardenednopiessp
 [4] i686-pc-linux-gnu-3.3.6-hardenednossp
 [5] i686-pc-linux-gnu-3.3.6-vanilla
 [6] i686-pc-linux-gnu-3.4.4 *
 [7] i686-pc-linux-gnu-3.4.4-hardenednopie
 [8] i686-pc-linux-gnu-3.4.4-hardenednopiessp
 [9] i686-pc-linux-gnu-3.4.4-hardenednossp
 [10] i686-pc-linux-gnu-3.4.4-vanilla
---
test:
gcc-config <n>
source /etc/profile
g++ -c preprocessed.c++
Comment 16 Starling 2005-12-15 12:31:42 UTC
Fails with:
gcc version 3.4.4 (Gentoo Hardened 3.4.4-r1, ssp-3.4.4-1.0, pie-8.7.8)
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe"
CXXFLAGS="${CFLAGS}"
CHOST="i686-pc-linux-gnu"

Works with:
Reading specs from /usr/lib/gcc/i686-pc-linux-gnu/3.4.4/vanilla.specs

sigh...
Comment 17 Christian Korff 2005-12-26 04:01:03 UTC
I think this also applies to
media-libs/libfpx-1.2.0.9

Same error message (internal compiler error: in sweep_string_variable) and works fine with vanilla gcc. (i686-pc-linux-gnu-3.4.4)
Tested with:
i686-pc-linux-gnu-3.4.4-hardened
CFLAGS/CXXFLAGS="-O2 -march=pentium4 -pipe -msse3"

Comment 18 Jakub Moc (RETIRED) gentoo-dev 2005-12-30 03:16:28 UTC
*** Bug 117174 has been marked as a duplicate of this bug. ***
Comment 19 Jakub Moc (RETIRED) gentoo-dev 2006-01-06 09:12:51 UTC
*** Bug 109833 has been marked as a duplicate of this bug. ***
Comment 20 Jakub Moc (RETIRED) gentoo-dev 2006-01-08 02:38:34 UTC
*** Bug 107833 has been marked as a duplicate of this bug. ***
Comment 21 Kevin F. Quinn (RETIRED) gentoo-dev 2006-01-08 06:59:28 UTC
Created attachment 76527 [details, diff]
Avoid sweep string variable ICE; issue a warning when it occurs

Ok; here goes nothing.  Patch is for gcc-3 (NOT gcc-4 where everything is different).  It avoids the ICE that occurs in the affected packages, and instead issues a warning.

It should generate working executables, however it may mean that one of the steps SSP takes to protect functions is not taken properly.  In other words, while it's better than switching off SSP completely, it may leave some functions partly unprotected.

To try it out, add this patch to sys-devel/gcc, and remove 'filter-flags -fstack-protector' from the ebuilds of the affected packages if present (all in your overlay or course).

Please report here if any of the packages that previously ICE'd in sweep_string_variable still ICE, or if the application builds but doesn't run properly.
Comment 22 solar (RETIRED) gentoo-dev 2006-01-08 07:50:26 UTC
Any final versions should probably be wrappered in #ifdef __i386__ as it seems this only effects x86 arch according to kumba
Comment 23 Kerin Millar 2006-01-08 17:02:58 UTC
I applied Kevin's patch to gcc-3.4.5 and it fixed up my compile problems with both versions of hylafax currently in the tree (4.2.3-r1 and 4.2.4). These problems are described in bug 109833. Thanks :)
Comment 24 Joshua Kinard gentoo-dev 2006-01-09 22:38:03 UTC
Only tested on a Mips box atm.  I'll have to reboot my sparc64 box (it's deadlocked) and test it later on to see if it's affected as well.  Will update on how that works out.
Comment 25 Jakub Moc (RETIRED) gentoo-dev 2006-01-19 11:52:23 UTC
*** Bug 119586 has been marked as a duplicate of this bug. ***
Comment 26 Jakub Moc (RETIRED) gentoo-dev 2006-01-27 14:30:13 UTC
*** Bug 120569 has been marked as a duplicate of this bug. ***
Comment 27 Michal Suchanek 2006-01-28 06:12:36 UTC
Created attachment 78347 [details]
preprocessed source that fails to compile

compiles with gcc 3.3.6 (hardened), and gcc 3.4.4-hardened-nossp.
It fails with 3.4.4 (hardened).
I did not apply any optoins, just tried g++ -c failed.cc
Comment 28 Kevin F. Quinn (RETIRED) gentoo-dev 2006-01-30 17:24:05 UTC
(In reply to comment #27)
> It fails with 3.4.4 (hardened).
> I did not apply any optoins, just tried g++ -c failed.cc

Adding -O2 optimises away the ICEs (i.e. 'g++ -O2 -c failed.cc' compiles cleanly).

Comment 29 Michal Suchanek 2006-02-07 08:31:41 UTC
(In reply to comment #28)
> (In reply to comment #27)
> > It fails with 3.4.4 (hardened).
> > I did not apply any optoins, just tried g++ -c failed.cc
> 
> Adding -O2 optimises away the ICEs (i.e. 'g++ -O2 -c failed.cc' compiles
> cleanly).
As well as -O3 and -Os.

I patched boost to always optimize (even for debug libraries), and I will see if it builds. 

Comment 30 Michal Suchanek 2006-02-07 08:38:17 UTC
Created attachment 79129 [details]
another failed source

This one is from libfpx, and compiles with -fno-stack-protector.
A few -O options I tried do not affect it, and it does not compile with just gcc -c (gcc 3.4.4).
gcc 3.3.6 compiles it.
Comment 31 Jakub Moc (RETIRED) gentoo-dev 2006-02-10 04:43:49 UTC
*** Bug 122349 has been marked as a duplicate of this bug. ***
Comment 32 Michal Suchanek 2006-02-13 15:20:17 UTC
The gcc patch also fixes boost and libfpx.

Thanks
Comment 33 Jakub Moc (RETIRED) gentoo-dev 2006-02-14 01:24:17 UTC
*** Bug 122765 has been marked as a duplicate of this bug. ***
Comment 34 Mark Loeser (RETIRED) gentoo-dev 2006-03-09 09:46:08 UTC
*** Bug 125583 has been marked as a duplicate of this bug. ***
Comment 35 Mark Loeser (RETIRED) gentoo-dev 2006-03-09 09:52:06 UTC
Created attachment 81777 [details]
Reduced testcase

Incase anyone wants this to look at it, here is a reduced testcase which triggers the bug.
Comment 36 Stephen Torri 2006-03-09 14:02:09 UTC
I confirm that the problem is exposed by the latest test case provided.

Error
---------------

storri@base ~ $ g++ -fstack-protector -o test test.cc
test.cc: In constructor `PErrorsList::PErrorsList(OSErr, FicNom)':
test.cc:33: internal compiler error: in sweep_string_variable, at protector.c:1158
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
Preprocessed source stored into /tmp/ccWWEgva.out file, please attach this to your bugreport.


Compiler
----------------------
storri@base ~ $ gcc -v
Reading specs from /usr/lib/gcc/i686-pc-linux-gnu/3.4.5/specs
Configured with: /var/tmp/portage/gcc-3.4.5/work/gcc-3.4.5/configure --prefix=/usr --bindir=/usr/i686-pc-linux-gnu/gcc-bin/3.4.5 --includedir=/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/include --datadir=/usr/share/gcc-data/i686-pc-linux-gnu/3.4.5 --mandir=/usr/share/gcc-data/i686-pc-linux-gnu/3.4.5/man --infodir=/usr/share/gcc-data/i686-pc-linux-gnu/3.4.5/info --with-gxx-include-dir=/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/include/g++-v3 --host=i686-pc-linux-gnu --build=i686-pc-linux-gnu --disable-altivec --enable-nls --without-included-gettext --with-system-zlib --disable-checking --disable-werror --disable-libunwind-exceptions --disable-multilib --enable-java-awt=gtk --enable-languages=c,c++,java,f77 --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu
Thread model: posix
gcc version 3.4.5 (Gentoo 3.4.5, ssp-3.4.5-1.0, pie-8.7.9)

Comment 37 Jakub Moc (RETIRED) gentoo-dev 2006-03-23 10:07:01 UTC
*** Bug 127325 has been marked as a duplicate of this bug. ***
Comment 38 Jakub Moc (RETIRED) gentoo-dev 2006-03-31 07:48:38 UTC
*** Bug 128238 has been marked as a duplicate of this bug. ***
Comment 39 Jakub Moc (RETIRED) gentoo-dev 2006-05-30 03:56:33 UTC
*** Bug 134901 has been marked as a duplicate of this bug. ***
Comment 40 Jakub Moc (RETIRED) gentoo-dev 2006-05-30 03:56:53 UTC
*** Bug 133759 has been marked as a duplicate of this bug. ***
Comment 41 joe cave 2006-06-05 22:36:21 UTC
Fails with:

/usr/lib/gcc/i686-pc-linux-gnu/3.4.6/include/g++-v3/bits/stl_algo.h:292: internal compiler error: in sweep_string_variable, at protector.c:1158
Please submit a full bug report,
with preprocessed source if appropriate.

Preprocessed source stored into /var/tmp/portage/libtorrent-0.8.3/temp/ccGRYuLy.out file, please attach this to your bugreport.
make[3]: *** [connection_list.lo] Error 1
make[3]: *** Waiting for unfinished jobs....


emerge --info
Portage 2.0.54-r2 (hardened/x86/2.6, gcc-3.4.6, glibc-2.3.6-r3, 2.6.14-hardened-r7 i686)
=================================================================
System uname: 2.6.14-hardened-r7 i686 Pentium III (Coppermine)
Gentoo Base System version 1.6.14
dev-lang/python:     2.4.2
dev-python/pycrypto: [Not Present]
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=pentium3 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-Os -march=pentium3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
MAKEOPTS="-j3"
PKGDIR="/usr/portage//packages/x86/"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage/"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="apache2 berkdb bzip2 crypt curl dlloader expat gd gif gmp hardened idn jpeg mhash mysql ncurses nls pam pcre perl php pic png postgres python qmail readline sqlite ssl tcpd udev userlocales x86 xml xml2 xorg zlib userland_GNU kernel_linux elibc_glibc"
Unset:  CTARGET, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTAGE_RSYNC_OPTS, PORTDIR_OVERLAY
Comment 42 Kevin F. Quinn (RETIRED) gentoo-dev 2006-06-06 10:32:55 UTC
Mark,
I've committed my change to protector.c to remove this ICE for 3.4.6; if you could roll it up if you release 3.4.6 again that'd be great.
Comment 43 SpanKY gentoo-dev 2006-06-07 04:07:51 UTC
you want a revbump ?
Comment 44 Kevin F. Quinn (RETIRED) gentoo-dev 2006-06-07 07:21:04 UTC
ultimately, yes please - but I'll do #104754 (SSP specs consistency) first to avoid unnecessary bumps (it's top of my list), and maybe if we can find what's wrong, a fix for #133301.
Comment 45 Jakub Moc (RETIRED) gentoo-dev 2006-06-13 15:15:57 UTC
*** Bug 136712 has been marked as a duplicate of this bug. ***
Comment 46 Jakub Moc (RETIRED) gentoo-dev 2006-06-23 03:00:27 UTC
*** Bug 137698 has been marked as a duplicate of this bug. ***
Comment 47 Jakub Moc (RETIRED) gentoo-dev 2006-06-24 14:41:55 UTC
*** Bug 137873 has been marked as a duplicate of this bug. ***
Comment 48 Láďa Durchánek 2006-07-02 09:32:52 UTC
Is it possible to post patch somewhere? I want to use it as overlay as i'm need of pdns-recursor.
Comment 49 Kevin F. Quinn (RETIRED) gentoo-dev 2006-07-02 11:03:42 UTC
(In reply to comment #48)
> Is it possible to post patch somewhere? I want to use it as overlay as i'm need
> of pdns-recursor.

It's already attached to this bug - see the 4th attachment "Avoid sweep string variable ICE; issue a warning when it occurs" (actually the final patch is a little tidier, but that's just cosmetic).

SpanKY - when you get chance, can you do the bump including also the fix for #104754?  The patches for this bug and #104754 are in the patchset CVS in ssp and piepatches directories respectively.  I did a trial-run of a bump with gcc-3.4.6-ssp-1.0.tar.bz2 and gcc-3.4.6-piepatches-v8.7.9.tar.bz2 and it seemed to go fine.  Or give me the nod if you're happy for me to do it.
Comment 50 Láďa Durchánek 2006-07-02 12:14:53 UTC
Sorry, i was confused about its creation date. Thanks a lot.
Comment 51 SpanKY gentoo-dev 2006-07-05 22:33:37 UTC
feel free to push out ssp/pie fixes for gcc-3.x ... if you need something, just grab me on irc
Comment 52 Kevin F. Quinn (RETIRED) gentoo-dev 2006-07-06 12:05:14 UTC
ok; sys-devel/gcc-3.4.6-r2 is in, with this fix
Comment 53 Láďa Durchánek 2006-07-09 07:28:47 UTC
gcc-3.4.6-r2 emerges ok, pdns-recursor emerges ok, everything is working great. Thank you guys.
Comment 54 Jakub Moc (RETIRED) gentoo-dev 2006-07-14 08:02:50 UTC
*** Bug 140363 has been marked as a duplicate of this bug. ***
Comment 55 Harald van Dijk (RETIRED) gentoo-dev 2006-07-31 01:13:10 UTC
*** Bug 142246 has been marked as a duplicate of this bug. ***
Comment 56 Harald van Dijk (RETIRED) gentoo-dev 2006-08-05 09:22:25 UTC
*** Bug 142890 has been marked as a duplicate of this bug. ***
Comment 57 Jakub Moc (RETIRED) gentoo-dev 2006-09-21 20:06:01 UTC
*** Bug 148594 has been marked as a duplicate of this bug. ***
Comment 58 Jakub Moc (RETIRED) gentoo-dev 2006-12-16 08:10:17 UTC
*** Bug 158298 has been marked as a duplicate of this bug. ***
Comment 59 Jakub Moc (RETIRED) gentoo-dev 2007-03-14 00:37:10 UTC
(In reply to comment #52)
> ok; sys-devel/gcc-3.4.6-r2 is in, with this fix

... and stable for some time, closing. Yay! :)