Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 74285 - GNOME with HAL and gamin doesn't update the presence of usb stick
Summary: GNOME with HAL and gamin doesn't update the presence of usb stick
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
: 85179 (view as bug list)
Depends on:
Blocks: 74075 91928
  Show dependency tree
Reported: 2004-12-13 07:45 UTC by Sebastian Dröge
Modified: 2005-07-04 12:57 UTC (History)
18 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Dröge 2004-12-13 07:45:08 UTC
the bug described at
also applies to gentoo.

this is with gnome-vfs-2.8.3-r1, gamin-0.0.19 instead of fam, hal-0.4.2 and happens on x86 and ppc

CDs work without problems

Comment 1 Sebastian Dröge 2004-12-13 07:56:10 UTC
btw... it works the same way with fam instead of gamin
so maybe it's a bug in gamin or a bug in gnome-vfs which only shows up with gamin...
Comment 2 foser (RETIRED) gentoo-dev 2004-12-22 09:34:43 UTC
the bug you reference to should be solved in gnome-vfs-2.8.3

it could still be notification, do you use an inotify enabled kernel ? (you should always provide your emerge info in bugreports!)
Comment 3 Sebastian Dröge 2004-12-22 09:44:06 UTC
it isn't solved in 2.8.3 for me... I'm using gamin over the inotify kernel interface

With fam (using simple polls) everything works as expected

here's emerge info, but I don't think you can do sth usefull with it... it's from the x86 box:

Portage 2.0.51-r8 (default-linux/x86/2004.3, gcc-3.4.3, glibc-,
 2.6.9-gentoo-r10 i686)
System uname: 2.6.9-gentoo-r10 i686 AMD Athlon(TM) XP 2600+
Gentoo Base System version 1.6.8
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Oct 14 2004, 02:13:12)]
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disable
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.8.5-r2, 1.5, 1.4_p6, 1.6.3, 1.7.9, 1.9.3
sys-devel/libtool:   1.5.10-r2
CFLAGS="-march=athlon-xp -mfpmath=sse,387 -momit-leaf-frame-pointer -O3 -fomit-f
rame-pointer -fprefetch-loop-arrays -fforce-addr -fmerge-all-constants -ftracer 
-funit-at-a-time -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/s
hare/config /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dv
ipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config
/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -mfpmath=sse,387 -momit-leaf-frame-pointer -O3 -fomit
-frame-pointer -fprefetch-loop-arrays -fforce-addr -fmerge-all-constants -ftrace
r -funit-at-a-time -pipe"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS=" http://ftp.belnet.
be/mirror/ http://www.ibiblio.o
USE="3dnow X Xaw3d aac aalib accessibility acpi alsa audiofile avi berkdb bitmap
-fonts bonobo bzlib caps cddb cdr chroot crypt curl devmap dga dnd dv dvd encode
 ethereal expat ext-png ext-zlib f77 faad fam ffmpeg fftw flac flash foomaticdb 
fortran freetype gcj gd gd-external gdbm gif gmp gnome gpm gstreamer gtk gtk2 gt
khtml guile hal imagemagick imap imlib imlib2 jack java javascript jpeg junit la
dcca lcms ldap libg++ libgda libsamplerate libwww live lzw-tiff mad matroska mbo
x md5sum mmap mmx mng monkey motif mozilla moznocompose moznoirc moznomail mozp3
p mpeg mpeg4 mpi mplayer native ncurses nls nocardbus nptl nptlonly objc oggvorb
is openal opengl oss pam parse-clocks pcre pdflib perl pic png pthreads python q
uicktime radeon readline real ruby samba sasl sdl slang sndfile sox speex spell 
sse ssl svg szip t1lib tcltk tcpd tetex theora tiff transcode truetype type1 uni
code usb userlocales vim-with-x wmf wxwindows x86 xgetdefault xinerama xml xml2 
xprint xrandr xv xvid yv12 zlib"
Comment 4 B. Keroack 2004-12-26 11:27:33 UTC
This bug also affects me. FWIW this bug was not present in GNOME 2.8.0 but appeared after upgrading to stable 2.8.1. I'm using gamin with the inotify backend.

Portage 2.0.51-r3 (default-linux/x86/2004.3, gcc-3.4.3, glibc-, 2.6.9-gentoo-r9 i686)
System uname: 2.6.9-gentoo-r9 i686 AMD Athlon(tm) XP 2600+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux26-headers-,sys-kernel/linux26-headers-
Libtools: sys-devel/libtool-1.5.2-r7
CFLAGS="-O3 -march=athlon-xp -mfpmath=sse"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=athlon-xp -mfpmath=sse"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms userpriv usersandbox"
USE="x86 3dnow X aac acl acpi alsa avi berkdb bitmap-fonts cdr crypt cups eds encode faad flac foomaticdb gdbm gif gnome gtk gtk2 hal imagemagick imlib ipv6 jpeg junit libwww mad mikmod mmap motif mozilla mpeg ncurses nptl offensive oggvorbis opengl pam pda pdflib perl png ppds python quicktime readline real sdl slang spell sse ssl svga tcpd tiff truetype xml xml2 xmms xv zlib"
Comment 5 foser (RETIRED) gentoo-dev 2004-12-28 06:55:44 UTC
what i'd like to see is testing with a newer inotify version before further looking into this, this should be in 2.6.10 when it hits the streets.
Comment 6 Sebastian Dröge 2004-12-28 07:51:33 UTC
it's the same with gentoo-dev-sources-2.6.10-r1 (which include the newest inotify version)
Comment 7 foser (RETIRED) gentoo-dev 2005-01-06 04:05:25 UTC
well, then we go to manual labor. run hal in debugging mode, see if it detects the adds & removes of the stick. run gvm in a terminal to see what it picks up and how it handles it.
Comment 8 Andreas Proschofsky (RETIRED) gentoo-dev 2005-01-08 09:17:05 UTC
Can confirm this problem  here with latest gnome / gamin / hal / kernel 2.6.10 + inotify on ~x86

@foser: Everything gets picked up correctly by hal, the device (in this case a memstick) even gets mounted correctly by gnome-volume-manager:

manager.c/711: New Device: /org/freedesktop/Hal/devices/usb_usb_device_5dc_80_1_-1_B228472003050_0
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/usb_usb_device_5dc_80_1_-1_B228472003050_0
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/usb_usb_device_5dc_80_1_-1_B228472003050_0
manager.c/711: New Device: /org/freedesktop/Hal/devices/scsi_host_3
manager.c/711: New Device: /org/freedesktop/Hal/devices/scsi_3_0_0_0
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/scsi_3_0_0_0
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/scsi_3_0_0_0
manager.c/711: New Device: /org/freedesktop/Hal/devices/block_8_0
manager.c/711: New Device: /org/freedesktop/Hal/devices/block_18AF-B893
manager.c/747: Changed: /dev/sda1
manager.c/691: Added: /dev/sda1
manager.c/826: Mounted: /org/freedesktop/Hal/devices/block_18AF-B893

Just the corresponding icon is not displayed, neither on the desktop nor in the computer:/// view. As pointed out in the red hat bug report it works correctly once, but does not if you try again.
Comment 9 Andreas Proschofsky (RETIRED) gentoo-dev 2005-01-08 09:46:18 UTC
Just a bit more of information: After killing the /usr/libexec/gam_server process it works again (for one time).

Also unfortunately gamin-0.0.20 does not seem to solve that problem :(
Comment 10 foser (RETIRED) gentoo-dev 2005-01-08 11:56:23 UTC
i cannot test this here right now I'm afraid. Check and see if it's the original referenced problem where mtab gets updated too fast and doesn't show in gnome-vfs/gamin (you can run gamin in debug mode, check it's docs/homepage).
Comment 11 B. Keroack 2005-03-13 15:48:02 UTC
This bug still exists with GNOME 2.10, gamin 0.0.20 and kernel 2.6.10-gentoo-r6
Comment 12 foser (RETIRED) gentoo-dev 2005-03-14 00:37:29 UTC
'me too's' are not interesting, just CC if you are on of them. Answering my questions is.
Comment 13 foser (RETIRED) gentoo-dev 2005-03-14 01:57:19 UTC
*** Bug 85179 has been marked as a duplicate of this bug. ***
Comment 14 aethyr 2005-03-14 12:38:34 UTC
Based on what I read here:

I changed the ebuild to disable the inotify backend and enable the dnotify backend:
        econf \
                --enable-dnotify \
                --disable-inotify \
                `use_enable debug` \
                `use_enable debug debug-api` \
                || die

Everything works fine now (except media still won't eject when I physically press the eject button on the drive, but I think that's a different bug).
Comment 15 Martin Schlemmer (RETIRED) gentoo-dev 2005-03-15 23:52:57 UTC
Foser, I tried quick to add some g_warnings in places, but it really looks as if /etc/{fstab,mtab} is not monitored (monitors are added, but changes not seen), or I have a illusion about what g_warning do.  I also checked if the monitors added fails, but that is not the case.

I guess we, John (that originally did the inotify backend) or somebody else should really look into updating the backend to use poll as well, like the dnotify one does ... not sure if it will help, but .... ?

For those that still struggle with this issue, this is what I started to do a while back already:

nosferatu gnome-vfs-2.10.0 # cat /etc/udev/rules.d/45-usbfd.rules
BUS="usb", KERNEL="ub[a-z]*", NAME="usbfd%n"
nosferatu gnome-vfs-2.10.0 # grep usbfd /etc/fstab
#/dev/sdd1           /mnt/usbfd      auto        noauto,user         0 0
/dev/usbfd1         /mnt/usbfd      vfat        noauto,user         0 0
nosferatu gnome-vfs-2.10.0 #

Basically I use the ub driver, so any flash I put in gets assigned the /dev/usbfd1 node, and with the static entry in fstab, I can then just click on the drive already added (I dont normally get it to automount, as that is irritating).
Comment 16 Martin Schlemmer (RETIRED) gentoo-dev 2005-03-16 01:11:13 UTC
Urk, forget the last bit I said - used to rename sd? to usbfd when still using the usb-storage driver.
Comment 17 gad.kadosh 2005-03-20 03:02:04 UTC
I have the same problem (gnome-2.10, inotify-0.20, gamin-0.0.26). Is this not caused by the default polling of /mnt and /media? see:
Comment 18 Martin Schlemmer (RETIRED) gentoo-dev 2005-04-03 15:24:05 UTC
Tried it here, but no sigar - anybody else tried it?

$ cat .gaminrc
notify /mnt/* /media/*

Comment 19 Martin Schlemmer (RETIRED) gentoo-dev 2005-04-03 15:26:39 UTC
PS: I can see why it might be an issue - the inotify backend still cannot use polling as well (as the dnotify one can) ...
Comment 20 foser (RETIRED) gentoo-dev 2005-04-04 04:01:32 UTC
My theory still is that it has nothing todo with the polling of /mnt or /media, but that updates to {fs,m}tab do not get noticed by gnome-vfs.
Comment 21 Andreas Proschofsky (RETIRED) gentoo-dev 2005-04-07 05:15:31 UTC
There is a patch in Gnome Bugzilla which solves that problem for me:

This has also been applied upstream now and will be in the next release of gamin
Comment 22 Cyril Jaquier 2005-04-11 15:31:10 UTC
I can confirm that the CVS version (20050412) of Gamin solves this problem :) I'm using Gnome 2.10 and inotify-0.21.
Comment 23 Daniel Drake (RETIRED) gentoo-dev 2005-04-21 15:30:28 UTC
The final patch posted in the gnome bug can't be backported easily. Should we do a CVS snapshot?
Comment 24 Daniel Drake (RETIRED) gentoo-dev 2005-05-09 17:35:48 UTC
Need some testers for the CVS snapshot idea. Please leave feedback at:
Comment 25 Giacomo Perale 2005-05-10 02:21:35 UTC
there are known problems in current gamin CVS, please check this gnome bug:
Comment 26 Didier Link 2005-06-17 23:20:56 UTC
Seem's to work fine in ~amd64 (gnome-2.10) and gamin-0.1.1 released the 10 of
june. Need to be tested on other platforms.

Please update the ebuild tree ?

Comment 27 Daniel Drake (RETIRED) gentoo-dev 2005-06-19 08:36:35 UTC
gamin 0.1.1 is now in portage, and has an inotify fix applied on top of that.
Please post here if issues still exist when running against gentoo-sources-2.6.12
Comment 28 B. Keroack 2005-06-25 20:06:20 UTC
I haven't done stress testing but gamin-0.1.1 plus gentoo-sources-2.6.12-r1
seems to fix the issue so far.
Comment 29 Gen Zhang 2005-07-04 01:37:42 UTC
gamin 0.1.1 and a repatched 2.6.11-r11 gentoo kernel works fine.
Comment 30 Martin Schlemmer (RETIRED) gentoo-dev 2005-07-04 12:57:25 UTC
Can confirm that newer works fine.