Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 738010 - media-libs/libsdl2-2.0.12-r1 - Makefile:417: *** multiple target patterns. Stop.
Summary: media-libs/libsdl2-2.0.12-r1 - Makefile:417: *** multiple target patterns. S...
Status: RESOLVED DUPLICATE of bug 714094
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on: 738228
Blocks: nonbash
  Show dependency tree
 
Reported: 2020-08-19 11:59 UTC by Matthias Coppens
Modified: 2020-09-04 17:43 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info '=media-libs/libsdl2-2.0.12-r1::gentoo' (file_738010.txt,7.38 KB, text/plain)
2020-08-19 11:59 UTC, Matthias Coppens
Details
build.log (build.log,20.92 KB, text/plain)
2020-08-19 12:02 UTC, Matthias Coppens
Details
emerge --info '=media-libs/libsdl2-2.0.12-r1::gentoo' (file_738010.txt,7.38 KB, text/plain)
2020-08-19 12:18 UTC, Matthias Coppens
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Coppens 2020-08-19 11:59:45 UTC
Created attachment 655480 [details]
emerge --info '=media-libs/libsdl2-2.0.12-r1::gentoo'

Compilation fails with:
Makefile:417: *** multiple target patterns.  Stop.
Comment 1 Matthias Coppens 2020-08-19 12:02:13 UTC
Created attachment 655482 [details]
build.log
Comment 2 Sam James archtester gentoo-dev Security 2020-08-19 12:08:49 UTC
>/var/tmp/portage/media-libs/libsdl2-2.0.12-r1/work/SDL2-2.0.12/configure: 1: >/var/tmp/portage/media-libs/libsdl2-2.0.12-r1/work/SDL2-2.0.12/configure: objects: not found

This looks a bit weird.
Comment 3 Sam James archtester gentoo-dev Security 2020-08-19 12:11:07 UTC
Please reproduce with:
* standard CFLAGS (i.e. CFLAGS="-march=native -O2 -pipe")
* >=sys-devel/gcc-9.3.0, as you are currently using 8.4.0-r1
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2020-08-19 12:15:50 UTC
(In reply to Sam James from comment #2)
> >/var/tmp/portage/media-libs/libsdl2-2.0.12-r1/work/SDL2-2.0.12/configure: 1: >/var/tmp/portage/media-libs/libsdl2-2.0.12-r1/work/SDL2-2.0.12/configure: objects: not found
> 
> This looks a bit weird.

Seems to be caused by files/libsdl2-2.0.12-static-libs.patch
Comment 5 Matthias Coppens 2020-08-19 12:18:14 UTC
Created attachment 655484 [details]
emerge --info '=media-libs/libsdl2-2.0.12-r1::gentoo'

I get the same error with the standard CFLAGS and gcc version
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2020-08-19 12:27:13 UTC
sh dash 0.5.10.2-r1

!!!
Comment 7 Matthias Coppens 2020-08-19 12:30:28 UTC
Can confirm it builds with eselect sh set bash.
Comment 8 Ionen Wolkens gentoo-dev 2020-08-19 12:58:51 UTC
Would be a duplicate of bug #714094 that was tracked under bug #714092 dash LINENO tracker instead of the nonbash one.
Comment 9 Ionen Wolkens gentoo-dev 2020-08-19 15:04:58 UTC
Also, as stated in the above bug, this issue "should" (haven't tried) be gone when using dash 0.5.11+ but it still hasn't been stabilized (is there any reason to hold that back?).
Comment 10 Matthias Coppens 2020-08-19 15:09:35 UTC
Can confirm it merges with app-shells/dash-0.5.11.1
Comment 11 Pietro 2020-09-04 17:30:10 UTC
As a workaround I masked libsdl2-2.0.12-r1 until a fix is released. 
>=media-libs/libsdl2-2.0.12-r1
Comment 12 Sam James archtester gentoo-dev Security 2020-09-04 17:43:17 UTC
(In reply to Pietro from comment #11)
> As a workaround I masked libsdl2-2.0.12-r1 until a fix is released. 
> >=media-libs/libsdl2-2.0.12-r1

I'm not sure why -- in fact, this bug should be closed now because the fixed dash version is stabled?
Comment 13 Sam James archtester gentoo-dev Security 2020-09-04 17:43:55 UTC

*** This bug has been marked as a duplicate of bug 714094 ***