Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 73780 - net-analyzer/nessus-plugins-2.3.0 version bump
Summary: net-analyzer/nessus-plugins-2.3.0 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Netmon Herd
URL: http://www.nessus.org
Whiteboard:
Keywords:
: 74455 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-12-08 03:40 UTC by Hanno Böck
Modified: 2005-01-25 13:32 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
root ebuild for nessus 2.2.2.a (nessus-2.2.2a.ebuild,447 bytes, text/plain)
2004-12-19 07:29 UTC, Holger Hoffstätte
Details
ebuild for nessus-core (nessus-core-2.2.2a.ebuild,1.69 KB, text/plain)
2004-12-19 07:29 UTC, Holger Hoffstätte
Details
ebuild for nessus--libs (nessus-libraries-2.2.2a.ebuild,685 bytes, text/plain)
2004-12-19 07:30 UTC, Holger Hoffstätte
Details
ebuild for nessus-plugins (nessus-plugins-2.2.2a.ebuild,738 bytes, text/plain)
2004-12-19 07:30 UTC, Holger Hoffstätte
Details
ebuild for libnasl (libnasl-2.2.2a.ebuild,863 bytes, text/plain)
2004-12-19 07:30 UTC, Holger Hoffstätte
Details
root ebuild for nessus 2.3.0 (nessus-2.3.0.ebuild,447 bytes, text/plain)
2004-12-28 09:38 UTC, Holger Hoffstätte
Details
ebuild for nessus-core (nessus-core-2.3.0.ebuild,1.69 KB, text/plain)
2004-12-28 09:39 UTC, Holger Hoffstätte
Details
ebuild for nessus-libs (nessus-libraries-2.3.0.ebuild,685 bytes, text/plain)
2004-12-28 09:39 UTC, Holger Hoffstätte
Details
ebuild for nessus-plugins (nessus-plugins-2.3.0.ebuild,738 bytes, text/plain)
2004-12-28 09:40 UTC, Holger Hoffstätte
Details
ebuild for libnasl (libnasl-2.3.0.ebuild,863 bytes, text/plain)
2004-12-28 09:40 UTC, Holger Hoffstätte
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hanno Böck gentoo-dev 2004-12-08 03:40:33 UTC
nessus 2.2.1 has been released.
Comment 1 Jared B. 2004-12-09 12:53:06 UTC
This new version will mostly likely require some changes to the ebuilds.  The process for updating plugins and going through some pretty drastic changes.  Details are on the Nessus home page, but it appears to be down right now.  I'll try to post a link directly to it later on when it comes back up.
Comment 2 Daniel Webert 2004-12-09 16:15:47 UTC
jep - nessus-update-plugins 2.2.0 gives this error ...

<snip>
porkoo ~ # nessus-update-plugins 
all-2.0.sig is not the valid signature for all-2.0.tar.gz
Aborting
</snip>
Comment 3 Daniel Webert 2004-12-11 06:32:25 UTC
latest is 2.2.2a
Comment 4 Hanno Böck gentoo-dev 2004-12-15 05:28:58 UTC
*** Bug 74455 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Webert 2004-12-15 07:49:11 UTC
the issue from comment #2 was just temp. - i guess it was in-some-how related to the downtime-problem nessus.org had those days ...
Comment 6 Holger Hoffstätte 2004-12-19 07:28:28 UTC
I just found this bug after creating my own ebuilds for 2.2.2a, so here they are. :)
Comment 7 Holger Hoffstätte 2004-12-19 07:29:21 UTC
Created attachment 46344 [details]
root ebuild for nessus 2.2.2.a
Comment 8 Holger Hoffstätte 2004-12-19 07:29:57 UTC
Created attachment 46345 [details]
ebuild for nessus-core
Comment 9 Holger Hoffstätte 2004-12-19 07:30:16 UTC
Created attachment 46346 [details]
ebuild for nessus--libs
Comment 10 Holger Hoffstätte 2004-12-19 07:30:34 UTC
Created attachment 46347 [details]
ebuild for nessus-plugins
Comment 11 Holger Hoffstätte 2004-12-19 07:30:54 UTC
Created attachment 46348 [details]
ebuild for libnasl
Comment 12 Daniel Webert 2004-12-28 06:58:06 UTC
latest is 2.3.0
Comment 13 Holger Hoffstätte 2004-12-28 09:37:21 UTC
hot out of the oven: updates for 2.3.0. :)
Builds/runs for me both with and without UI, tested on three different installations.
Comment 14 Holger Hoffstätte 2004-12-28 09:38:59 UTC
Created attachment 47035 [details]
root ebuild for nessus 2.3.0
Comment 15 Holger Hoffstätte 2004-12-28 09:39:19 UTC
Created attachment 47036 [details]
ebuild for nessus-core
Comment 16 Holger Hoffstätte 2004-12-28 09:39:45 UTC
Created attachment 47037 [details]
ebuild for nessus-libs
Comment 17 Holger Hoffstätte 2004-12-28 09:40:01 UTC
Created attachment 47038 [details]
ebuild for nessus-plugins
Comment 18 Holger Hoffstätte 2004-12-28 09:40:40 UTC
Created attachment 47039 [details]
ebuild for libnasl
Comment 19 Daniel Black (RETIRED) gentoo-dev 2005-01-09 00:17:01 UTC
looking at this now.
Comment 20 Daniel Black (RETIRED) gentoo-dev 2005-01-12 00:36:57 UTC
all added please test. Bug reports with fixes welcome.
Comment 21 Daniel Webert 2005-01-12 06:59:33 UTC
libnasl-2.3.0 builds nothing ...

<snip>
make[1]: Entering directory `/var/tmp/portage/libnasl-2.3.0/work/libnasl/nasl'
/bin/sh /var/tmp/portage/libnasl-2.3.0/work/libnasl/libtool --silent gcc -pipe -march=pentium4 -O2 -pipe -fomit-frame-pointer -fforce-mem -fforce-addr -falign-functions=4 -fprefetch-loop-arrays  `sh ./cflags`  -c nasl_packet_forgery.c
/bin/sh /var/tmp/portage/libnasl-2.3.0/work/libnasl/libtool --silent gcc -pipe -march=pentium4 -O2 -pipe -fomit-frame-pointer -fforce-mem -fforce-addr -falign-functions=4 -fprefetch-loop-arrays  `sh ./cflags`  -c nasl_socket.c
sh: ./cflags: No such file or directory
sh: ./cflags: No such file or directory
/bin/sh /var/tmp/portage/libnasl-2.3.0/work/libnasl/libtool --silent gcc -pipe -march=pentium4 -O2 -pipe -fomit-frame-pointer -fforce-mem -fforce-addr -falign-functions=4 -fprefetch-loop-arrays  `sh ./cflags`  -c nasl_crypto.c
nasl_packet_forgery.c:19:22: includes.h: No such file or directory
nasl_packet_forgery.c:20:22: nasl_raw.h: No such file or directory
In file included from nasl_packet_forgery.c:23:
nasl_global_ctxt.h:35: error: parse error before "FILE"
nasl_global_ctxt.h:35: warning: no semicolon at end of struct or union
nasl_global_ctxt.h:39: error: parse error before ':' token
nasl_global_ctxt.h:40: error: parse error before ':' token
nasl_global_ctxt.h:41: warning: data definition has no type or storage class
nasl_global_ctxt.h:43: error: parse error before '*' token
nasl_global_ctxt.h:44: error: parse error before '*' token
In file included from nasl_packet_forgery.c:30:
capture_packet.h:33: warning: "struct in_addr" declared inside parameter list
capture_packet.h:33: warning: its scope is only this definition or declaration, which is probably not what you want
capture_packet.h:33: warning: parameter has incomplete type
capture_packet.h:33: warning: parameter has incomplete type
nasl_packet_forgery.c:41: error: parse error before "u_short"
...
...
...
nasl_packet_forgery.c:1408: warning: assignment makes pointer from integer without a cast
nasl_packet_forgery.c:1425: error: storage size of 'then' isn't known
nasl_packet_forgery.c:1425: error: storage size of 'now' isn't known
nasl_packet_forgery.c:1447: error: dereferencing pointer to incomplete type
nasl_packet_forgery.c:1448: warning: assignment makes pointer from integer without a cast
nasl_packet_forgery.c:1450: error: dereferencing pointer to incomplete type
nasl_packet_forgery.c:1394: error: storage size of `errbuf' isn't known
nasl_packet_forgery.c: At top level:
nasl_packet_forgery.c:362: error: storage size of `tcpheader' isn't known
make[1]: *** [nasl_packet_forgery.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/libnasl-2.3.0/work/libnasl/nasl'
make: *** [all] Error 2

!!! ERROR: net-analyzer/libnasl-2.3.0 failed.
!!! Function src_compile, Line 23, Exitcode 2
!!! make failed
!!! If you need support, post the topmost build error, NOT this status message.
</snip>
Comment 22 Andreas Kobara 2005-01-12 07:47:32 UTC
You'll need to set MAKEOPTS=-j1 otherwise ./cflags will be called when directory
already changed.
Comment 23 Daniel Webert 2005-01-12 07:51:48 UTC
the makeopts=-j1 trick does it for problem #21 - plz fix the ebuild ...
Comment 24 Daniel Black (RETIRED) gentoo-dev 2005-01-12 11:07:21 UTC
fixed with -j1 - thanks.
Comment 25 Daniel Webert 2005-01-12 11:14:57 UTC
<snip>
>>> Unpacking nessus-core-2.3.0.tar.gz to /var/tmp/portage/nessus-core-2.3.0/work
>>> Unpacking patch_0.nessus-core.2.0.7 to /var/tmp/portage/nessus-core-2.3.0/work
unpack patch_0.nessus-core.2.0.7: file format not recognized. Ignoring.
 * Applying patch_0.nessus-core.2.0.7 ...
 
 * Failed Patch: patch_0.nessus-core.2.0.7!
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/nessus-core-2.3.0/temp/patch_0.nessus-core.2.0.7-27822.out


!!! ERROR: net-analyzer/nessus-core-2.3.0 failed.
!!! Function epatch, Line 352, Exitcode 0
!!! Failed Patch: patch_0.nessus-core.2.0.7!
!!! If you need support, post the topmost build error, NOT this status message.
</snip>
Comment 26 Holger Hoffstätte 2005-01-12 11:37:44 UTC
The patch_0.nessus-core.2.0.7 file is weird because it seems that it has to be downloaded manually to distfiles. Don't know why; the older ebuilds had the same problem (read: I didn't change anything, AFAIR).
Comment 27 Daniel Black (RETIRED) gentoo-dev 2005-01-12 16:09:27 UTC
Daniel,  Holger

see bug #77710 and continue there for more prelude patch discussions.

Holger - its not a download issue its just the patch isn't compatible with the new version of nessus-core.
Comment 28 ChazeFroy 2005-01-12 19:16:36 UTC
Please also include ebuilds for 2.2.2a in portage, since 2.2.2a is the latest stable version. 2.3.0 is the development branch.

2.2.0 is currently the latest stable version available in portage, but does not come with the "nessus-fetch" command to grab the latest 7-day-old plugins. The 2.2.0 in portage, by default, will only grab the GPL plugins with "nessus-update-plugins", not all of them.
Comment 29 Daniel Black (RETIRED) gentoo-dev 2005-01-12 20:06:27 UTC
ChazeFroy - ok.
Comment 30 Jared B. 2005-01-25 13:32:55 UTC
I'd like to second ChazeFroy's request to add Nessus 2.2.2a back into portage.  2.3.0 is similar to the 2.1.x branch - highly experimental and not meant for production use.  The 2.2.x branch should continue to be updated, at least until version 2.4.0 is released (as 2.0.x has been, since 2.0.12 is still available in portage).

Also, again as ChazeFroy pointed out, all stable nessus packages in Gentoo are now officially broken, since the nessus-fetch command is not available.