Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 730700 - dev-util/csup fails to compile
Summary: dev-util/csup fails to compile
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
: 738946 (view as bug list)
Depends on:
Blocks: LD-is-lld
  Show dependency tree
 
Reported: 2020-07-04 10:15 UTC by Agostino Sarubbo
Modified: 2020-08-30 22:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,20.43 KB, text/plain)
2020-07-04 10:16 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-07-04 10:15:28 UTC
@@This is an auto-filed bug@@
Feel free to change the summary at your convenience.

Issue: dev-util/csup fails to compile.
Discovered on: amd64

NOTE:
This machine uses a clang/LLVM toolchain.
If you think that this issue is strictly related to clang/LLVM please mention it in the summary and block bug 408963. If you need further logs, feel free to ask.
Comment 1 Agostino Sarubbo gentoo-dev 2020-07-04 10:16:00 UTC
Created attachment 647570 [details]
build.log

build log and emerge --info
Comment 2 David Seifert gentoo-dev 2020-08-30 22:22:37 UTC
*** Bug 738946 has been marked as a duplicate of this bug. ***
Comment 3 Larry the Git Cow gentoo-dev 2020-08-30 22:25:39 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=227c43f85e2ae65102e1e1dc79dd97e51815a9dd

commit 227c43f85e2ae65102e1e1dc79dd97e51815a9dd
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2020-08-30 22:25:25 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2020-08-30 22:25:25 +0000

    dev-util/csup: Port to EAPI 7
    
    Closes: https://bugs.gentoo.org/730700
    Package-Manager: Portage-3.0.4, Repoman-3.0.1
    Signed-off-by: David Seifert <soap@gentoo.org>

 dev-util/csup/csup-20060318-r1.ebuild              | 23 +++++--------
 .../csup/files/csup-20060318-respectflags.patch    | 38 +++++++++++++---------
 2 files changed, 32 insertions(+), 29 deletions(-)