Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 728870 - x11-libs/libva-2.7.1 stablereq
Summary: x11-libs/libva-2.7.1 stablereq
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Alexis Ballier
URL: https://github.com/intel/libva/issues...
Whiteboard:
Keywords: CC-ARCHES
: 733514 (view as bug list)
Depends on:
Blocks: 733504
  Show dependency tree
 
Reported: 2020-06-20 08:35 UTC by Alexander Tsoy
Modified: 2020-10-01 11:09 UTC (History)
4 users (show)

See Also:
Package list:
x11-libs/libva-2.7.1
Runtime testing required: ---
nattka: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Tsoy 2020-06-20 08:35:08 UTC
x11-libs/libva-2.7.1 contains a fix for the intel iris driver, which when enabled in mesa is used by default on gen8+ hardware. So would be nice to stabilize this version.

<2.7.1:

$ vainfo 
libva info: VA-API version 1.5.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/va/drivers/iris_drv_video.so
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

2.7.1:

$ vainfo 
libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib64/va/drivers/iHD_drv_video.so
libva info: va_openDriver() returns -1
libva info: Trying to open /usr/lib64/va/drivers/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_5
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.7 (libva 2.5.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Coffee Lake - 2.3.0
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Simple            :	VAEntrypointEncSlice
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSliceLP
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointEncSlice
      VAProfileH264Main               :	VAEntrypointEncSliceLP
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointEncSlice
      VAProfileH264High               :	VAEntrypointEncSliceLP
      VAProfileH264MultiviewHigh      :	VAEntrypointVLD
      VAProfileH264MultiviewHigh      :	VAEntrypointEncSlice
      VAProfileH264StereoHigh         :	VAEntrypointVLD
      VAProfileH264StereoHigh         :	VAEntrypointEncSlice
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD
      VAProfileNone                   :	VAEntrypointVideoProc
      VAProfileJPEGBaseline           :	VAEntrypointVLD
      VAProfileJPEGBaseline           :	VAEntrypointEncPicture
      VAProfileVP8Version0_3          :	VAEntrypointVLD
      VAProfileVP8Version0_3          :	VAEntrypointEncSlice
      VAProfileHEVCMain               :	VAEntrypointVLD
      VAProfileHEVCMain               :	VAEntrypointEncSlice
      VAProfileHEVCMain10             :	VAEntrypointVLD
      VAProfileHEVCMain10             :	VAEntrypointEncSlice
      VAProfileVP9Profile0            :	VAEntrypointVLD
      VAProfileVP9Profile0            :	VAEntrypointEncSlice
      VAProfileVP9Profile2            :	VAEntrypointVLD
Comment 1 Alexander Tsoy 2020-06-21 17:17:48 UTC
CCing Lars as he was doing most of the work on this package recently.
Comment 2 Sam James archtester gentoo-dev Security 2020-07-30 02:25:04 UTC
ping
Comment 3 Pacho Ramos gentoo-dev 2020-07-30 18:58:27 UTC
*** Bug 733514 has been marked as a duplicate of this bug. ***
Comment 4 Sam James archtester gentoo-dev Security 2020-08-17 05:54:54 UTC
Will CC-ARCHES if no objections?
Comment 5 Agostino Sarubbo gentoo-dev 2020-09-24 06:47:14 UTC
amd64 stable
Comment 6 Agostino Sarubbo gentoo-dev 2020-09-24 07:00:39 UTC
x86 stable
Comment 7 Sam James archtester gentoo-dev Security 2020-10-01 11:09:42 UTC
arm64 done

all arches done