Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 727504 - dev-java/fop-2.7: stable request (was: dev-java/fop-2.7 version bump)
Summary: dev-java/fop-2.7: stable request (was: dev-java/fop-2.7 version bump)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords: CC-ARCHES, STABLEREQ
Depends on: 710208 832751
Blocks: 784839 834482 836135
  Show dependency tree
 
Reported: 2020-06-08 06:58 UTC by Einstok Fair
Modified: 2022-05-07 17:54 UTC (History)
2 users (show)

See Also:
Package list:
dev-java/fop-2.7 amd64 ppc64 x86
Runtime testing required: ---
nattka: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Einstok Fair 2020-06-08 06:58:06 UTC
new version of utility was released:
http://archive.apache.org/dist/xmlgraphics/fop/source/fop-2.5-src.zip

current gentoo tree contains only
fop-2.0-r3
Comment 1 Larry the Git Cow gentoo-dev 2022-04-04 07:31:43 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=55f3ec5078e3d85b0cce92b424b9202dd6a9b580

commit 55f3ec5078e3d85b0cce92b424b9202dd6a9b580
Author:     Volkmar W. Pogatzki <gentoo@pogatzki.net>
AuthorDate: 2022-03-29 23:14:39 +0000
Commit:     Florian Schmaus <flow@gentoo.org>
CommitDate: 2022-04-04 07:31:38 +0000

    dev-java/fop: Bump to 2.7
    
    Tests for mudule fop-core need a newer mockito version
    (see comment in the ebuild), skipped for now.
    
    Closes: https://bugs.gentoo.org/727504
    Package-Manager: Portage-3.0.30, Repoman-3.0.3
    Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net>
    Signed-off-by: Florian Schmaus <flow@gentoo.org>

 dev-java/fop/Manifest                            |   1 +
 dev-java/fop/files/fop-2.7-core-event-models.jar | Bin 0 -> 8835 bytes
 dev-java/fop/files/fop-2.7-test-event-model.jar  | Bin 0 -> 428 bytes
 dev-java/fop/fop-2.7.ebuild                      | 154 +++++++++++++++++++++++
 dev-java/fop/metadata.xml                        |  12 +-
 5 files changed, 163 insertions(+), 4 deletions(-)
Comment 2 Volkmar W. Pogatzki 2022-04-04 07:57:22 UTC
Reuse this bug for stabilization.
Comment 3 NATTkA bot gentoo-dev 2022-04-04 08:01:05 UTC Comment hidden (obsolete)
Comment 4 NATTkA bot gentoo-dev 2022-04-10 20:41:49 UTC Comment hidden (obsolete)
Comment 5 NATTkA bot gentoo-dev 2022-04-11 05:00:38 UTC Comment hidden (obsolete)
Comment 6 NATTkA bot gentoo-dev 2022-04-15 18:45:03 UTC Comment hidden (obsolete)
Comment 7 NATTkA bot gentoo-dev 2022-04-15 21:32:38 UTC Comment hidden (obsolete)
Comment 8 Volkmar W. Pogatzki 2022-04-16 05:27:19 UTC
*** Bug 838685 has been marked as a duplicate of this bug. ***
Comment 9 NATTkA bot gentoo-dev 2022-05-03 10:12:33 UTC Comment hidden (obsolete)
Comment 10 Larry the Git Cow gentoo-dev 2022-05-05 14:29:00 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e6e96ae5a6cc60f87906f6d9c2a868bcac20b920

commit e6e96ae5a6cc60f87906f6d9c2a868bcac20b920
Author:     Volkmar W. Pogatzki <gentoo@pogatzki.net>
AuthorDate: 2022-05-03 09:39:35 +0000
Commit:     Florian Schmaus <flow@gentoo.org>
CommitDate: 2022-05-05 14:28:55 +0000

    profiles/base: stable.use.mask dev-java/fop[test]
    
    Bug: https://bugs.gentoo.org/727504
    Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net>
    Closes: https://github.com/gentoo/gentoo/pull/25299
    Signed-off-by: Florian Schmaus <flow@gentoo.org>

 profiles/base/package.use.stable.mask | 5 +++++
 1 file changed, 5 insertions(+)
Comment 11 Jakov Smolić archtester gentoo-dev 2022-05-06 09:23:14 UTC
amd64 done
Comment 12 Jakov Smolić archtester gentoo-dev 2022-05-06 09:23:17 UTC
x86 done
Comment 13 Arthur Zamarin archtester gentoo-dev 2022-05-07 17:54:06 UTC
ppc64 done

all arches done