Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 724160 - dev-util/bloaty does not respect CFLAGS/LDFLAGS
Summary: dev-util/bloaty does not respect CFLAGS/LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: qa-cflags ldflags
  Show dependency tree
 
Reported: 2020-05-19 21:06 UTC by Agostino Sarubbo
Modified: 2020-07-05 08:24 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,9.42 KB, text/plain)
2020-05-19 21:07 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-19 21:06:57 UTC
This is an auto-filed bug because dev-util/bloaty does not respect CFLAGS/LDFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -frecord-gcc-switches" and LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ context you may want to set also FFLAGS and FCFLAGS or just see this bug as an hint to hide the QA warning where is not possible to respect CFLAGS/LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-19 21:07:05 UTC
Created attachment 640432 [details]
build.log

build log and emerge --info
Comment 2 ngg 2020-05-24 13:13:20 UTC
I've created a PR https://github.com/gentoo/gentoo/pull/15944 in which I bumped the version to 1.1, also added a live ebuild and added myself as proxy maintainer.
I checked that the new ebuilds respect CXXFLAGS/LDFLAGS (there are no C source files, so CFLAGS seems to be irrelevant).
Comment 3 Larry the Git Cow gentoo-dev 2020-07-05 08:24:32 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4e7de51a73307c3c473bbc445eabd5b08770d320

commit 4e7de51a73307c3c473bbc445eabd5b08770d320
Author:     Gergely Nagy <ngg@ngg.hu>
AuthorDate: 2020-05-24 10:45:23 +0000
Commit:     Joonas Niilola <juippis@gentoo.org>
CommitDate: 2020-07-05 08:24:15 +0000

    dev-util/bloaty: bump version to 1.1
    
    Closes: https://bugs.gentoo.org/717124
    Closes: https://bugs.gentoo.org/724160
    Signed-off-by: Gergely Nagy <ngg@ngg.hu>
    Signed-off-by: Joonas Niilola <juippis@gentoo.org>

 dev-util/bloaty/Manifest          |  1 +
 dev-util/bloaty/bloaty-1.1.ebuild | 45 +++++++++++++++++++++++++++++++++++++++
 2 files changed, 46 insertions(+)