Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722762 - dev-python/docutils-0.16 still supports Python 2.7 but it's dependency dev-python/pygments-2.6.1 doesn't -- dependency conflict
Summary: dev-python/docutils-0.16 still supports Python 2.7 but it's dependency dev-py...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
: 729372 (view as bug list)
Depends on: 708338 712122 729618 730060
Blocks:
  Show dependency tree
 
Reported: 2020-05-12 20:00 UTC by Simon
Modified: 2020-08-09 10:57 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon 2020-05-12 20:00:04 UTC
After the stabilization of dev-python/pygments-2.6.1 (see bug 720558) we have a dependency conflict because the stable version of docutils (dev-python/docutils-0.16:0/0::gentoo) which depends on dev-python/pygments still supports Python 2.7 but pygments doesn't.

I guess the proper way forward would be to drop Python 2.7 support from docutils?

Reproducible: Always
Comment 1 mercuriete 2020-05-26 01:34:42 UTC
I have the same problem

please change the status from UNCONFIRMED to CONFIRMED

:)

thanks for your work
Comment 2 mercuriete 2020-05-26 01:38:25 UTC
I could fixed it adding this line to package.use


dev-python/docutils PYTHON_TARGETS: -python2_7 python3_6 python3_7
Comment 3 Joe Breuer 2020-05-26 20:11:12 UTC
I ran into the same problem. A slightly simplified version of mercuriete's fix worked for me:

dev-python/docutils PYTHON_TARGETS: -python2_7

in a suitable package.use file
Comment 4 tt_1 2020-06-28 11:24:30 UTC
>=sys-devel/llvm-10.0.1_rc1 is going to pull in that combination, propably giving everyone a headache as soon as llvm-10 hits stable
Comment 5 Valmor de Almeida 2020-07-04 16:58:47 UTC
I added the line:

dev-python/docutils PYTHON_TARGETS: -python2_7

to /etc/portage/package.use/docutils

and I still have the same warning:

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-python/pygments:0

  (dev-python/pygments-2.6.1:0/0::gentoo, ebuild scheduled for merge) USE="-doc -test" ABI_X86="(64)" PYTHON_TARGETS="python3_7 (-pypy3) -python3_6 (-python3_8) (-python3_9)" conflicts with
    dev-python/pygments[python_targets_python2_7(-),python_targets_python3_7(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/docutils-0.16:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_7 (-pypy3) -python3_6 (-python3_8) (-python3_9)"

note:

gentoo-xps ~ # equery uses docutils
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for dev-python/docutils-0.16:
 U I
 - + python_targets_python2_7 : Build with Python 2.7
 - - python_targets_python3_6 : Build with Python 3.6
 + + python_targets_python3_7 : Build with Python 3.7
Comment 6 Andreas Sturmlechner gentoo-dev 2020-07-04 20:20:46 UTC
This is not really a bug. Portage is merely informing you why it is skipping this update.
Comment 7 Simon 2020-07-04 21:39:43 UTC
(In reply to Andreas Sturmlechner from comment #6)
> This is not really a bug. Portage is merely informing you why it is skipping
> this update.

Isn't it a bug when the default config (which still has Python 2.7 in PYTHON_TARGETS) caused a dependency conflict for stable packages?
Comment 8 Andreas Sturmlechner gentoo-dev 2020-07-05 18:23:44 UTC
It might be an inconvenience for not being able to get the latest version, but it is no blocker.
Comment 9 Thomas De Schampheleire 2020-07-14 18:56:26 UTC
As a result of the workaround in comment 3 which disables python 2.7 for docutils, this ripples through to other packages that depend on docutils and may cause problems on world updates. In such case, portage will complain and suggest:

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-python/m2r-0.2.1::gentoo[-test]
# required by dev-python/automat-20.2.0::gentoo
# required by dev-python/twisted-20.3.0::gentoo
# required by www-servers/tornado-6.0.4::gentoo
# required by dev-python/matplotlib-3.2.1::gentoo[-test]
# required by @selected
# required by @world (argument)
>=dev-python/docutils-0.16 python_targets_python2_7


I had to extend the workaround to m2r and automat to solve this issue:

dev-python/docutils PYTHON_TARGETS: -python2_7
dev-python/automat  PYTHON_TARGETS: -python2_7
dev-python/m2r      PYTHON_TARGETS: -python2_7


Other people may experience the same problem where package X depends on docutils (possibly via an intermediate dependency chain Y -> Z -> docutils) and they will have to find out which of the packages in the mentioned chain still try to build against Python 2.7, then disable it similarly as above.
Comment 10 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-07-20 05:41:09 UTC
I'm sorry about this but this is an inevitable problem with supporting Python 2.  I'm slowly working towards removing dev-python/sphinx py2 revdeps (bug #730060), and once that's done I'll focus on dev-python/docutils.
Comment 11 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-08-09 05:24:33 UTC
The only real blocker here is trac -- I don't think we can remove docutils from it without harming some of the installations.  Ofc, the generic question is how many people are actually still using this whole webapps infra rather than virtualenv or docker.
Comment 12 Andreas Sturmlechner gentoo-dev 2020-08-09 08:46:27 UTC
Empty docutils revbump w/o py27 to push down the skipped update to users of those slacker packages?
Comment 13 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-08-09 09:01:42 UTC
I suppose that could work.
Comment 14 Larry the Git Cow gentoo-dev 2020-08-09 09:02:44 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=458b1724bf54155f49ee4a729a30a2904109efd0

commit 458b1724bf54155f49ee4a729a30a2904109efd0
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: 2020-08-09 09:02:16 +0000
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: 2020-08-09 09:02:39 +0000

    dev-python/docutils: Revbump to drop py2.7
    
    Closes: https://bugs.gentoo.org/722762
    Signed-off-by: Michał Górny <mgorny@gentoo.org>

 dev-python/docutils/docutils-0.16-r1.ebuild | 72 +++++++++++++++++++++++++++++
 1 file changed, 72 insertions(+)
Comment 15 tt_1 2020-08-09 10:57:03 UTC
*** Bug 729372 has been marked as a duplicate of this bug. ***