Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722292 - dev-java/icedtea-3.16.0 fails to build without bash as /bin/sh (PATCH)
Summary: dev-java/icedtea-3.16.0 fails to build without bash as /bin/sh (PATCH)
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Andrew John Hughes
URL: https://icedtea.classpath.org/bugzill...
Whiteboard:
Keywords: PATCH, UPSTREAM
: 722536 (view as bug list)
Depends on:
Blocks: nonbash
  Show dependency tree
 
Reported: 2020-05-10 23:33 UTC by Kerin Millar
Modified: 2021-01-08 02:41 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
icedtea-3.16.0-acinclude-posix-conformance.patch (icedtea-3.16.0-acinclude-posix-conformance.patch,1.29 KB, patch)
2020-05-10 23:33 UTC, Kerin Millar
Details | Diff
patch to change Bash pattern substition in Makefile to POSIX-sh-compatible way (icedtea-3.16.0-makefile_00_posix_sh_pattern_substitution.patch,934 bytes, patch)
2020-05-17 20:31 UTC, Nico R.
Details | Diff
expands brace expansion (Bashism) in Makefile to allow installation with non-bash POSIX sh (icedtea-3.16.0-makefile_01_posix_sh_brace_expansion.patch,2.20 KB, patch)
2020-05-17 20:32 UTC, Nico R.
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kerin Millar 2020-05-10 23:33:24 UTC
Created attachment 637816 [details, diff]
icedtea-3.16.0-acinclude-posix-conformance.patch

Alexander Tsoy reports in bug 526200 that icedtea-3.16.0 fails to build unless /bin/sh links to bash. Attached is a patch that should resolve the issue. A revised ebuild will be temporarily available at https://bitbucket.org/kerframil/portage-overlay/src/master/dev-java/icedtea/. The originally given error message was as follows, implying that it was tested with dash as /bin/sh.

checking if there is a ccache gcc wrapper on the PATH... ./configure: 12319: ./configure: Syntax error: redirection unexpected
Comment 1 Sam James archtester gentoo-dev Security 2020-05-10 23:38:37 UTC
(In reply to Kerin Millar from comment #0)
> Created attachment 637816 [details, diff] [details, diff]
> icedtea-3.16.0-acinclude-posix-conformance.patch
> 
> Alexander Tsoy reports in bug 526200 that icedtea-3.16.0 fails to build
> unless /bin/sh links to bash. Attached is a patch that should resolve the
> issue. A revised ebuild will be temporarily available at
> https://bitbucket.org/kerframil/portage-overlay/src/master/dev-java/icedtea/.
> The originally given error message was as follows, implying that it was
> tested with dash as /bin/sh.
> 
> checking if there is a ccache gcc wrapper on the PATH... ./configure: 12319:
> ./configure: Syntax error: redirection unexpected

Could you repost the patch over there?

*** This bug has been marked as a duplicate of bug 526200 ***
Comment 2 Kerin Millar 2020-05-10 23:42:15 UTC
This is not a duplicate. The other bug concerned a different issue in a version of icedtea that is no longer carried by Gentoo and, as such, should be closed as WONTFIX. The only thing that they had in common was they they both blocked "nonbash". I don't think that is a valid reason to refrain from opening a new bug.
Comment 3 Kerin Millar 2020-05-10 23:44:01 UTC
Apologies, Sam. Apparently I'm going blind and got it mixed up with a different bug entirely. I shall do as requested.
Comment 4 Kerin Millar 2020-05-10 23:45:08 UTC
Ah, I'm not going blind. You changed the issue title. In that case, I stand by my previous post.
Comment 5 Sam James archtester gentoo-dev Security 2020-05-10 23:47:16 UTC
(In reply to Kerin Millar from comment #3)
> Apologies, Sam. Apparently I'm going blind and got it mixed up with a
> different bug entirely. I shall do as requested.

I did just rename the bug, so maybe that was it. I just figured keep the information in the same one.

Anyway, sorry for the confusion, and thank you for the patch.
Comment 6 Kerin Millar 2020-05-12 09:07:15 UTC
*** Bug 722536 has been marked as a duplicate of this bug. ***
Comment 7 Nico R. 2020-05-17 20:31:34 UTC
Created attachment 639886 [details, diff]
patch to change Bash pattern substition in Makefile to POSIX-sh-compatible way

I also need this patch to build with /bin/sh -> dash.

I have not submitted it upstream; do so if you like. My modifications are licensed under the same license(s) as the original code, of course.
Comment 8 Nico R. 2020-05-17 20:32:56 UTC
Created attachment 639888 [details, diff]
expands brace expansion (Bashism) in Makefile to allow installation with non-bash POSIX sh

And I also need this patch to build with /bin/sh -> dash.

I have not submitted it upstream; do so if you like. My modifications are licensed under the same license(s) as the original code, of course.
Comment 9 Kerin Millar 2020-05-18 00:27:45 UTC
Good find, Nico. The name of my patch is a misnomer as there are various other POSIX violations, such as the use of readlink. Still, weeding out the bashisms is the more important thing for Gentoo.
Comment 10 Matt Whitlock 2020-05-19 05:10:03 UTC
I confirm that applying the three attached patches (plus adding "inherit autotools" and "src_prepare() { eautoreconf }" to the ebuild) allow dev-java/icedtea-3.16.0 to configure without error on my ~amd64 system, which has Dash as /bin/sh.
Comment 11 Lars Wendler (Polynomial-C) gentoo-dev 2020-11-02 15:20:31 UTC
Still happening with latest icedtea in portage. Can we have this finally fixed please?
Comment 12 Larry the Git Cow gentoo-dev 2020-11-02 19:28:20 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0f3df0a7b04dcb6f44632e872fdd252c7fe6bb25

commit 0f3df0a7b04dcb6f44632e872fdd252c7fe6bb25
Author:     Georgy Yakovlev <gyakovlev@gentoo.org>
AuthorDate: 2020-11-02 19:27:21 +0000
Commit:     Georgy Yakovlev <gyakovlev@gentoo.org>
CommitDate: 2020-11-02 19:27:21 +0000

    dev-java/icedtea: force bash for ./configure
    
    Bug: https://bugs.gentoo.org/722292
    Package-Manager: Portage-3.0.9, Repoman-3.0.2
    Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>

 dev-java/icedtea/icedtea-3.17.0.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 13 Georgy Yakovlev gentoo-dev 2020-11-02 19:28:56 UTC
I've added a workaround for now to use bash. After patch is upstreamed we can remove it.
Comment 14 Kerin Millar 2021-01-08 02:41:12 UTC
Reported upstream: https://icedtea.classpath.org/bugzilla/show_bug.cgi?id=3817.