Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721266 - games-emulation/advancemame-3.9 : /.../ld: error: obj/.../misc.a(cavepgm.o): multiple definition of pgm_mainram
Summary: games-emulation/advancemame-3.9 : /.../ld: error: obj/.../misc.a(cavepgm.o): ...
Status: RESOLVED DUPLICATE of bug 706924
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-06 14:08 UTC by Toralf Förster
Modified: 2020-05-21 12:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.54 KB, text/plain)
2020-05-06 14:08 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,136.75 KB, text/plain)
2020-05-06 14:08 UTC, Toralf Förster
Details
environment (environment,79.99 KB, text/plain)
2020-05-06 14:08 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.05 KB, application/x-bzip)
2020-05-06 14:08 UTC, Toralf Förster
Details
games-emulation:advancemame-3.9:20200506-132056.log.bz2 (games-emulation:advancemame-3.9:20200506-132056.log.bz2,61.57 KB, application/x-bzip)
2020-05-06 14:08 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,9.18 KB, application/x-bzip)
2020-05-06 14:08 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,82.27 KB, application/x-bzip)
2020-05-06 14:08 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-06 14:08:25 UTC
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: obj/mame/linux/blend/misc.a(cavepgm.o): multiple definition of pgm_mainram
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: obj/mame/linux/blend/igs.a(pgm.o): previous definition here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: obj/mame/linux/blend/misc.a(cavepgm.o): multiple definition of pgm_bg_videoram
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: obj/mame/linux/blend/igs.a(pgm.o): previous definition here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
clang version 10.0.0 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python3.8 (fallback)
  [3]   python2.7 (fallback)
  [4]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.252_p09 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Wed 06 May 2020 12:38:55 PM UTC

emerge -qpvO games-emulation/advancemame
[ebuild  N    ] games-emulation/advancemame-3.9  USE="alsa ncurses -fbcon -oss -slang -truetype"
Comment 1 Toralf Förster gentoo-dev 2020-05-06 14:08:28 UTC
Created attachment 636450 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-06 14:08:32 UTC
Created attachment 636452 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-06 14:08:35 UTC
Created attachment 636454 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-06 14:08:38 UTC
Created attachment 636456 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-06 14:08:41 UTC
Created attachment 636458 [details]
games-emulation:advancemame-3.9:20200506-132056.log.bz2
Comment 6 Toralf Förster gentoo-dev 2020-05-06 14:08:43 UTC
Created attachment 636460 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2020-05-06 14:08:46 UTC
Created attachment 636462 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-05-21 12:06:13 UTC

*** This bug has been marked as a duplicate of bug 706924 ***