Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 706924 - games-emulation/advancemame-3.7 : fails to build with -fno-common or gcc-10
Summary: games-emulation/advancemame-3.7 : fails to build with -fno-common or gcc-10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords: PATCH
: 721266 (view as bug list)
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-01-28 18:40 UTC by Toralf Förster
Modified: 2020-11-21 20:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.26 KB, text/plain)
2020-01-28 18:40 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,84.49 KB, text/plain)
2020-01-28 18:40 UTC, Toralf Förster
Details
environment (environment,101.73 KB, text/plain)
2020-01-28 18:40 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.53 KB, application/x-bzip)
2020-01-28 18:40 UTC, Toralf Förster
Details
games-emulation:advancemame-3.7:20200128-104846.log.bz2 (games-emulation:advancemame-3.7:20200128-104846.log.bz2,61.88 KB, application/x-bzip)
2020-01-28 18:40 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,8.77 KB, application/x-bzip)
2020-01-28 18:40 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,86.84 KB, application/x-bzip)
2020-01-28 18:40 UTC, Toralf Förster
Details
build.log.xz (3.9, amd64) (advancemame-3.9:20201023-150732.log.xz,66.55 KB, text/plain)
2020-10-23 15:24 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-01-28 18:40:23 UTC
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: obj/mame/linux/blend/misc.a(cavepgm.o):(.bss+0x450): multiple definition of `pgm_mainram'; obj/mame/linux/blend/igs.a(pgm.o):(.bss+0x48): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: obj/mame/linux/blend/misc.a(cavepgm.o):(.bss+0x448): multiple definition of `pgm_bg_videoram'; obj/mame/linux/blend/igs.a(pgm.o):(.bss+0x40): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_systemd-20200126-201521

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

clang:
clang version 9.0.1 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/9/bin
llvm:
9.0.1
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.6
  [3]   python3.7 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.40.0 *
java-config:
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.242_p08 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Tue, 28 Jan 2020 10:06:28 +0000

emerge -qpvO games-emulation/advancemame
[ebuild  N    ] games-emulation/advancemame-3.7  USE="-alsa -fbcon -oss -truetype"
Comment 1 Toralf Förster gentoo-dev 2020-01-28 18:40:26 UTC
Created attachment 606604 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-01-28 18:40:29 UTC
Created attachment 606606 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-01-28 18:40:32 UTC
Created attachment 606608 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-01-28 18:40:34 UTC
Created attachment 606610 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-01-28 18:40:37 UTC
Created attachment 606612 [details]
games-emulation:advancemame-3.7:20200128-104846.log.bz2
Comment 6 Toralf Förster gentoo-dev 2020-01-28 18:40:40 UTC
Created attachment 606614 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2020-01-28 18:40:43 UTC
Created attachment 606616 [details]
temp.tbz2
Comment 8 Jeroen Roovers (RETIRED) gentoo-dev 2020-05-21 12:06:13 UTC
*** Bug 721266 has been marked as a duplicate of this bug. ***
Comment 9 Kobboi 2020-08-30 11:58:39 UTC
Still present in 3.9
Comment 10 ernsteiswuerfel 2020-10-23 15:24:08 UTC
Created attachment 668153 [details]
build.log.xz (3.9, amd64)

Same here with 3.9.
Comment 11 ernsteiswuerfel 2020-10-23 16:04:58 UTC
Took it upstream to: https://sourceforge.net/p/advancemame/bugs/287/

There is also a git repository (https://github.com/amadvance/advancemame) but without an issue tracker. Building from current git master also leads to the same build errors on my amd64 box.
Comment 12 ernsteiswuerfel 2020-10-23 19:59:25 UTC
The issue got fixed now with this upstream commit:
https://github.com/amadvance/advancemame/commit/f8688cae05799a30cd5337e626a07fa9f004c0a3

Applies as is to 3.9 in the portage tree when put in /etc/portage/patches/games-emulation/advancemame.
Comment 13 Larry the Git Cow gentoo-dev 2020-11-21 20:39:00 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5615d9ee802541a4d6d1e6ffe77dddc4550806ac

commit 5615d9ee802541a4d6d1e6ffe77dddc4550806ac
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2020-11-21 20:38:07 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2020-11-21 20:38:07 +0000

    games-emulation/advancemame: Add upstream patch for -fno-common
    
    Closes: https://bugs.gentoo.org/706924
    Package-Manager: Portage-3.0.9, Repoman-3.0.2
    Signed-off-by: David Seifert <soap@gentoo.org>

 games-emulation/advancemame/advancemame-3.9.ebuild |  1 +
 .../files/advancemame-3.9-fno-common.patch         | 33 ++++++++++++++++++++++
 2 files changed, 34 insertions(+)