Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721182 - dev-libs/libratbag-0.9 : /.../ld: error: libhidpp.a(src_hidpp-generic.c.o): multiple definition of gskill_driver
Summary: dev-libs/libratbag-0.9 : /.../ld: error: libhidpp.a(src_hidpp-generic.c.o): m...
Status: RESOLVED DUPLICATE of bug 707440
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-06 07:32 UTC by Toralf Förster
Modified: 2020-05-15 08:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.53 KB, text/plain)
2020-05-06 07:32 UTC, Toralf Förster
Details
dev-libs:libratbag-0.9:20200506-053547.log (dev-libs:libratbag-0.9:20200506-053547.log,10.98 KB, text/plain)
2020-05-06 07:32 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,117.44 KB, text/plain)
2020-05-06 07:32 UTC, Toralf Förster
Details
environment (environment,90.68 KB, text/plain)
2020-05-06 07:32 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.98 KB, application/x-bzip)
2020-05-06 07:32 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,22.57 KB, application/x-bzip)
2020-05-06 07:32 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-06 07:32:23 UTC
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: libhidpp.a(src_hidpp-generic.c.o): multiple definition of gskill_driver
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: libutil.a(src_libratbag-util.c.o): previous definition here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: libhidpp.a(src_hidpp-generic.c.o): multiple definition of roccat_driver
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: libutil.a(src_libratbag-util.c.o): previous definition here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
clang version 10.0.0 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python3.8 (fallback)
  [3]   python2.7 (fallback)
  [4]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.252_p09 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Wed 06 May 2020 03:38:52 AM UTC

emerge -qpvO dev-libs/libratbag
[ebuild  N    ] dev-libs/libratbag-0.9  USE="-doc -test"
Comment 1 Toralf Förster gentoo-dev 2020-05-06 07:32:26 UTC
Created attachment 636356 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-06 07:32:29 UTC
Created attachment 636358 [details]
dev-libs:libratbag-0.9:20200506-053547.log
Comment 3 Toralf Förster gentoo-dev 2020-05-06 07:32:32 UTC
Created attachment 636360 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2020-05-06 07:32:36 UTC
Created attachment 636362 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2020-05-06 07:32:39 UTC
Created attachment 636364 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-05-06 07:32:43 UTC
Created attachment 636366 [details]
temp.tbz2
Comment 7 Jeroen Roovers gentoo-dev 2020-05-15 08:02:04 UTC

*** This bug has been marked as a duplicate of bug 707440 ***