Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 707440 - dev-libs/libratbag-0.9 : fails to build with -fno-common or gcc-10
Summary: dev-libs/libratbag-0.9 : fails to build with -fno-common or gcc-10
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
: 721182 (view as bug list)
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-01-30 19:14 UTC by Toralf Förster
Modified: 2020-05-15 08:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.52 KB, text/plain)
2020-01-30 19:14 UTC, Toralf Förster
Details
dev-libs:libratbag-0.9:20200130-054708.log (dev-libs:libratbag-0.9:20200130-054708.log,10.02 KB, text/plain)
2020-01-30 19:14 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,156.01 KB, text/plain)
2020-01-30 19:14 UTC, Toralf Förster
Details
environment (environment,84.05 KB, text/plain)
2020-01-30 19:14 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,13.17 KB, application/x-bzip)
2020-01-30 19:14 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,20.99 KB, application/x-bzip)
2020-01-30 19:14 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-01-30 19:14:03 UTC
[7/31] x86_64-pc-linux-gnu-gcc -Ilur@sha -I. -I../libratbag-0.9 -I../libratbag-0.9/ -fdiagnostics-color=always -pipe -D_FILE_OFFSET_BITS=64 -std=gnu99 -Wno-unused-parameter -fvisibility=hidden -Wmissing-prototypes -Wstrict-prototypes -O2 -march=native -fno-common -fPIC -MD -MQ 'lur@sha/src_liblur.c.o' -MF 'lur@sha/src_liblur.c.o.d' -o 'lur@sha/src_liblur.c.o' -c ../libratbag-0.9/src/liblur.c
[8/31] x86_64-pc-linux-gnu-gcc  -o liblur.so.3.0.3 'lur@sha/src_liblur.c.o' -Wl,--as-needed -Wl,--no-undefined -shared -fPIC -Wl,--start-group -Wl,-soname,liblur.so.3 -O2 -pipe -march=native -fno-common -Wl,-O1 -Wl,--as-needed libutil.a libhidpp.a -Wl,--version-script,/var/tmp/portage/dev-libs/libratbag-0.9/work/libratbag-0.9/src/liblur.sym /usr/lib64/libudev.so -lm -Wl,--end-group '-Wl,-rpath,$ORIGIN/' -Wl,-rpath-link,/var/tmp/portage/dev-libs/libratbag-0.9/work/libratbag-0.9-build/
FAILED: liblur.so.3.0.3 
x86_64-pc-linux-gnu-gcc  -o liblur.so.3.0.3 'lur@sha/src_liblur.c.o' -Wl,--as-needed -Wl,--no-undefined -shared -fPIC -Wl,--start-group -Wl,-soname,liblur.so.3 -O2 -pipe -march=native -fno-common -Wl,-O1 -Wl,--as-needed libutil.a libhidpp.a -Wl,--version-script,/var/tmp/portage/dev-libs/libratbag-0.9/work/libratbag-0.9/src/liblur.sym /usr/lib64/libudev.so -lm -Wl,--end-group '-Wl,-rpath,$ORIGIN/' -Wl,-rpath-link,/var/tmp/portage/dev-libs/libratbag-0.9/work/libratbag-0.9-build/
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: libhidpp.a(src_hidpp-generic.c.o):(.bss+0x0): multiple definition of `gskill_driver'; libutil.a(src_libratbag-util.c.o):(.bss+0x0): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: libhidpp.a(src_hidpp-generic.c.o):(.bss+0x80): multiple definition of `roccat_driver'; libutil.a(src_libratbag-util.c.o):(.bss+0x80): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_systemd-20200126-201521

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

clang:
clang version 9.0.1 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/9/bin
llvm:
9.0.1
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.6
  [3]   python3.7 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.40.0 *
java-config:
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.242_p08 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm
ghc:
The Glorious Glasgow Haskell Compilation System, version 8.0.2

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Thu, 30 Jan 2020 03:26:22 +0000

emerge -qpvO dev-libs/libratbag
[ebuild  N    ] dev-libs/libratbag-0.9  USE="-doc -test"
Comment 1 Toralf Förster gentoo-dev 2020-01-30 19:14:06 UTC
Created attachment 608932 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-01-30 19:14:09 UTC
Created attachment 608934 [details]
dev-libs:libratbag-0.9:20200130-054708.log
Comment 3 Toralf Förster gentoo-dev 2020-01-30 19:14:12 UTC
Created attachment 608936 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2020-01-30 19:14:14 UTC
Created attachment 608938 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2020-01-30 19:14:18 UTC
Created attachment 608940 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-01-30 19:14:20 UTC
Created attachment 608942 [details]
temp.tbz2
Comment 7 Jeroen Roovers gentoo-dev 2020-05-15 08:02:04 UTC
*** Bug 721182 has been marked as a duplicate of this bug. ***