Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721180 - sys-apps/restartd-0.2.2-r1 : /.../ld: error: config.o: multiple definition of debug
Summary: sys-apps/restartd-0.2.2-r1 : /.../ld: error: config.o: multiple definition of...
Status: RESOLVED DUPLICATE of bug 707678
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-06 07:31 UTC by Toralf Förster
Modified: 2020-05-17 12:53 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.50 KB, text/plain)
2020-05-06 07:32 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,111.92 KB, text/plain)
2020-05-06 07:32 UTC, Toralf Förster
Details
environment (environment,50.15 KB, text/plain)
2020-05-06 07:32 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.96 KB, application/x-bzip)
2020-05-06 07:32 UTC, Toralf Förster
Details
sys-apps:restartd-0.2.2-r1:20200506-040618.log (sys-apps:restartd-0.2.2-r1:20200506-040618.log,3.88 KB, text/plain)
2020-05-06 07:32 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,13.54 KB, application/x-bzip)
2020-05-06 07:32 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-06 07:31:57 UTC
x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native  -falign-functions=32:25:16 -fno-common -c config.c
x86_64-pc-linux-gnu-gcc -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0 -o restartd main.o config.o
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: config.o: multiple definition of debug
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: main.o: previous definition here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: config.o: multiple definition of config_file
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: main.o: previous definition here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
clang version 10.0.0 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python3.8 (fallback)
  [3]   python2.7 (fallback)
  [4]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.252_p09 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Wed 06 May 2020 02:09:01 AM UTC

emerge -qpvO sys-apps/restartd
[ebuild  N    ] sys-apps/restartd-0.2.2-r1
Comment 1 Toralf Förster gentoo-dev 2020-05-06 07:32:00 UTC
Created attachment 636344 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-06 07:32:03 UTC
Created attachment 636346 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-06 07:32:05 UTC
Created attachment 636348 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-06 07:32:08 UTC
Created attachment 636350 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-06 07:32:11 UTC
Created attachment 636352 [details]
sys-apps:restartd-0.2.2-r1:20200506-040618.log
Comment 6 Toralf Förster gentoo-dev 2020-05-06 07:32:17 UTC
Created attachment 636354 [details]
temp.tbz2
Comment 7 Jeroen Roovers gentoo-dev 2020-05-17 12:53:26 UTC

*** This bug has been marked as a duplicate of bug 707678 ***