Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 707678 - sys-apps/restartd-0.2.2-r1 : fails to build with -fno-common or gcc-10
Summary: sys-apps/restartd-0.2.2-r1 : fails to build with -fno-common or gcc-10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL: https://sources.debian.org/patches/re...
Whiteboard:
Keywords: PATCH
: 721180 (view as bug list)
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-01-31 22:19 UTC by Toralf Förster
Modified: 2020-11-26 10:33 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.71 KB, text/plain)
2020-01-31 22:19 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,312.93 KB, text/plain)
2020-01-31 22:19 UTC, Toralf Förster
Details
environment (environment,51.03 KB, text/plain)
2020-01-31 22:19 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,18.80 KB, application/x-bzip)
2020-01-31 22:19 UTC, Toralf Förster
Details
sys-apps:restartd-0.2.2-r1:20200131-212337.log (sys-apps:restartd-0.2.2-r1:20200131-212337.log,3.36 KB, text/plain)
2020-01-31 22:19 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,13.87 KB, application/x-bzip)
2020-01-31 22:19 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-01-31 22:19:38 UTC
  296 |     system (config_process[i].not_running);
      |     ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native -fno-common -c config.c
x86_64-pc-linux-gnu-gcc -Wl,-O1 -Wl,--as-needed -o restartd main.o config.o
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: config.o:(.bss+0x1c): multiple definition of `debug'; main.o:(.bss+0x1c): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: config.o:(.bss+0x0): multiple definition of `config_file'; main.o:(.bss+0x0): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no-multilib-20200124-204141

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

clang:
clang version 9.0.1 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/9/bin
llvm:
9.0.1
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.7
  [3]   python3.6
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.40.0 *
java-config:
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.242_p08 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm
ghc:
The Glorious Glasgow Haskell Compilation System, version 8.0.2

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Fri, 31 Jan 2020 20:47:54 +0000

emerge -qpvO sys-apps/restartd
[ebuild  N    ] sys-apps/restartd-0.2.2-r1
Comment 1 Toralf Förster gentoo-dev 2020-01-31 22:19:40 UTC
Created attachment 610052 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-01-31 22:19:43 UTC
Created attachment 610054 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-01-31 22:19:46 UTC
Created attachment 610056 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-01-31 22:19:49 UTC
Created attachment 610058 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-01-31 22:19:52 UTC
Created attachment 610060 [details]
sys-apps:restartd-0.2.2-r1:20200131-212337.log
Comment 6 Toralf Förster gentoo-dev 2020-01-31 22:19:54 UTC
Created attachment 610062 [details]
temp.tbz2
Comment 7 Jeroen Roovers (RETIRED) gentoo-dev 2020-05-17 12:53:26 UTC
*** Bug 721180 has been marked as a duplicate of this bug. ***
Comment 8 Sam James archtester gentoo-dev Security 2020-10-31 06:12:32 UTC
Bump to 0.2.3 + https://sources.debian.org/patches/restartd/0.2.3-1.1/fix_ftbfs.patch/.
Comment 9 Larry the Git Cow gentoo-dev 2020-11-26 10:33:05 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=fd6ae80cf2f1191ee1504798257fe8efe26e7e9c

commit fd6ae80cf2f1191ee1504798257fe8efe26e7e9c
Author:     Jakov Smolic <jakov.smolic@sartura.hr>
AuthorDate: 2020-11-26 10:32:42 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2020-11-26 10:32:42 +0000

    sys-apps/restartd: fix build with gcc-10
    
    Closes: https://bugs.gentoo.org/707678
    Package-Manager: Portage-3.0.9, Repoman-3.0.1
    Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
    Signed-off-by: David Seifert <soap@gentoo.org>

 .../restartd/files/restartd-0.2.2-fno-common.patch | 66 ++++++++++++++++++++++
 sys-apps/restartd/restartd-0.2.2-r1.ebuild         |  5 +-
 2 files changed, 69 insertions(+), 2 deletions(-)