Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 72099 - module-init-tools-3.1 hangs while modprobing some modules
Summary: module-init-tools-3.1 hangs while modprobing some modules
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Robin Johnson
: 72513 72617 73174 (view as bug list)
Depends on:
Reported: 2004-11-22 10:17 UTC by Harris Landgarten
Modified: 2005-07-03 18:04 UTC (History)
15 users (show)

See Also:
Package list:
Runtime testing required: ---

modprobe snd-seq-oss strace output (modprobe.log,10.97 KB, text/plain)
2004-11-29 13:25 UTC, Herbie Hopkins (RETIRED)
kernel output (dmesg.log,1.74 KB, text/plain)
2004-11-29 13:26 UTC, Herbie Hopkins (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Harris Landgarten 2004-11-22 10:17:04 UTC
After emerging module-init-tools-3.1 system hangs on reboot. Hang occurs after modprobe tries to load snd-seq-oss. Could not boot until alsasound was removed from boot. After restart I tried to modprobe snd-seq-oss and it hung. I downgraded to 3.0-r2 and the problem resolved.

Reproducible: Always
Steps to Reproduce:
1.emerge module-init-tools
2.reboot or modprobe snd-seq-oss or /etc/init.d/alsasound restart
3.hand after trying to load snd-seq-oss

Actual Results:  
If boot system hangs.

Portage 2.0.51-r3 (default-linux/x86/2004.2, gcc-3.4.3, glibc-,
2.6.9-gentoo-r3 i686)
System uname: 2.6.9-gentoo-r3 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.6.6
distcc 2.18.2 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux26-headers-
Libtools: sys-devel/libtool-1.5.2-r7
CFLAGS="-O3 -march=pentium4 -fprefetch-loop-arrays -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config
/usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium4 -fprefetch-loop-arrays -pipe
FEATURES="autoaddcvs autoconfig ccache distcc distlocks sandbox sfperms"
USE="X acl acpi alsa apache2 apm arts avi berkdb bitmap-fonts bonobo cdr crypt
cups dba directfb dvd eds encode esd f77 fam flac foomaticdb fortran gd gdbm gif
gnome gpm gstreamer gtk gtk2 gtkhtml guile hal imagemagick imlib innodb java
jpeg kde ldap libg++ libwww mad mikmod milter mmx motif mozilla mpeg mysql
ncurses nls nptl odbc oggvorbis opengl oss pam pdflib perl png python qt
quicktime readline samba sasl sdl session slang spell sse ssl svga tcltk tcpd
tiff truetype userlocales x86 xml xml2 xmms xv zlib"
Comment 1 SpanKY gentoo-dev 2004-11-22 10:40:47 UTC
anything in `dmesg` ?

if you run `depmod ; modprobe snd-seq-oss` does it work ?
Comment 2 Harris Landgarten 2004-11-22 10:55:49 UTC
Nothing relavent in dmesg or /var/log/messages. The hang is before sysklogd loads.

depmod runs but modprobe snd-seq-oss still hangs hard.
Comment 3 Jordan 2004-11-22 22:20:25 UTC
same problem here, I just went nuts recompiling kernels and alsa-headers and such until I decided to check my emerge.log....oh hey look, new module-init-tools...I managed to get my system to boot despite the hang by pressing ctrl-c a whole bunch but obviously this doesn't really fix least I could get in to my system to fix things though.

It seems some modules have a slight delay loading/unloading other than snd-seq-oss but they don't hang. I'm not too sure what's causing this but I have it in my /etc/portage/package.mask for now...
Comment 4 boris64 2004-11-23 03:25:32 UTC
hi, same problem here.

system boot hangs while loading the alsasound-startscript.
downgrading module-init-tools and masking the new ebuild 
should be the safest solution for now.
Comment 5 Dietrich Heise 2004-11-23 14:51:27 UTC
same problem here,
system hangs while booting when modprobing snd-seq-oss :/
Comment 6 Timo Gurr (RETIRED) gentoo-dev 2004-11-24 14:04:28 UTC
same here (soundcard is a soundblaster live! if that matters).
Comment 7 Don Seiler (RETIRED) gentoo-dev 2004-11-24 18:56:05 UTC
Another 'me too'.  Posting this from links on the livecd while re-emerging 3.0-r2.  >:-(
Comment 8 Don Seiler (RETIRED) gentoo-dev 2004-11-24 19:04:17 UTC
Noticed that this didn't affect my box at work.  That box is on baselayout 1.11.x, my two home machines (that both got hung) are still on baselayout 1.10.x.  Might that be a culprit?
Comment 9 Donnie Berkholz (RETIRED) gentoo-dev 2004-11-24 22:11:31 UTC
sys-apps/baselayout-1.11.6-r1 and I hit it.
Comment 10 Ian Hastie 2004-11-25 19:43:30 UTC
Happens for me too with module-init-tools-3.1 with kernel 2.6.9-ac10 on AMD64.  No useful information in dmesg either.  Reverting to module-init-tools-3.0-r2 got it working again.
Comment 11 Peter Ruskin 2004-11-26 03:38:22 UTC
Another "Me too!".   After rebooting, having disabled alsasound and removed alsa stuff from /etc/modules.autoload.d/kernel-2.6, I ran `/sbin/modprobe snd-pcm-oss` from an xterm; the xterm froze hard but the module loaded - I could start another xterm and run `/usr/bin/asfxload /usr/share/sfbank/CT4MGM.SF2` successfully, 
which can only happen if snd-pcm-oss is loaded.
Comment 12 Aaron Walker (RETIRED) gentoo-dev 2004-11-26 04:54:45 UTC
*** Bug 72513 has been marked as a duplicate of this bug. ***
Comment 13 Eric Nylander 2004-11-28 17:02:59 UTC
Another 'me too' here as well.
It happens on both my x86 machine at work and my home AMD64 machines.
The work machine has an older SB Live sound card, and the home machine has an Audigy2 card.
Does anyone have the problem that doesn't use the emu10k1 soundcard driver?

Another workaround I found was to recompile the kernel without sequencer support, which is great if you don't need it.
Comment 14 Harris Landgarten 2004-11-28 19:37:53 UTC
I am running a Sound Blaster Live as well. I believe the problem goes beyond alsa. When module-init-tools-3.1 was installed, vmware would not run nor would it configure properly. Downgrading fixed that problem as well.
Comment 15 Lee Trager 2004-11-28 20:38:08 UTC
What is the problem with? Is it alsa-utils or module-init-tools? Downgranding module-init-tools seems to have fixed it for me.
Comment 16 Eric Nylander 2004-11-28 20:55:30 UTC
Interesting, I run vmware at work as well (x86 version) and didn't experience any issues with that. I only have issues with the sound drivers.
Comment 17 Herbie Hopkins (RETIRED) gentoo-dev 2004-11-29 01:51:08 UTC
Same here on amd64, the command "modprobe snd-seq-oss" hangs. I can see from another console that the module does get loaded it's just that the command never returns and so the init script never completes hence the hang at bootup.
Comment 18 Jure Repinc 2004-11-29 03:06:55 UTC
*** Bug 72617 has been marked as a duplicate of this bug. ***
Comment 19 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-11-29 11:14:25 UTC
I can't reproduce this on any on my x86 machines, or my little MIPS box (which is why I put 3.1 in the tree in the first place).

Trying to summarize this:
1. bug happens when module-init-tools-3.1 and alsa are used together.
2. on load of 'snd-seq-oss' or 'snd-pcm-oss', the modprobe call never returns.

Could somebody with the problem please compile a kernel with 

and then either
or your own selection of serial port options.

set up your machine to send kernel messages to netconsole or the serial port, and log them from another machine.

once you have the logging working right, emerge module-init-tools-3.1 on the machine with the debug kernel, and run 'strace -ff -o /tmp/modprobe.log modprobe seq-snd-oss' (it would probably be best to do this from pure console mode, no X).

once your box hangs, you should be able to try and get at it with the magic-sysrq, and get the output from 'P', 'T' and 'M', then force your hard drive to sync with 'S'. After this, you can try to recover and get out of the hang using some of the other magic-sysrq keys, but it'd be easier just to reboot to a livecd and put the old module-init-tools back on.

Doing all of this should send a LOT of debug data out, that I would like you to then attach here as a file, and also attach the /tmp/modprobe.log file here.

Comment 20 Herbie Hopkins (RETIRED) gentoo-dev 2004-11-29 12:40:49 UTC
Just to clarify, running modprobe snd-seq-oss does not make my box hang. It is mearly that the command never returns hence neither does the init script. If I remove the alsasound init script from my runlevel the box starts up normally, I can then run modprobe snd-seq-oss which will hang (just the command not the box). CPU usage remains normal and the command can be killed from another terminal. I'll try and and run a strace/ attach gdb to get some debugging info. Logging to another box should not be neccessary as my machine remains functional.
Comment 21 Herbie Hopkins (RETIRED) gentoo-dev 2004-11-29 13:25:33 UTC
Created attachment 44953 [details]
modprobe snd-seq-oss strace output
Comment 22 Herbie Hopkins (RETIRED) gentoo-dev 2004-11-29 13:26:58 UTC
Created attachment 44954 [details]
kernel output
Comment 23 Tom Coleman 2004-11-30 19:07:45 UTC
Same problem here -- also I thought I'd point out for the record, that it really seems like its modprobe that is acting strangly -- insmod snd-seq-oss works fine, and also modprobe is sucessfully installing the module before it hangs:

root@kofi tmc # lsmod | grep snd_seq_oss
root@kofi tmc # modprobe -v snd-seq-oss
insmod /lib/modules/2.6.9-gentoo-r1/kernel/sound/core/seq/oss/snd-seq-oss.ko
Terminated [Hung.. killed from another terminal]
root@kofi tmc # lsmod | grep snd_seq_oss
snd_seq_oss            31744  0
snd_seq_midi_event      6400  3 snd_seq_oss,snd_seq_midi,snd_seq_virmidi
snd_seq                49424  8 snd_seq_oss,snd_seq_midi,snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,snd_seq_midi_event
snd_seq_device          6536  7 snd_seq_oss,snd_seq_midi,snd_emu10k1_synth,snd_emux_synth,snd_seq,snd_emu10k1,snd_rawmidi
snd                    46436  18 snd_seq_oss,snd_emux_synth,snd_seq_virmidi,snd_seq,snd_emu10k1,snd_rawmidi,snd_pcm,snd_timer,snd_seq_device,snd_ac97_codec,snd_hwdep
root@kofi tmc # modprobe -vr snd-seq-oss
rmmod /lib/modules/2.6.9-gentoo-r1/kernel/sound/core/seq/oss/snd-seq-oss.ko
root@kofi tmc # lsmod | grep snd_seq_oss
root@kofi tmc # insmod /lib/modules/2.6.9-gentoo-r1/kernel/sound/core/seq/oss/snd-seq-oss.ko
root@kofi tmc # lsmod | grep snd_seq_oss
snd_seq_oss            31744  0
snd_seq_midi_event      6400  3 snd_seq_oss,snd_seq_midi,snd_seq_virmidi
snd_seq                49424  8 snd_seq_oss,snd_seq_midi,snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,snd_seq_midi_event
snd_seq_device          6536  7 snd_seq_oss,snd_seq_midi,snd_emu10k1_synth,snd_emux_synth,snd_seq,snd_emu10k1,snd_rawmidi
snd                    46436  18 snd_seq_oss,snd_emux_synth,snd_seq_virmidi,snd_seq,snd_emu10k1,snd_rawmidi,snd_pcm,snd_timer,snd_seq_device,snd_ac97_codec,snd_hwdep

hope that helps anyone
Comment 24 Vidar Skjelanger 2004-12-01 00:14:01 UTC
I had the same problem on startup with the hang on loading snd-oss-seq. I re-emerged alsa-driver (1.0.7-r1) and that fixed it for me. Also fixed another problem I was having with xmms segfaulting (see bug 72609).
Comment 25 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-12-02 15:37:04 UTC
*** Bug 73174 has been marked as a duplicate of this bug. ***
Comment 26 Ian Truelsen 2004-12-02 16:30:39 UTC
Downgraded module-init-tools to 3.0-r2 solved the problem for me as well.
Comment 27 Sylvain BERTRAND 2004-12-04 11:21:08 UTC
Another 'me too!'... but got even into additional trouble: all the i686-linux-gnu-*(modprobe lsmod etc...) symlinks were not set when emerging the module-init-tools 3.1... and it was complaining about "the old modeprobe not being available"... hope that helps... I revert to 3.0-r2... everything went back to normal.
Comment 28 Sylvain BERTRAND 2004-12-04 11:48:16 UTC
Oops! the hang when loading alse seq module went away when reverting to 3.0... but the symlinks issue was still here... investigating...
Comment 29 Benjamin Braatz 2004-12-07 08:10:52 UTC
I don't know if this has something to do with this bug, but I had random reboots during the filesystem check (

They went away after downgrading module-init-tools from 3.1 to 3.0-r2.

There is also someone in who has solved another reboot cycle (somewhere in clock/bootmisc) by downgrading.

Is this a new bug or does it belong here?
Comment 30 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-12-21 17:17:34 UTC
Just an update on this.
I think it's a kernel glitch, possibly in how modprobe is calling init_module, or in some library buried deep.

GDB backtrace:
(gdb) run
Starting program: /var/tmp/portage/module-init-tools-3.1/image/sbin/modprobe snd-seq-oss

Program received signal SIGSTOP, Stopped (signal).
0xffffe410 in ?? ()
(gdb) bt
#0  0xffffe410 in ?? ()
#1  0xbfffee38 in ?? ()
#2  0x0805c1f0 in ?? ()
#3  0x0000aaec in ?? ()
#4  0xb7f64f73 in init_module () from /lib/tls/
#5  0x0804ad8c in insmod (list=0xbfffeeb0, optstring=0x805c1f0 "", 
    newname=0x0, first_time=0, error=0x8049615 <fatal>, dry_run=0, verbose=0, 
    options=0x805c3e0, commands=0x805c640, ignore_commands=0, ignore_proc=0, 
    strip_vermagic=0, strip_modversion=0) at modprobe.c:783
#6  0x0804c8f3 in main (argc=2, argv=0xbffff1b4) at modprobe.c:1475

(the top frame there is SYSENTER_RETURN from the kernel).
Comment 31 Travis Mehrer 2004-12-25 08:04:46 UTC
Kernel 2.6.10 solved this issue for me, I had to re-emerge module-init-tools 3.1 to solve another module problem (nvidia-kernel with 2.6.10 & module-init-tools 3.0), and the new kernel resolved this issue for me.
Comment 32 Timo Gurr (RETIRED) gentoo-dev 2004-12-25 14:14:02 UTC
The most recent gentoo-dev-sources-2.6.10 fixed the issue with module-init-tools-3.1 for me, too.
Comment 33 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-12-26 18:36:59 UTC
does anybody with a 2.6.10 kernel still have this problem?
if not, I'll mark module-init-tools as needed a 2.6.10+ kernel, and close this bug.
Comment 34 Ian Truelsen 2004-12-26 22:38:14 UTC
The ALSA problem seems to be dealt with using 2.6.10 and module-init-tools 3.1. I do get a message on boot up about not being able to calculate module dependencies, but as no problems are apparent from this, I think I can live with it.
Comment 35 Colin Tinker 2005-01-02 14:05:07 UTC
Kernel 2.6.10 fixes this one for me.
Comment 36 J.O. Aho 2005-01-16 11:41:46 UTC
A couple of days ago I did update my alsa-utils from 1.0.6 to 1.0.7, after this my kenrle 2.6.9 didn't boot completly, got stuck at loading the snd-seq-oss, then a kernel panic due not being able to sync will appear.

I was lucky that I had already made a 2.6.10, this one booted copletly, but sadly I can't use it (emu10k1 don't compile and using the alsa-driver package leads to that the drivers crashes after a while). So I had somewhere to work, first I thougth it was udev that messed up things, removed udev, but no, didn't help, then removed the alsasound init script from my bootup and I could boot into 2.6.9 again. Running the alsasound init script manually lead to the same problem, but thans to "ps -ax" I did get to know what was modprobed and with what options.

modprobe -q -- snd_seq_oss

Trying different ways to do this manually lead to that the problem is really the name of the module, "snd_seq_oss", if you do a

modprobe -q -- snd-seq-oss

it seems to work for me. So I have made a small modification to the alsasound init script

---the original code---
                if [ ! "${DRIVER}" = off ] &&
                   [ -z `cut -d' ' -f1 /proc/modules | egrep "^${DRIVER}\$"` ] &&
                   [ -z `cut -d' ' -f1 /proc/modules | egrep "^${DRIVER//-/_}\$"` ]; then
--- eof ---

removing the last part of the if statement seems to fix the whole prolem for my 2.6.9

--- modified code ---
                if [ ! "${DRIVER}" = off ] &&
                   [ -z `cut -d' ' -f1 /proc/modules | egrep "^${DRIVER}\$"` ] ; then
--- eof ---

Now alsasound will load all the modules wihout any problems.
Comment 37 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2005-07-03 18:04:28 UTC
this doesn't seem to be applicable any more. it works fine on newer kernels.