Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 71944 - freelords does not show any text
Summary: freelords does not show any text
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Games
Depends on:
Reported: 2004-11-21 06:38 UTC by gunix
Modified: 2004-12-06 14:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description gunix 2004-11-21 06:38:48 UTC
When I use freelords 0.3.4 with paragui 1.0.4 I don't get any text in the dialogboxes and windows. No text at all. Everything else seems to be displayed as it should be. 
Any fix for this? 

Reproducible: Always
Steps to Reproduce:
Comment 1 Mr. Bones. (RETIRED) gentoo-dev 2004-11-22 14:15:49 UTC
reopen with the output of emerge --info and the output spit out when you try to
run freelords from the command-line.  Also, the output of the command "groups" and the command "which freelords".  Thanks.
Comment 2 Mr. Bones. (RETIRED) gentoo-dev 2004-12-04 15:39:44 UTC
No reply and works for me.  Closing.
Comment 3 gunix 2004-12-04 23:46:20 UTC
I'm truly sorry for not reporting this sooner. I forgot it. :-(

Here is emerge --info:
Portage 2.0.51-r3 (default-linux/x86/2004.0, gcc-3.3.4, glibc-, i686)
System uname: i686 AMD Athlon(tm) XP 2600+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux-headers-2.4.21-r1
Libtools: sys-devel/libtool-1.5.2-r7
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer -finline-functions -mmmx -m3dnow -msse"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer -finline-functions -mmmx -m3dnow -msse"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
USE="3dnow X Xaw3d aalib acl acpi adns alsa apache2 apm arts atlas avi berkdb bindist bitmap-fonts bonobo cdparanoia cdr crypt cscope cups curl dga doc dvd encode esd ethereal evo f77 fam fastcgi fb firebird flac foomaticdb fortran gcj gd gdbm ggi gif ginac gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile icq imagemagick imap imlib innodb jabber jack java jpeg junit kde lcms ldap lesstif libg++ libgda libwww mad maildir mbox mcal mikmod mmx motif mozilla mpeg mpi msn mysql nas ncurses nls odbc oggvorbis opengl oscar oss pam pdflib perl plotutils png postgres ppds python qt quicktime readline ruby samba sasl scanner sdl slang speex spell sqlite sse ssl svg svga tcltk tcpd tetex theora tiff truetype v4l v4l2 videos vmf wxwindows x86 xml xml2 xmms xv zlib"

$ groups
wheel audio cdrom video games cdrw users

$ which freelords

Running freelords:
Found configuration file: /usr/share/games/freelords/freelordsrc
/usr/share/games/freelords/freelordsrc: The file is not obfuscated, attempting to read it....
MESSAGE [12/05/2004 08:43:49] > added '/usr/share/games/freelords/' to the searchpath
MESSAGE [12/05/2004 08:43:49] > theme 'freelords.theme' loaded sucessfully
MESSAGE [12/05/2004 08:43:49] > defaultfont: default/Vera.ttf
MESSAGE [12/05/2004 08:43:49] > size: 16
Using resolution: 800x600

Pressing a button:
CreateScenario.cpp: 42: CreateScenario::CreateScenario
CreateScenario.cpp: 161: CreateScenario::setSize
QuestsManager.cpp: 142: QuestsManager: deleteInstance
armysetlist.cpp: 147: load_armyset()
/usr/share/games/freelords/army/default.xml: The file is not obfuscated, attempting to read it....
CreateScenario.cpp: 84: CreateScenario::setMaptype
GamePreferencesDialog.cpp: 36: GamePreferencesDialog()
Found  TileSet "default".
GamePreferencesDialog.cpp: 176: initGUI

and still not text.

Is the problem with freelords or can it be the fonts in X that are giving me a headace?
Comment 4 Mr. Bones. (RETIRED) gentoo-dev 2004-12-05 03:55:12 UTC
No text in the pulldown menus in game either?

Guess it could be a font config issue but from the output it seems to find everything it needs.  You could try compiling up paragui and freelords (and as much of the other stuff from emerge -evp freelords as you like) with CFLAGS="-pipe" and CXXFLAGS="-pipe" and see if that makes a difference.

You're going to have to be pretty proactive in tracking this down yourself I'm afraid since it works fine here and my setup is pretty similar except for your cflags.

just for more data, what are you using for X and the desktop?
Comment 5 gunix 2004-12-05 04:17:35 UTC
I'm using Xorg and fluxbox-0.9.8
Yes I suspect it is a font issue. No text anywhere in the menues.
Comment 6 gunix 2004-12-05 05:11:53 UTC
In bug #70760  I have reported another font problem, that program is also using the vera font. Seems strange. 
Comment 7 Mr. Bones. (RETIRED) gentoo-dev 2004-12-05 09:20:06 UTC
what's "locate -i /vera" show on your system?
Comment 8 gunix 2004-12-05 09:55:38 UTC
$ locate -i /vera |grep -v qcad-parts

Comment 9 gunix 2004-12-06 13:45:48 UTC
Problem solved!
I changed the build option for media-libs/freetype to disable "bindist", and now it works! Great!!
Comment 10 Mr. Bones. (RETIRED) gentoo-dev 2004-12-06 14:07:58 UTC
glad things are working for you.  nice work tracking that down.